VPN Error 691

Discussion in 'Windows Vista Networking' started by Alisha, Dec 3, 2007.

  1. Alisha

    Alisha Guest

    I have searched all over the Internet, unable to find anything to solve this
    problem. When trying to connect to a PPTP VPN, I get a 691 error.
    Username/password are fine, I can connect to the VPN on XP with no problem.
    I'm guessing that the reason is the authentication, but I don't know what to
    do to fix this.

    The VPN server uses MS-CHAPv1 and 40-bit encryption.

    If more information is needed, please let me know.
     
    Alisha, Dec 3, 2007
    #1
    1. Advertisements

  2. In most cases, VPN error 691 is security settings issue. Any errors in the
    VPN server Event Viewer?

    Vista VPN Issues
    Post Posted: Wed Feb 07, 2007 2:56 am Post subject: Solved: Vista VPN
    error 691, Reply with quote. I'm VPN'n into a customer network that there is
    no domain ...
    www.chicagotech.net/vista/vistavpn.htm - Similar pages

    VPN error 691
    I try to connect via vpn and dial-in and it give me an error 691 (user
    or password are ... VPN Error 691 - Access denied because username and/or
    password is ...
    www.chicagotech.net/Q&A/vpn43.htm


    --
    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on
    http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on
    http://www.HowToNetworking.com
     
    Robert L. \(MS-MVP\), Dec 3, 2007
    #2
    1. Advertisements

  3. Alisha

    Alisha Guest

    I don't have access to that unfortunately, because I work from home part-time
    and I'm not sure that anyone at work would want to try to fix this for just
    one person who uses Vista. And, they also don't have an IT person at this
    time.

    I will try to ask, but I can't say if they want to spend any time on this to
    help me out. I will reply back with an answer if I can get it.

    Thanks,
    Alisha
     
    Alisha, Dec 3, 2007
    #3
  4. Try also looking in your local event log... (Right Click on Computer
    and select Manage). You may have a more detail error message logged
    in the Applications or System Log...
     
    Jeffrey Randow, Dec 4, 2007
    #4
  5. Alisha

    Alisha Guest

    Thanks Jeffrey, but it tells me less than when the error shows up after
    trying to connect.

    CoID={9A171B52-48E9-4486-9D2C-3A515FA9EBAE}: The user pisrpls\Alisha dialed
    a connection named mySmartSim which has failed. The error code returned on
    failure is 691.

    Just today I had access to connect to another VPN and it also gave me the
    same error.
     
    Alisha, Dec 4, 2007
    #5
  6. Do a simple test. Just turn off windows firewall and any third party
    security software, then try the VPN. Can you do it?

    --
    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on
    http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on
    http://www.HowToNetworking.com
     
    Robert L. \(MS-MVP\), Dec 4, 2007
    #6
  7. Alisha

    Alisha Guest

    I already tried that, it gave me the same error.

     
    Alisha, Dec 4, 2007
    #7
  8. Alisha

    Kerry Brown Guest

    Is pisrpls the name of your computer, your home workgroup, the computer you
    trying to connect to, or the domain you are trying to connect to?
     
    Kerry Brown, Dec 4, 2007
    #8
  9. Alisha

    Alisha Guest

    It's the name of my computer.

     
    Alisha, Dec 4, 2007
    #9
  10. Alisha

    Kerry Brown Guest

    You have to specify the name of the computer or the name of the domain with
    your user name.

    e.g. domain_name\user_name

    or

    computer_name\user_name

    The user_name has to be a valid user account either in the domain or on the
    computer you are connecting to. If you don't specify this Vista uses your
    computer name as indicated in the error message. If you are connecting to
    work it's most likely a domain.
     
    Kerry Brown, Dec 4, 2007
    #10
  11. Alisha

    Alisha Guest

    I did set the domain when logging in with the username and password by using
    the domain text box below the password.
     
    Alisha, Dec 4, 2007
    #11
  12. Alisha

    Kerry Brown Guest

    The error message indicated that your local computer account was used. Try
    typing in the full user name as in domain\user. It may not be the problem
    but it will force the right credentials to be used eliminating one possible
    cause of the problem.
     
    Kerry Brown, Dec 4, 2007
    #12
  13. Alisha

    Alisha Guest

    I tried it just now, but it gave me the same error.
     
    Alisha, Dec 4, 2007
    #13
  14. Alisha

    Kerry Brown Guest

    OK we know that's not the problem then. When you said you could connect from
    an XP computer are the Vista and the XP computer both on the same network?
    Does one use wireless and one wired? What security software is installed on
    the Vista computer?
     
    Kerry Brown, Dec 5, 2007
    #14
  15. Alisha

    Kerry Brown Guest

    I just re-read all your posts and realised you are using MSChap V1. Vista
    doesn't work with MSChap V1.

    http://support.microsoft.com/kb/926170

    You could try setting the connection for Chap but I don't know if this will
    work.
     
    Kerry Brown, Dec 5, 2007
    #15
  16. Alisha

    Alisha Guest

    Yeah, I had tried Chap, but it didn't work. I really wish this worked,
    because it's a pain to have to run a virtual machine just so I can connect to
    work. It would be nice if there was a way around this, because I know the VPN
    server at work isn't going to be upgraded for just me.
     
    Alisha, Dec 5, 2007
    #16
  17. Alisha

    ChadJK Guest

    A couple of things to keep in mind with Vista VPN as compared to XP VP
    from my endless Googling on this issue

    MS CHAP v1 and PAP are disabled by default in Vista (they weren't i
    XP). This was done in favor of the more secure MS CHAP v2. You have t
    go under the Advanced settings under the Security tab in your VP
    connection's properties to enable them

    40 and 56-bit encryption for PPTP and L2TP connections have bee
    disabled by Vista (they weren't in XP) in favor of the more secur
    128-bit encryption and you have to modify the registry to re-enabl
    them. Go to HKLM\System\CurrentControlSet\Services\RasMan\Parameter
    and change the keys AllowL2TPWeakCrypto and AllowPPTPWeakCrypto to
    DWORD hex value of 1 and then restart Windows to enable them
     
    ChadJK, Apr 23, 2008
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.