W2K detects non-existent ports and BSOD's!! How to disable auto-detection?

Discussion in 'Windows Server' started by Roland Giesler, Jul 15, 2005.

  1. I have disabled COM1, 2 and LPT1 in my server's BIOS, to allow enough IRQ's
    to be available for two 3COM PCI internal modems in the machine. In the
    BIOS this appears correctly and it reports the devices. However, when W2K
    (fully patches with all SP's and hotfixes) starts it detects com1, com2 and
    lpt1 anyway, and then reports that the second modem has a problem. When I
    force the IRQ's, after disabling the incorrectly detected com and lpt ports,
    the machine crashes with a BSOD.

    I moved the modems to a totally different server (a dual 1GHz PIII server)
    and the problem is exactly the same, so my suspicion that the BIOS in the
    Dell PE1400 is the problem, was proven wrong. It's actually windows 2000
    server that stuffs this up.

    So my question is: Is it possible to tell W2K that no COM or LPT ports are
    installed? (ie I don't want auto-detection). I think then I'd be able to
    manually config the modems to work correctly. Of course I don't want the
    modems autodetected either...

    regards

    Roland Giesler
     
    Roland Giesler, Jul 15, 2005
    #1
    1. Advertisements

  2. Roland Giesler

    David Davis Guest

    Sounds like you are still having a IRQ conflict. Can you change the IRQ
    address on the other modems?
     
    David Davis, Jul 15, 2005
    #2
    1. Advertisements

  3. Clearly I do, but I cannot fix it. Consider what I've done to date:

    I booted safe mode and removed all modems and ports. Disabled the ports
    (Com1,2 and LPT1) in the BIOS.
    On normal startup the ports are immediately redetected and installed. One
    modem has an available IRQ and is fine, the other reports a problem (but not
    specifically a resource conflict)
    So I disabled the com and lpt ports in hardware manager.
    Still the modem doesn't work.
    If I then (with com1,2 and lpt1 disabled) choose a different IRQ for the
    modem, or a different port, the ports are available for selection. However,
    when select COM1 for a modem for example, and click apply, the machine
    crashes immediately.

    Both machines have identical behaviour, which leads me to believe it's a
    windows problem.

    I cannot assign the resources in Safe Mode, just enable/disable, so I have
    to boot normally to do that.

    that's about it till now.

    Roland
     
    Roland Giesler, Jul 15, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.