w32tm /tz command crash

Discussion in 'Windows Vista General Discussion' started by Steven Andrews, Nov 4, 2008.

  1. Hello all

    Vista Ultimate SP1 64bit. All updates available installed.

    Open either standard user command prompt or Elevated command prompt and type

    w32tm /tz

    Expected results: Details about the current time zones.
    Actual result is (3 lines then crash):

    Time zone: Current:TIME_ZONE_ID_UNKNOWN Bias: -600min (UTC=LocalTime+Bias)
    [Standard Name:"E. Australia Standard Time" Bias:0min Date:(unspecified)]
    [Daylight Name:"E. Australia Standard Time" Bias:0min Date:(unspecified)]

    Windows Time Service Diagnostic Tool has stopped working. "Check online
    for a solution and close the program" or "Close the program"

    Problem Details:
    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: w32tm.exe
    Application Version: 6.0.6001.18000
    Application Timestamp: 47919586
    Fault Module Name: StackHash_43c8
    Fault Module Version: 6.0.6001.18000
    Fault Module Timestamp: 4791adec
    Exception Code: c0000374
    Exception Offset: 00000000000a6e97
    OS Version: 6.0.6001.2.1.0.256.1
    Locale ID: 3081
    Additional Information 1: 43c8
    Additional Information 2: 7afb45e905daaea53e9fde9fbcd88b7d
    Additional Information 3: c33d
    Additional Information 4: d90c4059b89530e803820982645bbc4e

    Read our privacy statement:
    http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409


    The output is also different on XP SP3 than Vista SP1.
    The 3rd line: Daylight Name:"E.Australia Standard Time" Bias:0
    Date:(unspecified) on vista is reported as Bias:-60 on XP.

    This may be due a config error, but My time Zone is set correctly
    (Brisbane / Australia +10, no Daylight savings (Thats a whole different
    story - referendum? - PAH)) and this is reported in Vista.

    2 Questions
    1: Why the w32tm /tz crash on vista
    2: Why the difference in output between vista and XP?

    Steve
     
    Steven Andrews, Nov 4, 2008
    #1
    1. Advertisements

  2. I have since done some more testing:

    SBS2008 Premium reports the same error (except the OS Version is different)
    Vista 64bit SP1 reports the error
    Vista 32 pre SP1 reports the same error / different version numbers.

    I've logged it as a bug on connect.microsoft.com

    Steve
     
    Steven Andrews, Nov 5, 2008
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.