What causes this?

Discussion in 'Windows Vista Performance' started by Mason, Jul 22, 2007.

  1. Mason

    Mason Guest

    I have read that something happens to the OS that causes it to realize the
    restore points it has are not an accurate depiction of the volume it is
    supposed to be restoring, causeing the restore points to get erased. What
    causes that so I can stop my computer from erasing every damn restore point
    it makes.

    AS long as I don't shut down/restart the computer, they will stay
    indefinitely, I kept putting the computer in S3 sleep mode for a few weeks
    and all of the restore points (automatic or manual) stayed. As soon as I
    restarted due to the updates, they were all erased.

    I know that windows XP erases them, but I do not have windows XP installed,
    so please do not post links to the Windows XP fixes for this issue - they
    won't help.
     
    Mason, Jul 22, 2007
    #1
    1. Advertisements

  2. Mason

    Rick Rogers Guest

    Hi,

    Certain updates erase old restore points to prevent an attempt to revert to
    a state where an updated system file is not compatible. Now, if the restore
    points are wiped out on every reboot, that would be different, but if you
    are only restarting every couple of weeks then I would expect that one or
    more of the updates are erasing older points.
     
    Rick Rogers, Jul 23, 2007
    #2
    1. Advertisements

  3. Mason

    Mason Guest

    No, its every boot. I did that as an experiment to see if it was the reboot
    that did it or if it just happened. I have confirmed it was rebooting the
    computer... Every single time.

    I see on third party websites that it happens every so often with ultimate.
    (Which is what I have) and here is an error message that everyone gets, my
    self included, upon the automatic startup after restoring the system to what
    ever restore point was created earlier in the same windows session.

    It reads:

    There was an unexpected error.
    The parameter is incorrect. (0x80070057)
    Please close System Restore and try again.

    BUT, the restore is completed successfully, but the restore point gets
    erased, so there is no undoing the restore.
     
    Mason, Jul 23, 2007
    #3
  4. Mason

    Bob J Guest

    The attached KB 305193 in an explanation of the error, (info only) I would
    not consider attempting to repair unless you know absolutely what is required.
    Have you attempted to Restore as the error suggests?
    http://support.microsoft.com/kb/305193/en-us
    --
    Regards
    Bob J
    If advise given from anyone, solves problem or not, or if solved from
    another source,post back & let us know.
    Then we all benefit.
     
    Bob J, Jul 23, 2007
    #4
  5. Mason

    Rick Rogers Guest

    Hi Mason,

    When you state "everyone gets", do you mean all users of this machine? Or
    all users in a work environment? That error code can be associated with both
    the BITS and VSS services.
     
    Rick Rogers, Jul 23, 2007
    #5
  6. On Sun, 22 Jul 2007 20:01:40 -0400, "Rick Rogers"
    Eh? I thought the whole *point* of System Restore was the ability to
    roll back such updated files, and that we "need" System Restore in
    case an update screws up the system.

    So how we have updates that deliberately break your ability to undo
    them? Those wouldn't happen to be user-hostile pushware, such as
    WGA(N) and/or DRM revocations, would they?
    Sounds whiffy.

    If you unmask what AutoChk usually kills, buries and denies after it
    "fixes" things after bad exits, you will see that in XP, the \SVI gets
    shot to pieces on a regular basis. I often wonder how reliable it can
    be, in the following scenario:
    - something crashes the PC, forcing bad exits
    - the bad exits corrupt System Restore material in \SVI
    - you do a SysRestore to blindly "fix" whatever's crashing the PC

    So maybe Vista is aware that \SVI (or Vista's more hidden equivalent)
    is going to be trashed after bad exits, and silently purges it
    whenever AutoChk has run, or (more sophisticated) AutoChk reports it
    has "fixed" material within the SR store?

    Couple that with an ATX hassle that cuts power to the HD before it has
    flushed to platters, and you'd have your failure pattern.





    The most accurate diagnostic instrument
    in medicine is the Retrospectoscope
     
    cquirke (MVP Windows shell/user), Jul 23, 2007
    #6
  7. On Sun, 22 Jul 2007 19:00:00 -0700, Mason
    When you say "rebooting", do you mean:
    - Start, Shutdown, Restart
    - pressing the reset button on the case
    ?
    Hmm... another possible scenario suggests itself:
    - you have resident malware
    - this malware updates itself every X minutes
    - so it is permanently newer than your av, which can't detect it
    - but when your do a System Restore, the av jumps in...


    The most accurate diagnostic instrument
    in medicine is the Retrospectoscope
     
    cquirke (MVP Windows shell/user), Jul 23, 2007
    #7
  8. Mason

    Mason Guest

    No, when I say, "Everyone gets" I mean every person who posted a thread wth
    the same symptoms as me.
     
    Mason, Jul 24, 2007
    #8
  9. Mason

    Mason Guest

    I get the error after a restore. And, after getting the error, the computer
    has rebooted due to the restore process, and the restoe points are purged...
    There's my dilema
     
    Mason, Jul 24, 2007
    #9
  10. Mason

    Mason Guest

    I mean reboot as in, I close my session and shut the coputer down. The next
    day, i boot it up and all of the restore points I made were erased.

    ALSO, if I make a restore point, then hit start restart, they are erased.

    I do not know what the reset button will do. I always properly turn the
    computer off if I can help it.

    I don't think I have malware as this has been going on since the day that
    vista was put on this computer and I run scans for spyware, viruses, etc
    religiously using many different scanners: Norton Antivirus 2007, avg
    antispyware, Xoftspyse, and spybot S&D, all of which come up clean.
     
    Mason, Jul 24, 2007
    #10
  11. Mason

    Rick Rogers Guest

    Hi Mason,

    Run regedit, does this key exist?
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\SystemRestore

    If so, you may have a GP causing this problem. Export a copy of the key,
    then open it in notepad and copy/paste the results into a reply. Please ask
    if you need assistance with the steps.
     
    Rick Rogers, Jul 24, 2007
    #11
  12. On Mon, 23 Jul 2007 21:08:10 -0700, Mason
    Cool; much relief ;-)
    Do you see AutoChk running, "fixing" things? Mind you, Vista may hide
    that completely, in keeping with the whole "kill, bury, deny" thing.

    Have you looked at the Reliability logs? They're a great feature
    (basically, a better UI to functionality even more hidden in XP) that
    are still a bit hidden; type Reliability in the Start, Search...

    Look for failed shutdowns, etc.
    Seems consistent, if nothing else :-/
    I'm glad - I certainly wasn't advocating the Red Button :)
    OK, fair enough. I'm thinking about some sort of ATX thing that may
    be cutting into the last part of shutdown so that writes to the file
    system are never completed. Couple that with "kill, bury, deny"
    cleanup and you may have your failure pattern.

    Is it an old mobo? How's the ACPI support? Overclocking?
     
    cquirke (MVP Windows shell/user), Jul 24, 2007
    #12
  13. Mason

    Mason Guest

    No, it does not exist. Is it supposed to?

     
    Mason, Jul 25, 2007
    #13
  14. Mason

    Mason Guest

    I have checked the reliability log, and the only errors in there have to do
    with when I was working very hard at getting Nero 7 to work. No other errors
    other than that. Also in the other error log, there are many, but none
    relate to system restore. Even the error I get on restart after doing a
    restore wasn't there.

    This mother board is 14 months old. I actually have flashed it to try to
    clear up errors with the S3(str) suspend mode, it only sleeps for a few
    minutes before it comes out of sleep with nothing to cause this happening, so
    I am forced to always shut it down... Very disappointing.

    I am not sure what you mean by the ACPI support. What exactly do you want
    to know? I know it has something to do with CDROMs...

    No, there is no over clocking.

    If it helps, this computer was built with XP, and because I work in a
    computer store, I was kinda forced, as well as wanted to update to vista so
    that I can learn the ways we have to go about fixing it and how differently
    it works so I can give consumer demonstrations and sales. This computer ran
    with out hiccups for a full year until I installed vista two months ago. I
    mean zero problems.
     
    Mason, Jul 25, 2007
    #14
  15. Mason

    Rick Rogers Guest

    Hi Mason,

    No it shouldn't unless there is a group policy in place for System Restore,
    which is what I was checking for. Have you tried disabling your antivirus
    and any internet security program?
     
    Rick Rogers, Jul 25, 2007
    #15
  16. Mason

    Bert Kinney Guest

    Hi Mason,

    The loss of restore points (shadow copies) can be caused by utilities
    running at boot, and before Windows starts. Disk utilities would be the
    first thing to check.

    Related article.
    Shadow copies may be lost when you defragment a volume:
    http://support.microsoft.com/kb/312067

    Regards,
    Bert Kinney MS-MVP Shell/User
    http://bertk.mvps.org
    Member: http://dts-l.org
     
    Bert Kinney, Jul 26, 2007
    #16
  17. Mason

    Mason Guest

    Yep, already tried that too. I only NAV2007 not the firewall, just the plain
    jane anti virus because I read the norton internet security would cause that
    problem, so I figured that maybe NAV could too, but nope. didn't help.

    When I did it, there was NOTHING to do with symantec running on the
    computer. I cleared out both of its processes from the startup tab in
    MSCONFIG as well as all 7 of its services on the service tab. Nothing else
    like that runs, but here's a list of what does:

    ROBO Form (password/login saver)
    NAV2007
    Creative labs webcam manager
    Nero Back it up (Can't be this because I had the problem well before this
    was installed)
    AVG antispy (Same as with nero)

    and that is it.
     
    Mason, Jul 26, 2007
    #17
  18. Mason

    Mason Guest

    Never thought of looking there.

    I know that I have defrag automatically at 7 pm on Monday, but I wasn't sure
    that that was all. So I went to check, and here a few errors that I got from
    task scheduler.

    Upon opening task scheduler:

    An error has occurred for task reminders - Mason. Error message: The
    specified account name is not valid.

    If I click "Task Sheduler Library:"

    Catastrophic Failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))

    If I click ok, they allow me to go on into what ever it is that I wanted to
    see, but the problem is that I don't know whether it is letting me see the
    tasks or not because it is blank. It is very possible that it is blank b/c
    the only thing I had set to run was defrag, but I don't know if it is or not
    seeing as how I get this error message and the I cannot understand how to
    make a damn thing work in the new task schedler. The old one was just fine,
    why can't they leave anything alone?!
     
    Mason, Jul 26, 2007
    #18
  19. Mason

    Rick Rogers Guest

    I would disable NAV and AVG as well to test (and actually, if there is any
    hidden process involved in each, it may require uninstalling).
     
    Rick Rogers, Jul 26, 2007
    #19
  20. Mason

    Bert Kinney Guest

    Hi Mason,

    I would suggest stopping Defrag from running while troubleshooting the
    restore point problem.

    In the Event Viewer look for any VOLSNAP errors.

    Regards,
    Bert Kinney MS-MVP Shell/User
    http://bertk.mvps.org
    Member: http://dts-l.org
     
    Bert Kinney, Jul 26, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.