Why do I see a folder called Default and sub-folders from the XPmachines

Discussion in 'Windows Vista Networking' started by tek, Aug 5, 2008.

  1. tek

    tek Guest

    I just purchased a new Vista HP laptop from Compaq. The network is
    setup and working fine. I'm sharing folders across a mixed network of
    Linux and XP machines. I can access and mount my Vista shares to Linux
    and XP with no issues.

    There's just few querky things I noticed about sharing folders in
    Vista. I click to open "My Network Places" from a XP machine and I see
    two folders, one is "Users" and the other is "Default". First, I
    didn't actually tell Vista to share "Users" but I selected sub-folders
    underneath "Users" to share. Namely, "Contacts", "Favorites", and
    "Documents". I'm sharing these folders so I can back them up on the
    Linux machine. So from "My Network Places" on XP that's what I
    expected to see when I clicked open the Vista machine name but, I see
    "Users" first. I'm also sharing the "Windows Mail" folder for backup.
    So I also see each sub-folder name leading to "Windows Mail".

    In the XP world I would select a folder to share and give the share a
    name and it would be available with that share name under the machine
    name in "My Network Place" without any sub-folders being visible. Is
    this the new and improved Windows networking I have to live with?

    Secondly, at the same level of "Users" when I open the Vista namchine
    name in "My Network Places" I see the "Default" folder. I never
    understood why there is a "Default" user account ini Windows but
    that's another story. Why is this folder visible since I did nothing
    to share it?
     
    tek, Aug 5, 2008
    #1
    1. Advertisements

  2. There's a bug in Vista that causes it to share the entire Users folder
    when you tell it to share a sub-folder. Browse to the Users folder
    and un-share it, then follow these steps to share the desired
    sub-folders:

    1. Browse to a sub-folder and right-click it.
    2. Click Properties.
    3. Click the Sharing tab.
    4. Click Advanced Sharing.
    5. Put a check mark in the "Share this folder" box.
    6. Specify the share name.
    7. If desired, click Permissions and define access permissions.
    8. Click OK.
    9. Click Close.

    I don't know why your computer has a shared Default folder -- I don't
    see one on my Vista computers. Browse to the Default folder and
    un-share it.
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional Program
    http://mvp.support.microsoft.com
     
    Steve Winograd, Aug 5, 2008
    #2
    1. Advertisements

  3. tek

    tek Guest


    Thanks, I'll give your instruction a try. The Default folder is only
    seen when I access the Vista machine from My Network Places on the XP
    machine. How weird?
     
    tek, Aug 5, 2008
    #3
  4. tek

    tek Guest


    So basically I go to my XP machine, open My Network Places and find
    the Vista machine. I see the User folder and underneath is two more
    folders. First is the Default (user) folder and the other is Main
    (user) folder.

    example: \\Vistahp\Users\Default

    I can navigate into the Default folder and I see a number of files and
    folders. I did not set this up to be shared from Vista but its doing
    it any way. Must be another sharing bug. Let me add that on my XP
    machine my folder options are set to vie hidden system files and
    folders. I believe Default is a hidden folder on Vista but it
    shouldn't be shared unless I configure it that way,right?
     
    tek, Aug 5, 2008
    #4
  5. tek

    tek Guest


    Ack! It did't work. Well it half way worked. I'm able to create the
    share and it is displayed as \\vistahp\wmail which is what I wanted
    (excluding all the sub-folders) but when I try to access it I get the
    "permission denied... call your administrator..." donkey noise. The
    permissions on the share are set to everyone with full control too.

    Oh back to the Default folder. When I turned on view hidden folders/
    files from Vista I can see the Default folder within it's Network
    Places also including the Public folder. Although the Public folder
    isn't visible across the network. Seems like there plenty of security
    issues within networking that have to be resolved.
     
    tek, Aug 5, 2008
    #5
  6. tek

    tek Guest

    I decided to not worry about accessing the shares from XP. My main
    purpose is to be able to execute the backups to a Linux machines
    anyways. With Samba I can connect to the shares and mount them without
    any problems in reading the content of the folders as long as I
    connect using the logon/password of the Vista user on the Vista
    machine.

    From Linux my mount points are:
    //vistahp/contacts 144263668 41383192 102880476 29% /mnt/vistahp/
    contacts
    //vistahp/cookies 144263668 41383192 102880476 29% /mnt/vistahp/
    cookies
    //vistahp/corel 144263668 41383192 102880476 29% /mnt/vistahp/
    corel
    //vistahp/documents 144263668 41383192 102880476 29% /mnt/vistahp/
    documents
    //vistahp/favorites 144263668 41383192 102880476 29% /mnt/vistahp/
    favorites
    //vistahp/wmail 144263668 41383192 102880476 29% /mnt/vistahp/
    wmail

    Now I'm able to read these directoies and backup the data. And I don't
    have to worry about the sub-folders being visible within c:\users\Main

    Man, I hope MS resolves this soon and get back to the XP way of
    sharing, hehehehe.
     
    tek, Aug 6, 2008
    #6
  7. "Everyone" permission doesn't give universal access. The "Everyone"
    group only contains users who have an account on the Vista computer.
    Create user account(s) on Vista with the same user name(s) and
    password(s) that you use to log onto the other computer(s).
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional Program
    http://mvp.support.microsoft.com
     
    Steve Winograd, Aug 6, 2008
    #7
  8. Sharing a folder automatically makes its subfolders visible over the
    network.

    I suspect that there's a user account named "Default" on your Vista
    computer. That would create a "Default" folder under the "Users"
    folder, and the "Default" folder would contain folders named
    "Contacts", "Desktop", "Documents", "Download", etc.
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional Program
    http://mvp.support.microsoft.com
     
    Steve Winograd, Aug 6, 2008
    #8
  9. The reason that you can access Vista from Linux is that you log onto
    both of them with the same user name and password. You can access
    Vista's shares from XP, too, if you do either of these:

    1. Log onto XP with the same user name and password that you use to
    log onto Vista.

    or:

    2. Create a user account on Vista with the same user name and password
    that you use to log onto XP.
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional Program
    http://mvp.support.microsoft.com
     
    Steve Winograd, Aug 6, 2008
    #9
  10. tek

    tek Guest

    Maybe the Default folder location is related to the Guest user account?
     
    tek, Aug 6, 2008
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.