Why does "Restart later" keep prompting again and again and again

Discussion in 'Windows Update' started by adolf garlic, Oct 14, 2004.

  1. adolf garlic

    adolf garlic Guest

    I will restart later.
    Me.
    I choose.
    Stop keep prompting.
    I already chose!
    Windows Update I hate you.
    You are but a skid mark on the underpants of software development.
     
    adolf garlic, Oct 14, 2004
    #1
    1. Advertisements

  2. Nice little poem.

    I find this mildly annoying, too, but I don't let anything install
    automatically - just download & notify, so you can get some degree of
    control over this. Just install updates & reboot before lunch or dinner or
    something.
     
    Lanwench [MVP - Exchange], Oct 14, 2004
    #2
    1. Advertisements

  3. adolf garlic

    SkinsFan Guest

    Yes. I am experiencig this same problem. I CHOSE "d/l but let me choose
    ..." but yet it keeps prompting to restart now or later. I have programs
    running that I DON'T want to restart until I am done with them. If I
    walk away from the cpu for a few minutes, I'm afraid that it will reboot
    since I am not there to choose "restart later" and I will lose what I am
    NOT READY to close yet! If I CHOOSE to set ************MY*************
    computer to not restart until ***********************I******************
    press the damn restart button, then THAT'S the way the damn software
    should run!!!!!!!!!! I can find no way to set this thing so that it
    runs the way ****I**** want it too!

    Sheez, Redmond!! Is it now "All your base are belong to US?!"

    I understand that Redmond is trying to change the image that they don't
    care about security, but this is the sledgehammer approach, and if I
    CHOOSE to take "the risk" of restarting when I FELL LIKE IT, then that
    should be the way it runs!
     
    SkinsFan, Oct 14, 2004
    #3
  4. Mine nags me, but doesn't reboot on its own.
     
    Lanwench [MVP - Exchange], Oct 15, 2004
    #4
  5. adolf garlic

    Hokiefan Guest

    I had the same experience last night. I kept getting interrupted every five
    minutes to put off the countdown. On my work PC I was not so fortunate. I
    came in this morning to find that it had reset because of this "feature"
     
    Hokiefan, Oct 15, 2004
    #5
  6. adolf garlic

    Hokiefan Guest

    I may found the answer. A colleague of mine found this link that suggests
    the answer. However, in true MS fashion, there is a bug.

    http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2maint.mspx

    This link seems to correctly identify the problem but the solution is not in
    the correct location, near as we can tell.

    The correct location seems to be:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update

    With NoAutoRebootWithLoggedOnUsers set to one.

    This has not been tested yet so who knows if it will really work. Hope this
    helps.
     
    Hokiefan, Oct 15, 2004
    #6
  7. I checked, but I have "ForcedReboot", not "NoAuto..."
    ForcedReboot is set to 1. I would THINK that a value of 0 would be what I
    want, but any thoughts?
    ROb
     
    MrMoustacheMM, Oct 15, 2004
    #7
  8. Hi

    The registry setting below should disable the 5 minute countdown timer
    (to automatic reboot). Create a text file with file extension .reg
    and put the text below in it.

    ------------------ Start registry file -------------------
    REGEDIT4


    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "NoAutoRebootWithLoggedOnUsers"=dword:00000001


    ------------------ End registry file -------------------

    Applies to both Win2k and WinXP.

    For more information, see "Summary of behavior for
    NoAutoRebootWithLoggedOnUsers registry key settings" here:

    http://winservices.web.cern.ch/WinServices/docs/Internal/SUS/

    (should apply to Automatic Updates as well as SUS)

    Note that this setting is available as a Group Policy configuration
    for those running Active Directory.
     
    Torgeir Bakken \(MVP\), Oct 16, 2004
    #8
  9. Hi

    The registry setting below should disable the 5 minute countdown timer
    (to automatic reboot). Create a text file with file extension .reg
    and put the text below in it.

    ------------------ Start registry file -------------------
    REGEDIT4


    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "NoAutoRebootWithLoggedOnUsers"=dword:00000001


    ------------------ End registry file -------------------

    Applies to both Win2k and WinXP.

    For more information, see "Summary of behavior for
    NoAutoRebootWithLoggedOnUsers registry key settings" here:

    http://winservices.web.cern.ch/WinServices/docs/Internal/SUS/

    (should apply to Automatic Updates as well as SUS)

    Note that this setting is available as a Group Policy configuration
    for those running Active Directory.
     
    Torgeir Bakken \(MVP\), Oct 16, 2004
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.