Wifi doesn't work after waking up from "sleep" in Vista

Discussion in 'Windows Vista General Discussion' started by lemkepf, Mar 26, 2007.

  1. lemkepf

    lemkepf Guest

    Hello all,
    I just bought a new Inspirion 6400 with Vista basic pre-loaded. I
    close the lid and the laptop goes into vista's "sleep" mode... and
    then I open the lid a few minutes later; the WIFI doesn't want to
    reconnect. Sometimes it takes 30 seconds, sometimes it takes 5
    minutes, sometimes it doesn't want to reconnect at all.

    "Repairing" the connection sometimes fixes it... but most of the time
    it doesn't. As soon as I reboot the laptop it connects instantly.

    I've applied all patches and upgraded all drivers i could. I'm not to
    far away that it can't connect because of distance. I know the router
    itself isn't the issue as my friends Win XP laptop connects instantly
    every time. (My Wii works fine too. ) I've been scouring the net for
    any word on what the issue might be... i've seen some rumblings about
    issues with it but no solution.

    Does anyone know of a fix for this?

    Thanks, any help is appreciated!
     
    lemkepf, Mar 26, 2007
    #1
    1. Advertisements

  2. lemkepf

    Andy Guest

    OMG, I had a guy with a new Gateway come into my store the other day, SAME
    problem.

    Cold Boot into Vista, Wireless works and connects no problem.
    Go to Sleep/Hibernate. Come back in, nothing appears in available wirelsss
    even though the light is on indicating that the wireless connection is
    powered on.

    I actually had to restart his system to get wireless connections to
    re-appear. It didn't occur to me to try and "Repair" the connection, but
    toggling the power to the wireless connection didn't work either.

    Sounds like a Vista problem to me, oddly enough I think this was in Vista
    Basic as well. I can't recall which model he had, but could probably find it
    on the floor if you need it. Maybe some google searching is in order.

    andy at nortra-cables dot com
     
    Andy, Mar 26, 2007
    #2
    1. Advertisements

  3. lemkepf

    Shane Guest

    I found a setting under:

    ->Control Panel->System and Maintenance->system
    ->device manager

    right click on your wireless adapter and choose properties. I have an Intel 3945ABG, so your settings may differ, but I was able to change my "wireless mode" from A/B/G to just B/G. Since my Netgear WTG624 router is only cabable of 802.11 B/G, changing my wireless mode has seemed to fix my post-resume reconnection problem. I would suggest checking what modes your routers are broadcasting and compare that to your wireless adapter's mode.

    Hope this helps.

    EggHeadCafe.com - .NET Developer Portal of Choice
    http://www.eggheadcafe.com
     
    Shane, Apr 10, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.