Win7 and Wireless Network

Discussion in 'Windows 64 Bit' started by Mark H, Jun 12, 2009.

  1. Mark H

    Mark H Guest

    I'm new to the Win7 RC OS and wondering if anyone else is finding that their
    Linksys Wireless Network adapter is randomly disabled. All the other
    computers on my home network continue to function just fine on the web, but
    this Win7 x64 machine keeps shutting down the adapter. Once it shuts down,
    you can no longer shut down the computer either and some programs seem to
    "get stuck."

    All drivers are updated. No malware or spyware.
    9800GTX video card
    nForce mobo (M4N78 Pro)
    Linksys N wireless USB adapter
    Phenom II 940 (3.6Ghz)
    8GB ram

    Thanks.
     
    Mark H, Jun 12, 2009
    #1
    1. Advertisements

  2. What chipset is in that Linksys? If it's Broadcom based, it may well be a
    bad driver. (there _is_ a bad driver out there for Broadcom wireless that
    was causing major issues in my Ferrari for a while.)

    Did you check WU/MU for an updated driver? Or the linksys site?
     
    Charlie Russel - MVP, Jun 12, 2009
    #2
    1. Advertisements

  3. Mark H

    Charlie Tame Guest

    Also I had a couple of identical looking Linksys PCI cards which
    differed only by a minor version number (Only visible on the board
    itself), but they required different drivers. Ended up that one would
    work with 32 and 64 bit XP but not Vista, one would work with 32 bit
    Vista and 64 bit XP but not 32 bit XP and various combinations in
    between, I ended up buying another cheap card that worked with anything.
    Spent ages messing about before I spotted the hardware version
    difference.

    Since the OP mentions also that his device is USB I guess it's also
    possible that the MB maker has newer drivers for the USB system on the MB.

    While this may be irrelevant it does sound a bit like the random bad
    behavior I encountered and that was definitely driver related.
     
    Charlie Tame, Jun 12, 2009
    #3
  4. Mark H

    Barb Bowman Guest

    Barb Bowman, Jun 12, 2009
    #4
  5. Mark H

    Mark H Guest

    Thanks for the replies! They led me down the path to check model numbers in
    Linksys site for problems and found during this check that my USB Wireless
    stick should not be plugged into a hub port. (Even though the instruction
    manual shows it being plugged into a keyboard USB slot.) Apparently it's
    enough for the stick to "drop out".

    When I connected it directly into one of the USB ports on the back of the
    computer, it was instantly recognized and installed the WUSB600N driver
    version #2 instead of version #1.

    This version number is not written on the stick. Version 1 is a fairly
    rectangular flat stick, while version 2 is more tapered, end to end and
    front to back. So, by shape, I have version 1. Win7 is installing version 2.

    We'll give it a few days and see if the problem is cleared up.
     
    Mark H, Jun 12, 2009
    #5
  6. I am not sure that those numbers (#x) applies to versioning - it rather is a
    Windows installation enumeration label, meaning that it is the second
    installation so that you (the user) can differentiate between them. Writing
    a manual is known to be tricky. Good thing that the second install works
    better than the first one.

    :0)


    Tony. . .
     
    Tony Sperling, Jun 12, 2009
    #6
  7. Mark H

    Mark H Guest

    No, it actually has in the title:
    "Linksys WUSB600N Wireless-N USB Network Adapter with Dual-Band ver. 2"

    Originally this stated:
    "Linksys WUSB600N Wireless-N USB Network Adapter with Dual-Band ver. 1"

    I understand the enumeration thing your are mentioning that Windows does if
    it installs the same device twice. That looks like:
    "Linksys WUSB600N Wireless-N USB Network Adapter with Dual-Band ver. 2 #2"
    (I tried it to get the '#2' to show up.)
     
    Mark H, Jun 12, 2009
    #7
  8. Windows will decide which driver to use based on the PCI, VEN & SUBSYS
    information read from the device.

    The following is an example from my on-board Marvell Yukon 88E8056 PCI-E
    Gigabit Ethernet Controller: PCI\VEN_11AB&DEV_4364&SUBSYS_27001565&REV_13
     
    Bobby Johnson, Jun 12, 2009
    #8
  9. Hmmm - interesting, one of those where you need to put on your glasses.

    (Thats me looking like Inspector Closseau, stepping out of the broom
    closset!)


    Tony. . .
     
    Tony Sperling, Jun 12, 2009
    #9
  10. Mark H

    Mark H Guest

    Well, the "other" driver only partially worked.
    Looking farther, I found I may have skipped the obvious:

    Win7 renamed the GroupID back to WORKGROUP when installed instead of the
    GroupID the remainder of the network is using.

    So, not sure if this is the problem since I would have assumed that if it
    was able to connect in the first place, it would stay connected.
    Oh well, renamed to match the rest of the network. Will watch a little
    longer.
     
    Mark H, Jun 15, 2009
    #10
  11. Something is weird about your setup. WORKGROUP is no longer the default
    in Win 7. All my installations defaulted to HOMEGROUP. It makes it
    easy to share folders in a home network environment because you don't
    need a login on the other computers and some folders are just
    automatically shared when you "join" the HOMEGROUP from other Win 7
    computers.

    Also, if the GroupID was significant then you wouldn't be able to use
    WiFi in public places. WiFi is primarily concerned with the SSID of the
    Access Point.
     
    Bobby Johnson, Jun 15, 2009
    #11
  12. Mark H

    Mark H Guest

    Well, I won't be carting my desktop out into the public to test the
    significance of my GroupID :)-) but, Win7 did change the name to WORKGROUP.
     
    Mark H, Jun 15, 2009
    #12
  13. Mark H

    Mark H Guest

    In the Win7 forum, there was a general comment that Win7 installed by the
    upgrade path may have introduced the error. (Did Vista default to WORKGROUP?
    Is there some working part of Vista remaining that conflicts with Win7?)

    If I have to clean install to fix the problem, I'll probably just go back to
    my Vista backup until Win7's "ready" for primetime.
     
    Mark H, Jun 15, 2009
    #13
  14. But the SSID of the Access Point is the primary factor for a wireless
    connection, not the GroupID. The GroupID would be affect your
    connection to other computers.

    When I'm working on someone else's portable computer I never touch the
    GroupID to connect to my wireless router. The only things I set are the
    SSID and WPA2 password. That's why you GroupID shouldn't have anything
    at all to do with having internet access. The GroupID would be for
    seeing others on you network.
     
    Bobby Johnson, Jun 15, 2009
    #14
  15. Mark H

    Mark H Guest

    I was not trying to state that the GroupID was the problem, but that it
    defaulted to WORKGROUP was indication of a deeper issue.
     
    Mark H, Jun 15, 2009
    #15
  16. Mark H

    Mark H Guest

    Some searching on LinkSys site found an forum entry that basically stated
    this USB device has shown some problems with not be able to draw enough
    power through the USB port to maintain operational status. It may be fixed
    by moving it from USB port to USB port until you find one that holds it up.

    Sounds kind of flaky to me. So, maybe time to go find an internal card.
     
    Mark H, Jun 15, 2009
    #16
  17. Apologize. When I read your post I thought you were relating the two.
     
    Bobby Johnson, Jun 15, 2009
    #17
  18. Mark H

    Mark H Guest

    No problem. These things are easily confusing when discussed since the
    problem is not understood.
     
    Mark H, Jun 15, 2009
    #18
  19. Mark H

    Mark H Guest

    Just to provide closure to this issue:

    Installed an internal card and have had no more disruptions in my home
    network. Don't know how common this is with the USB type of plug-in
    adapter's and it may not be limited to network adapters. It appears that
    there is a limitation on how much juice the computer is designed to pour out
    of the USB ports and more ports may not be such a great thing.

    Not solved:
    Why did Win7 default the GroupID of the Network to WORKGROUP when I upgraded
    from VU x64 to Win7 x64?
    Why did Win7 recognize the network adapter as Version 1 when connected
    through a hub and Version 2 when connected to the back of the machine?
    (This one may have simply been that Win7 downloaded an update after
    installation.)
    After disabling the adapter, why the "lockup"?
    (This one is probably the driver, but indicates a more serious issue
    since Win7 could not shut it down to complete a shutdown either.)
     
    Mark H, Jun 16, 2009
    #19
  20. USB power from a standard port is up to 500mA, in units of 100mA, at 5V.

    It is unlikely that more than one device which needs power, not just
    data transfer, will work from a single port. If only one port is
    available, an external powered hub can be used: the power supply to this
    can provide 500mA to each port.

    To conserve battery power, laptops usually provide 500mA to be shared
    between all ports.

    Some devices will not work satisfactorily through a hub.

    Radio transmitter devices, such as net adapters, can easily be shielded
    by the metal and electromagnetic shielding in the computer case if
    placed at the back. Internal net adapters can draw more power than USB
    devices to compensate, but a cabled aerial gives more flexibility in
    positioning.

    Hubs and front USB ports have extra connections which can lead to power
    loss and may be USB1, not USB2, standard.


    Windows 7 provides homegroup networking, which is a significant change
    from previous versions of Windows. It can't guess what you want so
    defaults the workgroup name to WORKGROUP and prompts you for the type of
    network group you want the first time you log on after installation.
     
    Dominic Payer, Jun 16, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.