windbg: suppressing symbol search for modules - symsrv.ini?

Discussion in 'Windows Vista Drivers' started by Joerg Hoppe, Apr 25, 2007.

  1. Joerg Hoppe

    Joerg Hoppe Guest

    When working with windbg 6.6, I'm delayed because
    windbg tries to load symbols for lots of 3rd party modules
    at startup and at breakpoint stop. I tried to suppres symbol loading
    with an winsrv.ini-File, but this does not work.



    Output of windbg is like :
    *** ERROR: Module load completed but symbols could not be loaded for
    cmon.sys
    *** ERROR: Module load completed but symbols could not be loaded for
    VMparport.sys
    *** ERROR: Module load completed but symbols could not be loaded for
    vmx86.sys
    *** ERROR: Module load completed but symbols could not be loaded for EIO.sys
    *** ERROR: Symbol file could not be found. Defaulted to export symbols
    for atkosdmini.dll -
    *** ERROR: Symbol file could not be found. Defaulted to export symbols
    for atkosdmini.dll -
    .....


    symsrv.ini like this:

    [Exclusions]
    amdk8.*
    ati2cqag.*
    ati2dvag.*
    ati2mtag.*
    ati3duag.*
    atikvmag.*
    ativvaxx.*
    atkdisp.*
    .....


    I placed symsrvr.ini in the same directorie as symsrv.dll.
     
    Joerg Hoppe, Apr 25, 2007
    #1
    1. Advertisements

  2. Try disabling unqualified symbol loads (using -snul command line
    parameter, or .symopt+ 100). This should prevent windbg from
    trying to load symbols in the first place.

    --
    This posting is provided "AS IS" with no warranties, and confers no
    rights.

    "Joerg Hoppe" wrote:

    > When working with windbg 6.6, I'm delayed because
    > windbg tries to load symbols for lots of 3rd party modules
    > at startup and at breakpoint stop. I tried to suppres symbol loading
    > with an winsrv.ini-File, but this does not work.
    >
    > Output of windbg is like :
    > *** ERROR: Module load completed but symbols could not be loaded for
    > cmon.sys
    > *** ERROR: Module load completed but symbols could not be loaded for
    > VMparport.sys
    > *** ERROR: Module load completed but symbols could not be loaded for
    > vmx86.sys
    > *** ERROR: Module load completed but symbols could not be loaded for
    > EIO.sys
    > *** ERROR: Symbol file could not be found. Defaulted to export symbols
    > for atkosdmini.dll -
    > *** ERROR: Symbol file could not be found. Defaulted to export symbols
    > for atkosdmini.dll -
    > ....
    >
    >
    > symsrv.ini like this:
    >
    > [Exclusions]
    > amdk8.*
    > ati2cqag.*
    > ati2dvag.*
    > ati2mtag.*
    > ati3duag.*
    > atikvmag.*
    > ativvaxx.*
    > atkdisp.*
    > ....
    >
    >
    > I placed symsrvr.ini in the same directorie as symsrv.dll.
     
    Pavel Lebedinsky [MSFT], Apr 27, 2007
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. zarbiker

    Suppressing a Vista event logging request

    zarbiker, Jan 12, 2008, in forum: Windows Vista Performance
    Replies:
    0
    Views:
    439
    zarbiker
    Jan 12, 2008
  2. Keith Patrick

    Suppressing Welcome screen (and password entry) on wakeup from sleep

    Keith Patrick, Jun 12, 2007, in forum: Windows Vista General Discussion
    Replies:
    4
    Views:
    440
    ...winston
    Jun 14, 2007
  3. Greg3D
    Replies:
    5
    Views:
    441
    Arjan
    Oct 18, 2008
  4. Windbg symbol path

    , Sep 30, 2005, in forum: Windows Vista Drivers
    Replies:
    3
    Views:
    962
  5. RossettoeCioccolato

    suppressing /hotpatch in ddk build environment

    RossettoeCioccolato, Jan 3, 2006, in forum: Windows Vista Drivers
    Replies:
    10
    Views:
    526
    RossettoeCioccolato
    Jan 20, 2006
  6. KMDF_FW

    error 0x1 when downloading symbol in Windbg?

    KMDF_FW, Mar 20, 2006, in forum: Windows Vista Drivers
    Replies:
    0
    Views:
    382
    KMDF_FW
    Mar 20, 2006
  7. vwbug
    Replies:
    0
    Views:
    574
    vwbug
    Jun 6, 2008
  8. Inetimon
    Replies:
    5
    Views:
    446
    Al Dunbar [MS-MVP]
    Feb 3, 2007
Loading...