windbg: suppressing symbol search for modules - symsrv.ini?

Discussion in 'Windows Vista Drivers' started by Joerg Hoppe, Apr 25, 2007.

  1. Joerg Hoppe

    Joerg Hoppe Guest

    When working with windbg 6.6, I'm delayed because
    windbg tries to load symbols for lots of 3rd party modules
    at startup and at breakpoint stop. I tried to suppres symbol loading
    with an winsrv.ini-File, but this does not work.



    Output of windbg is like :
    *** ERROR: Module load completed but symbols could not be loaded for
    cmon.sys
    *** ERROR: Module load completed but symbols could not be loaded for
    VMparport.sys
    *** ERROR: Module load completed but symbols could not be loaded for
    vmx86.sys
    *** ERROR: Module load completed but symbols could not be loaded for EIO.sys
    *** ERROR: Symbol file could not be found. Defaulted to export symbols
    for atkosdmini.dll -
    *** ERROR: Symbol file could not be found. Defaulted to export symbols
    for atkosdmini.dll -
    .....


    symsrv.ini like this:

    [Exclusions]
    amdk8.*
    ati2cqag.*
    ati2dvag.*
    ati2mtag.*
    ati3duag.*
    atikvmag.*
    ativvaxx.*
    atkdisp.*
    .....


    I placed symsrvr.ini in the same directorie as symsrv.dll.
     
    Joerg Hoppe, Apr 25, 2007
    #1
    1. Advertisements

  2. Try disabling unqualified symbol loads (using -snul command line
    parameter, or .symopt+ 100). This should prevent windbg from
    trying to load symbols in the first place.
     
    Pavel Lebedinsky [MSFT], Apr 27, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.