Window blocked startup programs

Discussion in 'Windows Vista Security' started by Tim, Apr 4, 2007.

  1. Tim

    Tim Guest

    When I start Vista, I always get a popup that says Windows blocked some
    startup programs. When I go into Windows Defender to find out what is
    being blocked, I get the list of programs loaded at startup, and each is
    either designated "Permitted" or "Not yet classified." Even the "Not yet
    classified" programs are being loaded. So how do I find out which ones
    Windows is blocking?
     
    Tim, Apr 4, 2007
    #1
    1. Advertisements

  2. Tim

    Dave Guest

    Have you used msconfig to stop some programs?
    I have, and that's what causes the message, not Defender.
     
    Dave, Apr 4, 2007
    #2
    1. Advertisements

  3. There's a menu item on the icon that lets you start blocked programs.

    It was msconfig in my case as well, which I used to turn off a bunch of junk
    that came bundled with my Dell.

    Anthony Wieser
    Wieser Software Ltd
     
    Anthony Wieser, Apr 4, 2007
    #3
  4. Tim

    Rock Guest

    Click on the icon on the notification area and select the option to have it
    display the blocked program(s) so you can give it permission to run. Any
    program that runs at startup that either needs admin privileges or for which
    you marked it as Run as Administrator will be blocked at startup until you
    give permission.

    So you need to ask yourself, first do you need that program to run at
    startup? If so does it have to have admin privileges? Is there an update
    for it that allows it to run without admin privileges? Is there another
    program that will do the trick that doesn't need admin privileges.

    This happens with msconfig when you make a change in it and then reboot.
     
    Rock, Apr 5, 2007
    #4
  5. Tim

    Tim Guest

    Yes, it was apparently msconfig that is causing this. Since I don't need to
    be notified every bootup of this condition, how do I turn off the popup?
     
    Tim, Apr 5, 2007
    #5
  6. Tim

    Rock Guest

    Just like you did in XP when it popped up with the one added step. First
    unblock it so it can. Do this by an option from clicking on the icon in the
    notification area. Then when msconfig comes up check the box to not have it
    display. It won't until the next time you make changes with msconfig and
    reboot.
     
    Rock, Apr 5, 2007
    #6
  7. Tim

    Tim Guest

    No, that's doesn't solve the problem. I have always checked the box to not
    have msconfig display after I have made changes. But I still get the popup
    box saying Windows blocked some startup programs.
     
    Tim, Apr 5, 2007
    #7
  8. Tim

    mikeyhsd Guest

    it is MSCONFIG causing the problem most likely.
    using MSCONFIG to block startup program is not the best way.
    you should try to use the OPTIONS/PROPERTIES of the individual programs to prevent them from loading with windows.








    No, that's doesn't solve the problem. I have always checked the box to not
    have msconfig display after I have made changes. But I still get the popup
    box saying Windows blocked some startup programs.
     
    mikeyhsd, Apr 5, 2007
    #8
  9. Tim

    Rock Guest

    So you're saying it's more than just msconfig? Any program that runs at
    startup requesting admin privileges or which you specify to run that way by
    checking the Run as Administrator box will be blocked until you give it
    permission. You click the icon in the notification area, and unblock it
    from there.

    You need to ask some questions. Why does this program need admin
    privileges? Does it has to have them? If not then uncheck run as
    administrator. If it needs admin privileges, why? Is there an update for
    it that doesn't need them? Is there a different program to use in place of
    it that's properly coded for Vista? Does it have to run at startup?

    Also see this link for one way to deal with this issue.
    http://blog.gerke-preussner.de/inde...cking-Elevated-Startup-Programs-in-Vista.html
     
    Rock, Apr 6, 2007
    #9
  10. Tim

    Olly Guest

    Have you been into msconfig ? type msconfig in search click on the file look
    in start
    up programes make sure they are all checked.
     
    Olly, Apr 7, 2007
    #10
  11. Tim

    LoneStar Guest

    I think the main issue at this point is not the blocked startup programs but getting rid of the notification that lives in the notification area, forever.

    EW

    it is MSCONFIG causing the problem most likely.
    using MSCONFIG to block startup program is not the best way.
    you should try to use the OPTIONS/PROPERTIES of the individual programs to prevent them from loading with windows.








    No, that's doesn't solve the problem. I have always checked the box to not
    have msconfig display after I have made changes. But I still get the popup
    box saying Windows blocked some startup programs.
     
    LoneStar, Apr 11, 2007
    #11
  12. Tim

    LoneStar Guest

    I have the same situation. Your solution does no good and I've tried
    (almost) everything to keep the pop-up from appearing and staying in the
    notification area: right clicking, msconfig, etc. Or perhaps I don't get
    exactly what you're saying.

    Of course, I didn't have this notification after I first got my new Vista
    computer, but after I disabled several garbage entries in msconfig, the
    notification about "some items have been blocked..." keeps coming back every
    bootup and stays during the entire up-time.

    Nevertheless, Vista is excellent!

    EW
     
    LoneStar, Apr 11, 2007
    #12
  13. Tim

    LoneStar Guest

    SNIP.................

    You're a valuable MVP, but.................. The question/issue is THE POPUP
    NOTIFICATION THAT APPEARS EVERY BOOTUP, not the actual blocked programs!
    Many of us are asking how to keep the notification from appearing always --
    we don't need it to remind us of which programs we blocked from starting.

    Maybe we're not being clear enough. We simply want the notification to
    stop!

    Thanks.
     
    LoneStar, Apr 11, 2007
    #13
  14. Tim

    mikeyhsd Guest

    then I believe you need to cure the problem that is causing the NOTIFICATION.








    SNIP.................

    You're a valuable MVP, but.................. The question/issue is THE POPUP
    NOTIFICATION THAT APPEARS EVERY BOOTUP, not the actual blocked programs!
    Many of us are asking how to keep the notification from appearing always --
    we don't need it to remind us of which programs we blocked from starting.

    Maybe we're not being clear enough. We simply want the notification to
    stop!

    Thanks.
     
    mikeyhsd, Apr 11, 2007
    #14
  15. Tim

    LoneStar Guest

    Great. Thanks..... It's not a "problem," it's a feature. And others and I are asking for the "cure."

    then I believe you need to cure the problem that is causing the NOTIFICATION.








    SNIP.................

    You're a valuable MVP, but.................. The question/issue is THE POPUP
    NOTIFICATION THAT APPEARS EVERY BOOTUP, not the actual blocked programs!
    Many of us are asking how to keep the notification from appearing always --
    we don't need it to remind us of which programs we blocked from starting.

    Maybe we're not being clear enough. We simply want the notification to
    stop!

    Thanks.
     
    LoneStar, Apr 12, 2007
    #15
  16. Tim

    Rock Guest

    Sigh, if a program running at startup, either through one of the run keys in
    the registry or the Startup folder, requests admin privileges then it will
    need permission. There is no way around it. This is to ensure that you
    intended it to run with admin privileges. Personally I would strongly
    question why a program needs to run at startup that needs admin privileges.

    In any event here is a link to one work around using scheduled tasks.

    http://blog.gerke-preussner.de/inde...cking-Elevated-Startup-Programs-in-Vista.html
     
    Rock, Apr 12, 2007
    #16
  17. Tim

    Tim Guest

    All of this discussion and still no real answer. Apparently, we must live
    with this popup box indefinitely, or unless Microsoft ultimately fixes the
    issue. As for your recommendation to remove programs that require admin
    privileges at startup, my problem is that Windows Defender does not identify
    which programs those are! According to it, all programs are either
    permitted or not yet classified - none are being blocked. So, how do I
    actually do what you're recommending?
     
    Tim, Apr 12, 2007
    #17
  18. Tim

    Rock Guest

    When the icon appears in the notification area you click on it, and pint to
    the run blocked program option to see what program(s) was blocked and give
    it permission to run if you want.

    Error message when you reach the Windows Vista Desktop: "Windows has blocked
    some startup programs"
    http://support.microsoft.com/kb/930367/en-us

    I also posted a workaround in the post to which you replied.
     
    Rock, Apr 12, 2007
    #18
  19. Tim

    LoneStar Guest

    Rock.......... thanks for the info and the link. However, I don't think Tim
    and I are being understood at all. The problem IS the NOTIFICATION ICON,
    nothing else. We don't need or want it popping up continuously, and there
    seems to be no way to get rid of it. As Tim said, we'll just have to live
    with this indefinitely, or until someone really understands the question.

    If you really want to see what we're talking about, uncheck some of your
    startup items using msconfig. The next time you boot up, you'll see this
    stupid notification which really means nothing!

    Anyway, thanks Rock for your help. Keep up the fine work.

    EW
     
    LoneStar, Apr 12, 2007
    #19
  20. Tim

    mikeyhsd Guest

    in you example of using msconfig to disable some startup items is what causes the icon.
    why, probably because msconfig requires uac approval to run.
    try running msconfig using the RUN box and see.

    it is one of the defects in UAC to not have a method to permanently allow programs to run.
    it was apparently impossible for ms programmers to tell the difference in keyboard command and programmed command.

    the solution is simple, do not use MSCONFIG for a permanent solution to startup program control.








    Rock.......... thanks for the info and the link. However, I don't think Tim
    and I are being understood at all. The problem IS the NOTIFICATION ICON,
    nothing else. We don't need or want it popping up continuously, and there
    seems to be no way to get rid of it. As Tim said, we'll just have to live
    with this indefinitely, or until someone really understands the question.

    If you really want to see what we're talking about, uncheck some of your
    startup items using msconfig. The next time you boot up, you'll see this
    stupid notification which really means nothing!

    Anyway, thanks Rock for your help. Keep up the fine work.

    EW
     
    mikeyhsd, Apr 12, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.