Window could not search for new update-Solutions (OS: window vista

Discussion in 'Windows Update' started by Okky Hendra, Jan 17, 2008.

  1. Okky Hendra

    Okky Hendra Guest

    To all whoever have this problem,

    Below are some solutions which microsoft support section sent me to my email.

    Credit goes to them and in no way I am taking credit for these solutions.

    1. Disable any Firewall, Antivirus, download accelerator software.

    Firewalls and Antivirus programs are 3rd Party (non-Microsoft) Programs, and
    although they are mostly effective in protecting your computer from Viruses
    and Computer hackers, they do fail to take into consideration program
    installations. The nature of these programs is that they scan everything on
    the computer, making sure to try and stop any virus-like activity.



    When you visit Windows Update and download, and most importantly install any
    of the updates, the update installation is always battled by the Antivirus
    and Firewall until the Antivirus clears the program of being a virus. In most
    cases, this is harmless and the Update installation goes through
    successfully. Occasionally, the Installation gets corrupted, and a process
    during the install is stopped, or interfered with by the Antivirus product.



    For this reason, we suggest that you disable any Antivirus or Firewall
    software while trying to install updates from Windows Update.



    2. Verify the Language Settings

    2.1. Start Internet Explorer.

    2.2. Click "Tools", and then click "Internet Options".

    2.3. Click the "General" tab, and then click "Languages".

    2.4. In the "Language" list, make sure that the operating system language
    version is included. If the operating system language version is not on the
    list, click "Add", click the language in the "Language" list, click "OK",
    click "OK", and then click "OK" again.



    3. Reset Internet Zone Security

    3.1. Start Internet Explorer.

    3.2. Click "Tools", and then click "Internet Options".

    3.3. Click the "Security" tab, and then in the" Select a Web content zone to
    specify its security settings" box, click "Internet".

    3.4. Click "Default Level", and then click "Apply" to set this zone to
    Medium security.

    3.5. Click "OK".



    4. Verify that the Date and Time Are Set Correctly

    4.1 In the bottom right corner of your screen, double click the time. This
    will open the Date and Time Properties window.

    4.2 Please check that all details are correct including the year, the Time
    zone and that AM/PM is set correctly.

    4.3 Click OK.



    If the problem persists despite performing above troubleshooting steps, I'd
    like you to perform below guidelines to download and install a new Windows
    Update Agent as the current one might be corrupted.



    1. Please click on below link depending on which version of Windows your
    computer is running. To find the bit version of Windows, please visit
    http://support.microsoftcom/kb/827218/



    Windows Vista

    ----------------

    32 Bit

    -
    http://download.windowsupdate.com/v7/windowsupdate/redist/standalone/WindowsUpdateAgent30-x86.exe



    64 Bit

    -
    http://download.windowsupdate.com/v7/windowsupdate/redist/standalone/WindowsUpdateAgent30-x64.exe



    2. A box will prompt to save the Windows Update Agent file, save it on the
    Local C: drive.

    3. Click Start, on Start Search, type cmd, right click command prompt icon
    and Run as Administrator.

    4. Type c:\WindowsUpdateAgent30-x86.exe in the command prompt and Enter.

    Note: Replace "WindowsUpdateAgent30-x86" with relevant file name
    according to the version that you downloaded.

    5. Follow the instructions to install the Windows Update Agent.

    6. Please restart the computer after the installation.

    7. After restarting the PC, click on Start and choose Windows Update and it
    will open a new Internet browser.

    8. A box will prompt asking permission to install the Windows Update
    software, click Install and proceed to download the updates.


    If it is still not resolved, please follow below guidelines.


    1. Click on Control Panel (Classic View) > Network and Sharing Center >
    Manage Network Connections > Local Area Connection > Right Click and click on
    Properties.

    2. Double-click Internet Protocol Version 4 >Mark the Use the following DNS
    Server Addresses.

    3. Set the IP Addresses for "Preferred DNS Server" as 4.2.2.2 and for
    "Alternate DNS Server" as 4.2.2.3 and click OK.

    This is in response to the thread I put on few days ago. Since it's already
    quite old and people may not see it I've decided to put this in a new post.

    Once again, the above solutions are the one given to me from microsoft
    support sections after I mailed them my problem.

    In no way I am taking credit for the above solutions. I am just posting them
    to help people that are having the same problem as me.

    Cheers,

    Okky Hendra
     
    Okky Hendra, Jan 17, 2008
    #1
    1. Advertisements

  2. Original thread:
    http://groups.google.com/group/micr..._frm/thread/ee99fa778cd60a39/4d680b3ad8022dbc

    Which of these addressed your problem, Okky?

    What anti-virus application and third-party firewall (if any) is installed?
    *NB: If you disable a third-party firewall, make sure you enable the Windows
    Firewall!*

    I find it very irresponsible of MS PSS Support not to state the above in the
    canned reply. And if one disables the anti-virus application, one should be
    advised to use /extreme/ caution when the machine's in this state: Don't do
    *anything* else online (i.e., browsing to other sites; checking email;
    chatting) other than going to Windows Update website. Also make absolutely
    certain that you re-enable the anti-virus application immediately after
    updating successfully.
     
    PA Bear [MS MVP], Jan 17, 2008
    #2
    1. Advertisements

  3. Okky Hendra

    Okky Hendra Guest

    The solution that solved my problem is the last one whereby they told me to
    change my DNS adresses.

    1. Click on Control Panel (Classic View) > Network and Sharing Center >
    Manage Network Connections > Local Area Connection > Right Click and click on
    Properties.

    2. Double-click Internet Protocol Version 4 >Mark the Use the following DNS
    Server Addresses.

    3. Set the IP Addresses for "Preferred DNS Server" as 4.2.2.2 and for
    "Alternate DNS Server" as 4.2.2.3 and click OK.

    Cheers,

    Okky
     
    Okky Hendra, Jan 17, 2008
    #3
  4. Okky Hendra

    nmc Guest

    All I manage to get is : "Windows update agent has encountered an
    unrecoverable error".

    I don't know if you met this at all. Thanks for the most informative advice
    I have seen on this subject.
     
    nmc, Jan 17, 2008
    #4
  5. Thank you very much, Okky.

    [Another Wareout infection?]
     
    PA Bear [MS MVP], Jan 18, 2008
    #5
  6. Thanks for trying to help - I received "fatal error - unrecoverable error"
    attempting the install of the new Update Agent. None of the other suggestions
    worked. I have followed about twenty of the various suggestions, all to no
    avail. My Visa Ultimate system is over a year old and the "can't check for
    updates" began in mid-february! Prior to that, all was fine!
     
    I have a problem!, Mar 26, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.