Windows 2000 Pro - All Updates Fail!!!

Discussion in 'Windows Update' started by Tbenson81, Aug 6, 2005.

  1. Tbenson81

    Tbenson81 Guest

    Ok - this problem is getting ridiculous and no fix thus far seems to work. I
    have tried everything. I have 2000 pro with all updates and patches and have
    removed the softdistr folder, played around with services, re-registered
    dlls, even reinstall the 2000 rollup. There is only 1 account on my PC and it
    is the admin account. All updates download fine and say failed when trying to
    install. Went back to the v4 update and installs work great, its just with
    the new version v6. Here is the code

    2005-08-05 22:04:26 820 318 COMAPI - Allow source prompts: Yes; Forced:
    No; Force quiet: No
    2005-08-05 22:04:26 820 318 COMAPI - Updates in request: 1
    2005-08-05 22:04:26 820 318 COMAPI - ServiceID =
    {9482F4B4-E343-43B6-B170-9A65BC822C77}
    2005-08-05 22:04:26 820 318 COMAPI - Updates to install = 1
    2005-08-05 22:04:26 820 318 COMAPI <<-- SUBMITTED -- COMAPI: Install
    [ClientId = WindowsUpdate]
    2005-08-05 22:04:26 1188 378 Agent *************
    2005-08-05 22:04:26 1188 378 Agent ** START ** Agent: Installing updates
    [CallerId = WindowsUpdate]
    2005-08-05 22:04:26 1188 378 Agent *********
    2005-08-05 22:04:26 1188 378 Agent * Updates to install = 1
    2005-08-05 22:04:26 1188 378 Agent * Title = <NULL>
    2005-08-05 22:04:26 1188 378 Agent * UpdateId =
    {CCF08B4E-10B8-48BF-936F-0D16A1B4FB9E}.100
    2005-08-05 22:04:26 1188 378 Agent WARNING: Failed to evaluate Installed
    rule, updateId = {ED300F67-421C-4C08-B3BA-F35C55F3B427}.100, error =
    0x80041017
    2005-08-05 22:04:27 1188 378 Service WARNING: GetUserTokenFromSessionId
    failed with hr 0x800706d3
    2005-08-05 22:04:27 1188 378 Agent * WARNING: Exit code = 0x80240020
    2005-08-05 22:04:27 1188 378 Agent *********
    2005-08-05 22:04:27 1188 378 Agent ** END ** Agent: Installing updates
    [CallerId = WindowsUpdate]
    2005-08-05 22:04:27 1188 378 Agent *************
    2005-08-05 22:04:27 1188 378 Agent WARNING: WU client failed installing
    updates with error 0x80240020
    2005-08-05 22:04:27 820 2b8 COMAPI >>-- RESUMED -- COMAPI: Install
    [ClientId = WindowsUpdate]
    2005-08-05 22:04:27 820 2b8 COMAPI - Install call failed
    2005-08-05 22:04:27 820 2b8 COMAPI - Reboot required = No
    2005-08-05 22:04:27 820 2b8 COMAPI - WARNING: Exit code = 0x80240FFF;
    Call error code = 0x80240020
     
    Tbenson81, Aug 6, 2005
    #1
    1. Advertisements

  2. Tbenson81

    PA Bear Guest

    1. See the "Need more help? Tell us what problem you are having" section of
    http://support.microsoft.com/?scid=ph;en-us;6527

    2. You cannot install some updates or programs
    http://support.microsoft.com/default.aspx?scid=kb;en-us;822798

    3a. Check Windowsupdate.log (%windir%\Windowsupdate.log) for errors
    associated with the download/install.

    How to read the Windowsupdate.log file
    http://support.microsoft.com/?kbid=902093

    3b. Compare errors to those listed here
    http://inetexplorer.mvps.org/archive/windows_update_codes.htm and/or go to
    http://windowsupdate.microsoft.com > click on Help and Support link in left
    pane > Solve problems on your own.

    4. Windows Update Checklist:
    http://www3.telus.net/dandemar/updtcl.htm
    --
    ~Robear Dyer (PA Bear)
    MS MVP-Windows (IE/OE) & Security

     
    PA Bear, Aug 6, 2005
    #2
    1. Advertisements

  3. Hi,

    Please do the following:

    1. Start Explorer.
    2. In Explorer, right click on "My Computer"
    3. Select "Manage"
    4. Expand Local Users and Groups.
    5. Select Users.
    6. Open the account used to access Windows Update.
    7. Click the Member Of tab.
    8. If you find anything else than the "Administrators" group there,
    remove those other entries. You need to have only the
    "Administrators" group listed there.
    9. If you did any changes to the Member of list, log off and on again,
    and try Windows Update again.


    Regards,
    Torgeir
     
    Torgeir Bakken \(MVP\), Aug 6, 2005
    #3
  4. Tbenson81

    Tbenson81 Guest

    The only group listed is Administrators. I even tried adding a new account as
    an administrator and that didnt work either.
     
    Tbenson81, Aug 6, 2005
    #4
  5. Tbenson81

    Savage Guest

    Seems that this could be from COM config.

    I could be way off the mark, but give this a try.

    Run DCOMCNFG

    Navigate to Console Root \ Component Services \ Computers \ My Computer
    Right click on My Computer and select Properties
    Select Default COM Security tab

    Access Permissions click Edit Default
    system should have allow for local.

    Launch Permissions click Edit Default
    I've got Administrators , Interactive and System all with allow under
    available options.

    Check it out. ( P.s I checked on an XP machine , so if you have 2 do a
    little more leg work on Win2k I'm sorry. : ). )


    Hope this helps , feedback is helpful.
     
    Savage, Aug 15, 2005
    #5
  6. Tbenson81

    BrainSel Guest

    I've been working on this problem on one machine ALL DAY. Your suggestion
    worked like a charm.

    Thank You, Savage!!!

    BrianSel
     
    BrainSel, Aug 16, 2005
    #6
  7. Tbenson81

    dev Guest

    Savage,
    I have 2 computers running win2k- one sp4 the other running somethin earlier
    than sp4. I am experiencing the same problem as posted here on both
    machines, and the one with sp4 i just formatted yesterday- i haven't
    installed anything but windows updates and some drivers (network/video). i
    tried the com config and it did not fix the problem. the only thing that
    wasn't as you had put was system was not set to local access- once i did this
    tho the link to windows update in start menu stopped working and when
    accessing the site in IE windows update would search for updates
    indefinitely. When I erased the local access entry for system, these issues
    remained. I tried it on the other machine to verify that changing con config
    was definitely what caused these changes and other computer did same thing.
    I resolved these issues by using the old windows update program- v6 just does
    not work correctly imo.
     
    dev, Aug 22, 2005
    #7
  8. Tbenson81

    Savage Guest

    I'm sorry to hear that you're still having trouble Dev , I had only checked
    those settings on an XP machine. I'm a little too nervous to make suggestions
    about messging with DCOM on Windows 2000 machines.

    I'd compare the settings to a working 2000 machine( tis how I did it 4 XP.).
    From what I can fuddle on a 2000 machine this is what it looks like :

    Default access permissions is blank.( on this machine anyway.)
    Default Launch permissions =
    Administrators
    INTERACTIVE
    SYSTEM
    All as Allow launch.

    I think the main issue is the update site trying to impersonate an
    interactive user to install updates.

    Just in case I've included the Default Configuration Permissions :
    Administrators + Creator Owner+ System - Full Control
    Everyone + Power Users - Special Access
    Users - Read

    Also check the default authentication level for BITS and Automatic updates.
    Set to default auth level.

    Ok now this was all checked on an installation I cannot check windows
    updates on, but I hope this helps as a template or sumthin.
     
    Savage, Aug 22, 2005
    #8

  9. dev,

    Notice that the OP tbenson81 has not updated all of his many threads,
    opting instead to use new FIX!!! posts:

    http://www.microsoft.com/communitie...b0a30f-8a9a-4435-8ec5-ffcd30d78e54&sloc=en-us

    (web interface to newsgroups search for
    tbenson81
    )


    Please use the above search to find all the suggestions OP received
    in other threads and test them for your symptom. Reply back here
    with your observations and comments from those tests. Include any
    diagnostics which were also requested of the others. Details are the
    key to finding appropriate resolutions for problem symptoms.


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Aug 22, 2005
    #9
  10. Tbenson81

    dev Guest

    i also started a new thread; i'm just using the older windows update version.
    i only really wanted to reply to savage b/c it seemed like he/she was
    looking for some feedback to said suggestion. i have no interest in fixing
    windows update v6; if i'd had known i could just use the older version i
    would not have spent any time on it. long as i can get the updates, i'm
    good. i have other things to do. that being said, thank you for taking the
    time to try to help out and lead me to a solution all the same.
     
    dev, Aug 22, 2005
    #10
  11. Tbenson81

    Mike629 Guest

    Mike629, Jan 29, 2006
    #11
  12. ....
    <title>Error messages that you may receive when you try to download
    and install updates from the Windows Update Web site, from the Microsoft
    Update Web site, or from a WSUS server: &quot;0x800704DD,&quot;
    &quot;0x80240020,&quot; or both</title>


    Thanks for updating this old thread with this new information.


    Robert Aldwinckle
    ---


    From Aug 2005:

    http://www.microsoft.com/communitie...b44bf9-9028-4116-a1f9-c9865aa0f4d7&sloc=en-us
     
    Robert Aldwinckle, Feb 7, 2006
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.