Windows 2003. Telnet service does not exist anymore. How can I restore it?

Discussion in 'Server Setup' started by David Lightman Robles, Feb 4, 2004.

  1. I was trying to make Telnet service run on Windows 2003 Server for some of
    my users, but the error:

    Failure in initializing the telnet session. Shell process may not have been
    launched.
    Telnet Server has closed the connection.
    Connection to host lost.

    appeared everytime. I had checked
    http://www.petri.co.il/enable_telnet_on_win2003.htm and had created
    TelnetClients group and also granted permissions on cmd.exe to that group,
    but still no luck and the problem still appeared. Then I found the page
    http://support.microsoft.com/default.aspx?scid=kb;en-us;309523 and even
    though the page was intended for solving the problem on Windows XP 64-Bit
    Professional (which was not my case) I decided to try it out.

    1 cd %systemroot%\system32
    2 stop tlntsvr
    3 tlntsvr /unregserver
    4 tlntsvr /service
    5 net start tlntsvr

    And opsss...invalid service name. The service tlntsvr does not exists
    anymore. It seems that tlntsvr /service does not recreate it, nor tlntsvr
    /regserver. It has vanished. It does not appear in services.mmc either.

    How can I restore the service (and by the way, solve the problem that lead
    me to this dead end) ?

    Thanks in advance, and sorry for reposting ;)
     
    David Lightman Robles, Feb 4, 2004
    #1
    1. Advertisements

  2. David Lightman Robles

    iamwind Guest

    Because the tlntsvr service default account is LocalService, you can change the service account to LocalSystem, then tlntsvr work.
     
    iamwind, Feb 25, 2004
    #2
    1. Advertisements

  3. David Lightman Robles

    jb Guest

    same problem here!!!
     
    jb, May 26, 2004
    #3
  4. It is disabled by default. Just go into services and set it how you want it.
    IE. Automatic/Manual and then start it.
     
    Scott Harding - MS MVP, May 26, 2004
    #4
  5. David Lightman Robles

    satanemanojkumar

    Joined:
    Oct 9, 2013
    Messages:
    1
    Likes Received:
    0
    Telnet service doesnot exist. How to restore

    When telnetting to win2003 server, got the error "Failure in initializing the telnet session. Shell process may not have been launched.
    Telnet Server has closed the connection.
    Connection to host lost." and so By mistake followed the steps @ kb 309523..Failure in initializing the telnet session. Shell process may not have been launched. Telnet...[/url] i.e.
    "At a command prompt on the Windows XP 64-bit Professional host that is running the Telnet service, type cd %systemroot%\system32, and then press ENTER.
    Type net stop tlntsvr, and then press ENTER.
    Type tlntsvr /unregserver, and then press ENTER.
    Type tlntsvr /service, and then press ENTER.
    Type net start tlntsvr, and then press ENTER. Telnet connections to the Telnet service should now be accepted"
    without reading it completely that its applicable only to WinXP.
    How to restore now? Telnet is not available in services.msc aswel.

    Whats the solution for this?
     
    satanemanojkumar, Oct 9, 2013
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.