Windows cannot find file when clicking on file?

Discussion in 'Windows Vista File Management' started by mlsoup, Sep 30, 2007.

  1. mlsoup

    nalbon Guest

    Hi thanks for your tip as well, nothing in the start-up folder

    have a good holiday

    Nigel
     
    nalbon, Dec 26, 2007
    #21
    1. Advertisements

  2. mlsoup

    hankuk Guest

    Hi there

    I've experienced exactly the same problem. Bad news is that I'm no
    closer to resolving it.

    The good news is though, that I've managed to find a clue.

    I found that I could prevent the problem by disabling my antivirus. I
    use AVG Free edition. As soon as I turned on the AVG and booted Word
    (or any Office product) from a dbl click document in explorer then the
    problem occured.

    What AV software are u using? and does disabling the AV help?

    Hank
     
    hankuk, Dec 27, 2007
    #22
    1. Advertisements

  3. mlsoup

    nalbon Guest

    Hank, sorry for the delay, I'm using AVG Home edtion 7.5 full control centre.
     
    nalbon, Jan 11, 2008
    #23
  4. I have (had) the exact same problem, only it occurs EVERY time i open a .docx
    file from explorer. I, too, have Office 2007 and Windows Vista and found this
    really annoying. Reinstalling anything won't work, I've tried uninstalling
    and reinstalling Office myself.

    I came across this solution here:
    http://help.wugnet.com/office/Windo...-correctftopic-1011444-days0-orderasc-40.html

    SOLUTION:
    -Run regedit (Start menu, run, etc.) and go to this key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins
    (I had three addins here, two from Adobe and one from Microsoft.)
    -Export all the addins to a reg file (for backup)
    -Then delete all of them in the registry (or one at a time if you want to
    know which addin is causing the problem, i didn't bother with that)
    -Now try opening a .docx or .doc file in windows explorer and find that
    document loads properly with out any error messages!
    -now exit MS Word and open the reg file(s) you exported and import them back
    -try opening a .docx file again and it appears that the problem is fixed.
    This made me really happy! lol.

    This also fixed the same problem with excel. It's weird that this problem
    happens in the first place and it's even more odd this somehow fixes it.
    Please reply if this doesn't work, it's already been two days after I've
    done this and there hasn't been any problems so far.

    Cheers.
     
    Jesse J Pelley, Feb 3, 2008
    #24
  5. mlsoup

    psydeways Guest

    I had the same error trying to open some Doc & DocX files from Vista Windows Explorer, and yet the same files opened fine within Word 2007. I checked the programs associated with the various file extensions and found many of the Word files were associated with MS WORD VIEWER. I am guessing that this user's computer initially had MS WORD VIEWER & Office 2007 was later installed. After some experimentation, I deleted MS WORD VIEWER (via control panel), rebooted, launched Word 2007 directly & Word automatically changed all of the file extension associations to Word. All is well again.

    Manually changing the file extensions was not sufficient (I suspect the user was accidentally launching Word Viewer sometimes which switched back the associations).

    I wonder if the Excel & PowerPoint viewers can cause similar problems . . .
     
    psydeways, Jul 29, 2008
    #25
  6. hey guys sorry to drag up an old thread. but i've been having problems
    with various file types on my pc lately. when i double click some files
    i get the "windows cannot find" error and when i right-click on the file
    itself i get this at the top of the context menu "*[open("%1")]*" (no
    outside quotes)

    anyone know a solution? NB: no probs with office docs
     
    BleepingCrazy, Nov 16, 2008
    #26
  7. mlsoup

    St Guest

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    BleepingCrazy ïèøåò:
    I looks like application DDE command. What did you with your computer
    recently?
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.6 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFJIR/1ujclDHu6l+gRAktsAJ9ZJrVfY4ZxxqT2hEIImfqfm5nGJACcDOn3
    TyMDobg7Xnb/lbhJP8VbfKQ=
    =OfVd
    -----END PGP SIGNATURE-----
     
    St, Nov 17, 2008
    #27
  8. its a fresh install of vista only. happened again after i downloaded al
    the recommended updates

    i was getting it before re-installing too as there were some fil
    association problems that were driving me nuts (its my work pc
     
    BleepingCrazy, Nov 17, 2008
    #28
  9. ok using Acronis True Image Home 2009, I went back to my 1st imag
    post-install. and it still had this "*[open("%1")]*" but from what
    can see its just on my cakewalk files "*.cwp"...i have some other audi
    programs on the same pc and they have no problem at all. must be just
    cakewalk error rather than a vista thing. unless there is a way to fi
    it in vista

    is there a way to ADD a program to "default programs"
     
    BleepingCrazy, Nov 19, 2008
    #29
  10. yep, always do that with any lost program associations. this one didn't
    do it, no matter how many times i tried. (running as admin). its a
    cakewalk thing as everything else is fine. I just keep getting a popup
    "windows cannot find..." and then the file opens in the propper program
    (sonar) anyways. while the popup stays onscreen. crazy!
     
    BleepingCrazy, Nov 19, 2008
    #30
  11. mlsoup

    mark fenemer Guest

    Although this may not be current date wise. I have had a simila
    problem, when I click on an excel doc. in my documents foler I woul
    keep getting an error message -:mad:- Windows cannot fin
    "Filename/Path" make sure you typed the name correctly and try again
    :rolleyes: This was sligthly annoying as I could access the file b
    opening excel first and then opening the doc. After searching an
    reading through many forums for a fix I finally found a resolve fo
    myself...I simply inserted the Office 2003 install disc and got it t
    repair instead of install. Problem solved within a few minutes:D
    I have a feeling that when I used the trial version of Office 200
    bundled on my PC this had some kind of affect in the registry, which i
    turn affected my Office 2003 which did not fix when i finished with th
    trial version:cry:
     
    mark fenemer, Dec 14, 2008
    #31
  12. mlsoup

    prabhathps Guest

     
    prabhathps, Mar 22, 2009
    #32
  13. mlsoup

    hifismith Guest

    I know this thread is old and I've visited it before, but now I'm
    motivated to solve this problem.

    I've changed virus protection from AVG Free 8.0 to McAfee 8.5.0i and
    I've used the install disc to repair my 2007 install. And I've tried a
    few of the KB articles posted, but the problem persists.

    My problem is the one where clicking on a file from it's location in
    windows explorer opens the office program but doesn't open the file and
    I get the "Cannot find" message. Opening the file from the program
    works fine.

    has there been any more progress on this?
     
    hifismith, May 1, 2009
    #33
  14. mlsoup

    hifismith Guest

    It was a good idea, Viper. I copied an office file into the \office12
    folder and I got the same error message. The message says that it can't
    find the file at the location, and it does find the winword.exe file.
    Word loads first and then says it can't find the file. Thanks anyway.
     
    hifismith, May 18, 2009
    #34
  15. mlsoup

    Viper71 Guest

    Another possibility comes to mind....
    Try a doc-file with no spaces in the pathname, not just the filename
    but the complete path should be space-less. If that works, then it must
    a registry thing.
    If you double-click a file, windows looks at the extension to determine
    to which app this file belongs, looks up the corresponding application
    and start it with the file in question as a parameter.
    So double-clicking a file, is the same as running something like:
    "C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE" "C:\Users\John
    Doe\My Letter.doc".
    This is because in the registry, it says something like: app.exe "%1",
    where %1 will be substituted with the filename as the first parameter.
    If you would remove the quotes, you would get this:
    "C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE" C:\Users\John
    Doe\My Letter.doc
    The first parameter would be "C:\Users\John", the second would be
    "\Doe\My" and the third would be "Letter.doc". None of these exist as a
    loadable file, so it's possible that the parameter-passing of your
    filename is done without the surrounding quotes.

    Sadly, I cannot reproduce the error on my pc (all works well here, and
    I'm not gonna screw up my system for this, sorry), but it's possible
    that your registry got screwed up in this area, the "open" command
    should have a "%1" instead of a %1 (i.e. surrounding with quotes).
    The most obvious way to check this, is use a file without spaces in the
    path, like "C:\Docs\Letter.doc".
     
    Viper71, May 18, 2009
    #35
  16. mlsoup

    hifismith Guest

    That actually worked! Do you know where I can find this %1 error? I
    haven't corrected the error; I just confirmed that the spaces are an
    issue.
     
    hifismith, May 18, 2009
    #36
  17. mlsoup

    Viper71 Guest

    In theory, it should be somewhere in HKEY_CLASSES_ROOT and located in a
    subtree like shell\open\command.
    For instance, if you look in:
    HKEY_CLASSES_ROOT\Wordpad.Document.1\shell\open\command
    you would see:
    "%ProgramFiles%\Windows NT\Accessories\WORDPAD.EXE" "%1"

    Except that all the Office-apps are very well hidden and interlaced
    real deep within the Windows OS (too well IMHO). This is not strange, if
    you consider that Office is developed by the same company as the Windows
    operating system (whose name will remain unmentioned here...)

    (At least, I couldn't find any registry-entry with WINWORD.EXE "%1" in
    it.)
    They appearantly don't want you to mess with their settings through any
    backdoor, so my advice is first try some kind of "repair" from the
    Office-setup, or do a re-install.

    The only key I could find, that remotely matched the search, is:
    HKEY_CLASSES_ROOT\Oice.Word.Document\shell\open\command
    which reads:
    C:\PROGRA~1\MICROS~2\Office12\Oice.exe "%1"

    I even tried removing the quotes (messing it up temporarily), but even
    then it all kept working fine. Go figure....
     
    Viper71, May 18, 2009
    #37
  18. mlsoup

    Viper71 Guest

    I looked at the symantec-inf file, it just resets entries for
    exe,com,bat,pif,and scr-files. These are alle executables (sort of) and
    this reset is usefull if your registry is so messed up that you can't
    even run apps or batchfiles anymore.
    (scr is really an .exe(cutable), but renamed to .scr to be recognised
    by Windows as a screen-saver program)

    The difference between doc (docx) and xls (xlsx) is that it triggers
    another application to open it, that's all. The concept of linking is
    the same.

    But do I understand correctly that you solved the .doc issue with this
    symantec patch? (that is, not being able to open .doc files from
    explorer with spaces in the path?)
     
    Viper71, May 18, 2009
    #38
  19. mlsoup

    hifismith Guest

    I've been living with this problem for at least 6 months and now I'm
    starting to doubt that it was ever a problem with Word. I'm almost
    certain it was. I am able to open any Word file in any location. Other
    files (*.pdf, *.txt, *.html, etc) never had a problem. Still no love
    for excel, I assumed the problem was with the Office install.

    I did do a repair of Office a couple weeks ago, which took about 30
    minutes. It didn't help. Thanks for your help. Is it worth doing a
    complete uninstall and reinstall? I don't know how helpful that would
    be since some file would remain in place (like my Outlook *.pst files)
    and I assume some registry entries.
     
    hifismith, May 18, 2009
    #39
  20. mlsoup

    AnnieBrownTX Guest

    I had the same issues. I finally reformatted my hard drive, for the
    third time since December 2008.

    HOWEVER, I tried this software that promised to fix my issues "Windows
    can't find file fix" and it did NOTHING - the error messages were
    exactly the same after installing the software, then before installing
    the software.

    The company PROMISES your money back, if the software doesn't work -
    but the company, Security Stronghold, is intent on keeping their fee -
    no matter that I am NOT using their software, it is NOT installed on my
    computer and I am obvioulsy unhappy with their program and services.

    I sent them a message immediately after realizing the software did not
    work, and after a week, and my 3rd request for a refund, they responded.
    By then, I had installed the "Free" True Sword software, hoping it
    might fix my issue, and all it did was screw up my SQL Server. THAT led
    me to reformatting my hard drive...

    Needless to say, because I didn't get their permission to remove their
    software - I am not entitle to a refund.

    The point of this story is, stick with Microsoft. They will have a fix
    for their issues eventually - you just have to find it. Third party
    companies promising to be "experts" in Microsoft errors are sometimes
    just scams, like Security Stronghold.
     
    AnnieBrownTX, Jul 6, 2009
    #40
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.