Windows Defender error 0x800106ba

Discussion in 'Windows Vista Security' started by Bquinn, Dec 13, 2007.

  1. Bquinn

    Bquinn Guest

    12/11/2007

    Long post, sorry.
    Desktop computer with new clean install of Vista Ultimate about 15 Oct 2007.
    Everything else works. Tried to open and to start to run Windows Defender
    in order to scan my disks and got a message something like this:

    Application failed to initialize : 0x800106ba. A problem caused this
    program service to stop. To start the service, restart your computer or
    search Help and Support for how to start a service manually. Did the
    restart, however IT DID NOT CORRECT THE START PROBLEM of Windefend. I went
    to services to try to start it manually by right clicking on the WinDefend
    and selecting start. The message received was:

    Windows Defender could not be started.
    System error 2 has occurred
    The system can not find the file specified svchost.exe in the Windows
    System32 folder.

    I checked to insure that the file was in the system32 folder. It was.

    Check Google and one fellow said that the command: 'net start windefend'
    worked for him. I typed the command: 'net start windefend' and got the
    following messages:

    The Windefend service is starting and then
    The Windefend service could not be started
    A system error has occurred
    System error 2 has occurred
    The system cannot find the file specified

    Went to the MS download site and downloaded new Defender program and tried
    to install the program over the installed version. Received this message
    when starting the install - "You do not need to install this software
    because Windows Defender is included in Windows Vista. You can access
    Windows Defender from the Security Section of the Control Panel.

    Went to Control Panel - Programs and Features - Uninstall or Change a
    program, but Windows Defender was not listed. I guess it was not listed
    since it was included in the release of Vista. Went to msconfig and
    disabled all services and rebooted. Used the command 'net start windefend'
    and got the same system 2 error answer. Computer still operates with no
    other problems noted. I wonder if my security program "Avira Premium
    Security Suite" is blocking the Defender? It shouldn't be true since I
    stopped all services and got the same error.

    Any suggestions are welcomed. Thanks.

    Bill Quinn
     
    Bquinn, Dec 13, 2007
    #1
    1. Advertisements

  2. Bquinn

    Engel Guest

    Hello Bquinn,

    I quote dean – dean --a regular contributor here:

    You might try this. Go to the main Windows Update window and
    click on "Installed Updates" (on the left-hand side of the window, at the
    bottom), and then remove "Update for Microsoft Windows (KB931099)" (only).
    Reboot. Reboot again. Go back to Windows Update, and re-install the same
    update, by clicking on the Check for Updates button.
    This should essentially re-install Windows Defender on Vista.
     
    Engel, Dec 13, 2007
    #2
    1. Advertisements

  3. Bquinn

    Bquinn Guest

    Thank you Engel for your help. Did the uninstall of KB931 099 update as
    outlined in your message, rebooted two times, and then ran the update
    program which did reinstall the KB931 099 and KB915 579.

    I still get those same error messages so the Defender is not fixed. Since
    the computer is running OK with those problems maybe I should stop trying to
    fix it --- or should I say live with it.

    Again thanks for you help and interest.

    Bill Quinn
     
    Bquinn, Dec 13, 2007
    #3
  4. Bquinn

    Engel Guest

    Engel, Dec 14, 2007
    #4
  5. Bquinn

    kiwi Guest

    Hi Bill
    I know you posted a long while ago......but I have the same issues wit
    an OEM loaded Vista 64 on a laptop I purchased some 6 months ago
    Looking for a fix is driving me mad! Tried so many things.
    Thinking of giving up on Windows Defender....unless u were able to fin
    a fix?
     
    kiwi, Jun 11, 2008
    #5
  6. Bquinn

    Engel Guest

    See here:

    http://www.microsoft.com/communitie...pt=&catlist=&dglist=&ptlist=&exp=1&sloc=en-us

    Event Viewer - Windows Vista features a unified event log so that a support
    professional can view all the operational information about a machine from a
    single Event Viewer.

    <http://www.microsoft.com/downloads/...60-CF5F-4B62-B985-6BF494F42EF9&displaylang=en>


    Windows Defender - Windows Defender works with Internet Explorer 7 to help
    you make conscious choices about software installed on your PC by providing
    always-on protection that monitors key system locations, watching for changes
    that signal the presence of unwanted spyware.

    <http://www.microsoft.com/downloads/...20-ea7c-489b-8d66-fde0606de2ad&DisplayLang=en>

    Good luck
    - -- ---
     
    Engel, Jun 11, 2008
    #6
  7. Bquinn

    kiwi Guest

    Thanks Engle,

    Just trying sfc scannow to see what if any vista programs are faulty/corrupt.
    If this does not help will try your suggestions
     
    kiwi, Jun 11, 2008
    #7
  8. Bquinn

    Robinb Guest

    also you cannot uninstall Windows Defender in Vista
    you can disable it by unchecking the resident shield
    robin
     
    Robinb, Jun 17, 2008
    #8
  9. Bquinn

    romieb69 Guest

    Hey guys I found a really crappy workaround for this. This is NOT a
    fix, but I've tried a bunch of stuff suggested in this
    and other various forums, done hours of research and
    tinkering and this is the only solution I've found
    that will get Windows Defender to fire up

    Go to Admin Tools, Services

    Locate the WD service (if it's not stopped, stop it)

    Change it's startup type to Automatic

    Click the Log On Ta

    Select Local System Account and check the box that
    says Allow service to interact with deskto

    Click the Recovery Tab and ensure that First and
    Second failures are set to Restart the Service

    Click Appl

    Go to the General Tab agai

    Click Star

    Now go back to Ctrl Pannel and start up Windows
    Defender ... should fire up. I checked for updates and
    there were none.

    Notes: I did a reboot and checked out the service.
    It's stuck in a 'stopping' state and of course
    WinDefend isn't working. I used the Task Manager
    clicked the Services tab and found the service name
    that was stuck in the stopping state (WinDefend). I
    then right clicked it and chose go to process (make
    sure you choose show processes from all users). That
    took me to the svchost.exe instance that was hung up.
    I ended the process. Now I disabled the service and
    rebooted.
    Once my reboot was complete I went back to the service
    and put it in manual mode (leaving everything else I
    changed earlier alone) Tried to start it but it
    wouldn't start because no active processes needed the
    service. At this point I went back to ctrl panel and
    started windows defender. I got the dialog box
    indicating it was off and clicked the link to turn it
    on. It fired back up. Again checked for updates and
    there were none
    So now I reboot leaving the service in manual mode.
    I'm back to where I started. Same original error. The
    service however is not stuck in a 'stopping' state.
    It's just stopped. I was able to start it sucessfully.
    and Windows Defender opened up normally when I fired
    it back up. VERY VERY WEIR
    A final word on this pain in the a$$ error, I have not
    been successful using the Automatic delayed start
    option. I get an error indicating that the parameter
    isn't correct. Go figure
     
    romieb69, Dec 3, 2008
    #9
  10. Bquinn

    Ray Guest

    Thank you for this information
     
    Ray, Jan 12, 2009
    #10
  11. Bquinn

    lbug Guest

    I had the same issue after I installed Mcafee. After contacting Mcafe
    tech support I found out that there was a conflict with Interne
    Explorer 8Beta. Removing the Internet Explorer 8Beta from my Windows X
    computer corrected the issue. But the computer with Vista kept havin
    the same error. I followed the steps that romieb69 wrote. After th
    computer restarted the first time the issue was resovled. Thank you al
    for your posts
     
    lbug, Feb 1, 2009
    #11
  12. Bquinn

    mlt503 Guest

    This may be a bit late but I experienced the same problem on my Toshiba
    laptop running Vista Home / 32 bit OS.
    I tried all the solutions online but nothing helped fix the irritating
    0x800106ba error that Defender would put up when I tried to launch it
    using the icon in Control Panel.
    The fix that worked for me was to go to Start/Control
    Panel/Administrative Tools/Services.
    I found Windefend (or Windows Defender) and left-clicked, then
    right-clicked to bring up the pull-down menu. Clicked on Properties and
    changed the status from manual to automatic!
    I re-booted TWICE (because it was advised on one of the forums) and
    it's running fine now.
    Now if your Defender is already set to automatic and you're seeing the
    same error, I would change it to manual, go thru ALL the above steps
    (and try not to be too impatient) and then change it to automatic,
    reboot twice and see what happens.
    As a side note, my version of Vista won't allow un-installing Update
    KB931099 to fix this problem.
    Keep trying, the great feeling you get when you troubleshoot this
    successfully may be the highlight of your day.
    Good luck!!!!

    Mark :cool:
     
    mlt503, May 9, 2009
    #12
  13. Bquinn

    FlorenceTG Guest

    I gotta tell you

    I had been dealing with this problem for months and I have googled,
    uninstalled, etc....to no help

    I did exactly what you said and POW! It is gone

    Thanks and you are right....made me flipping day :D
     
    FlorenceTG, May 23, 2009
    #13
  14. Bquinn

    mlt503 Guest

    Florence, it made my day to hear you fixed it!! You go Girl!
    And it's a pleasure giving back after receiving so much help from this
    forum.
    Mark
     
    mlt503, May 25, 2009
    #14
  15. Bquinn

    jhlouie Guest

    This same process worked for me too running Windows Vista. Thanks for
    posting this info!!
     
    jhlouie, Jun 11, 2009
    #15
  16. Bquinn

    bulitas78 Guest

    How'd you come up with this fix?! You're the best man!
    Thanx a lot! :)
     
    bulitas78, Jun 20, 2009
    #16
  17. Bquinn

    doulos737 Guest

    Hi Engel,

    This doesn't work for me cause that there are no updates related to
    Defender in my list of updates. Please advise as this issue has cost me
    too much frustrating time... Thanks... :)
     
    doulos737, Jun 21, 2009
    #17
  18. Bquinn

    doulos737 Guest

    Thanks so much Mark! This is the only suggestion that worked for me
    after wasting so much time trying many things. I appreciate your
    contribution as well as those of all others though they didn't work for
    me.

    The confusion thing is, how did the problem get intoduced. I didn't
    change the service setting to 'manual' and it used to automatically run.
    Also, since it was now somehow set to manual, then why was I getting the
    error upon start up, unless cause it was in the Start up task list and
    then there was a conflict with the 'manual' service setting... Oh
    well... Thanks again... :)
     
    doulos737, Jun 21, 2009
    #18
  19. Bquinn

    doulos737 Guest

    Hi, follow -Narendran_K's suggested steps as they worked for me...:)-
     
    doulos737, Jun 22, 2009
    #19
  20. Bquinn

    Jeff Guest

    Thanks. This worked for me too. This is the first time I have used Windows
    Live for a fix. I will use it again now that I have found that it works. I
    have a 64 bit system, but it worked just the same. Thanks Again...Jeff
     
    Jeff, Jul 1, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.