Windows Firewall won't turn on

Discussion in 'Windows Vista Security' started by nsmartinez46, Jun 13, 2008.

  1. nsmartinez46

    nsmartinez46 Guest

    I've just had this problem recently. When I start up my computer, there is a
    pop up that says that Windows Firewall is turned off. I click the button to
    turn it on and then a screen pops up that says "Security Center cannot turn
    on Windows Firewall." I then click on "Turn on Windows Firewall manually." It
    then says that it isn't using the recommended settings to protect my
    computer. I click "update settings now" but then it says that it was unable
    to make the requested updates.

    I use Windows Vista and I've had my computer for a year now. This only
    happened the other day and I have Symantec installed as my anti-virus
    program.

    How can I turn Windows Firewall on again?
     
    nsmartinez46, Jun 13, 2008
    #1
    1. Advertisements

  2. nsmartinez46

    Mick Murphy Guest

    If you have norton internet security; it has taken over from Windows firewall!
     
    Mick Murphy, Jun 13, 2008
    #2
    1. Advertisements

  3. nsmartinez46

    nsmartinez46 Guest

    I've been using Symantec for a year now and Windows Firewall has been working
    with it just fine until recently... I don't believe Symantec has a firewall.

    So basically, as of now, I have no firewall. How can I turn Windows Firewall
    back on?
     
    nsmartinez46, Jun 13, 2008
    #3
  4. nsmartinez46

    Engel Guest

    You could try this:

    Right-click Command Prompt (in Start Menu\Programs\Accessories) and choose
    Run as Administrator. Type (or Copy and Paste) the following command:

    winmgmt /verifyrepository

    If the system returns "WMI repository is not consistent", type this command:

    winmgmt /salvagerepository

    The first time you run this it will fail. (It will issue stop commands to
    the services causing it to fail, saying, "A stop control has been sent to a
    service that other running services are dependent on"). It might take a
    couple minutes for the services to shut down. Run the last command again.
    You actually may have to run it 3 times before it finally runs and completes
     
    Engel, Jun 13, 2008
    #4
  5. nsmartinez46

    nsmartinez46 Guest

    I tried it and it said that the WMI repository is consistent. Is there
    something else that I'm supposed to do? I am still unable to turn my firewall
     
    nsmartinez46, Jun 13, 2008
    #5
  6. nsmartinez46

    Engel Guest

    Hi nsmartinez,

    What changed in your system shortly before the problem occurred? Knowing
    about a setting change or added software or hardware may be helpful in
    solving the problem.


    Donload and Install SuperAntiSpyware (Free)
    <http://www.superantispyware.com/superantispywarefreevspro.html>



    Have you scanned your system in Safe Mode (F8) for malware (spyware, adware,
    trojans, and other pests) using other tools, like

    Spybot S&D Free <http://www.safer-networking.org/index2.html>,

    a-Squared Free (formerly a² free) (online)
    <http://www.emsisoft.com/en/software/ax/>

    ewido (online) <http://www.ewido.net/en/>,

    Pest Patrol (online)
    <http://www.ca.com/us/securityadvisor/pestscan/default.aspx>

    Scan Your Computer With the F-Secure Online Virus Scanner
    http://support.f-secure.com/enu/home/olsbeta.shtml



    Also have a look to this URLs provided by Dave M.

    http://wiki.castlecops.com/Malware_Removal_and_Prevention:_Introduction
    - - ---
    http://wiki.castlecops.com/Malware_Removal_and_Prevention:_Overview
    -- - - -



    Have you tried doing a System Restore to a point in time before you started
    experiencing this problem

    Maybe you could try doing System Restore and see if it corrects the problem.



    Unexplained computer behavior may be caused by deceptive software
    <http://support.microsoft.com/kb/827315>



    I hope this post is helpful.

    Good luck
    - -- ---
     
    Engel, Jun 13, 2008
    #6
  7. nsmartinez46

    noone Guest

    If you are using a Norton product such as Internet Security,
    Systemworks or maybe 360, it has a firewall. I tried the cures for
    rebuilding the repository and they did not work. Out of desperation I
    uninstalled and reinstalled and updated everything via LiveUpdate and
    it was fixed.
     
    noone, Jun 14, 2008
    #7
  8. nsmartinez46

    Chappy Guest

    Hi

    I would have suggested that you make sure the Win Firewall service was
    running and not Stopped or Disabled by something, or accidentally by yourself.
    It sure sounded as if the Firewall service was not running at all with what
    you posted originally but I'm glad you got it fixed...albeit, the HARD
    way...;)

    Dave
     
    Chappy, Jun 16, 2008
    #8
  9. nsmartinez46

    nsmartinez46 Guest

    Nothing that I've tried so far has helped.

    How do I make sure that it wasn't stopped or disabled by something?
     
    nsmartinez46, Jun 20, 2008
    #9
  10. nsmartinez46

    Nikitash Guest

    Yes you can turn on windows firewall again just do what i say.

    1. login windows vista

    2. press start type secpol.msc under search.

    3. a window will open now goto>the tabs at lest hand side named windows
    firewall
    with advanced security open the tree.

    4. Now you will see profile state is not configured here , click on windows
    firewall properties and set default and recommended settings to all the
    profile click apply and ok.
    5. now logoff windows and then login. Voila! firewall is on again.

    6. incase it does not work please repeat all the steps again because it take
    proper settings to save in order.
     
    Nikitash, Jun 24, 2008
    #10
  11. nsmartinez46

    CARAPRX Guest

    I have the exact same problem. Did any ot he the post suggestions finally
    solve this> I have tried without success.
     
    CARAPRX, Jul 11, 2008
    #11
  12. nsmartinez46

    msu50000 Guest

    I know this is an old topic but I'm having the same trouble! I've tried
    both fixes listed in this thread to no avail. When I get to the advanced
    security tree that nikitash explains in the above post this is the error
    I get:

    ___________________________
    There was an error opening the Windows Firewall with Advanced Security
    Snap-in
    The Windows Firewall with Advanced Security Snap-in failed to load.

    Restart the Windows Firewall service on the computer that you are
    managing. Error Code: 0x6D9
    _________________________

    Does anyone have any idea on how to fix this? I have searched for a
    couple weeks and cannot find anything on it. This thread is as close as
    I've come.
     
    msu50000, Apr 8, 2009
    #12
  13. nsmartinez46

    Spirit Guest

    Spirit, Apr 10, 2009
    #13
  14. nsmartinez46

    RhondaLeigh Guest

    When I tried doing this to turn on my Windows Firewall, I received
    WinMgmt.exe - Entry Point Not Found. The procedure entry point
    [email protected]@[email protected]@XZ
    could not be located in the dynamic link library wbemcomn.dll

    Can you suggest something for me, please?

    Thanks!
     
    RhondaLeigh, May 15, 2009
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.