Windows Installer 3.1 V2 ( redictributable) is NOT installing prop

Discussion in 'Windows Update' started by SunRise, Jun 25, 2006.

  1. SunRise

    SunRise Guest

    Hi
    Following is the patch 'Windows update" tried to install but
    failed with just the message "Updates were unable to be installed"

    I downloaded this patch WindowsInstaller-3.1_KB893803-v2-x86.exe ,
    from Microsoft site and tried to install; but it is not successful.

    It tried to install and at the end of installation it displayed a window
    "Access Denied" and installation failed ( and rolled-back).

    Then it prompted to reboot PC.

    Now , this is blocking all other Windows updates as well installing other
    Windows Programs which use Windows-Installer feature.

    After spending an hour searching Microsoft website and Googling, still the
    issue is NOT fixed.

    Your suggestion to fix this would be very much appreciated.


    thanks in advance!

    Best Regards
    VETRI

    SCM Consultant - IBM-Rational & OpenSource Tools.

    www.Global-Software-Engineering.com
     
    SunRise, Jun 25, 2006
    #1
    1. Advertisements

  2. SunRise

    realcestmoi Guest

     
    realcestmoi, Jun 26, 2006
    #2
    1. Advertisements

  3. SunRise

    realcestmoi Guest

    This might solve your problem:

    At the command prompt, type the following commands, pressing ENTER after
    each line:



    net stop cryptsvc

    ren %systemroot%\System32\Catroot2 oldcatroot2

    net start cryptsvc

    exit





    NB: Make sure the filenames are *both* entered as *catroot2, not catroot;
    ie, don't forget the "2" at the end of catroot.





    At the command prompt:







    cd \windows\system32

    ren msi.dll msi.old

    ren msihnd.dll msihnd.old

    ren msiexec.exe msiexec.old

    exit



    Restart the computer.

    On the desktop, double-click WindowsInstaller-KB893803-x86.exe.

    Follow the prompts to complete the installation.

    Restart the computer.

    Double-click the desktop installer file and see if that solves your problem.



    It worked for me.



    Best regards,



    Michel Denie
     
    realcestmoi, Jun 26, 2006
    #3
  4. MowGreen said: "Apparently corruption in the Catroot2 folder is what
    caused the Access is denied error when the update was attempting to
    backup the uninstall registry key," commenting on this fix by W S:

    http://groups.google.com/group/micr...nstaller+3.1+v2&rnum=1&hl=en#087fd12bae7ec49d

    -Rename the Catroot2 folder, and then try to install the program again.
    To rename the Catroot2 folder, follow these steps:
    -Click Start, and then click Run.
    -In the Open box, type cmd, and then click OK.
    -At the command prompt, type the following commands, pressing ENTER
    after each line:
    net stop cryptsvc
    ren %systemroot%\System32\Catroot2 catroot2old
    net start cryptsvc
    exit
    -Important: Do not rename the Catroot folder. The Catroot2 folder is
    automatically recreated by Windows, but the Catroot folder is not recreated
    if it is renamed.
     
    Michael Jennings, Jun 26, 2006
    #4
  5. SunRise

    realcestmoi Guest

    Echo?

    Best regards,

    Michel Denie


     
    realcestmoi, Jul 1, 2006
    #5
  6. Singapore had your problem. Suspecting that SunRise's search wasn't
    thorough, I rooted around on Google while you posted your second,
    non-blank reply. Two say the same reinforces the answer - this occurs
    frequently due to server lag and users not refreshing the newsgroup.
     
    Michael Jennings, Jul 1, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.