Windows Media Player 10 prompts user for credentials

Discussion in 'Windows Media Player' started by Gavin Bloodworth, Jun 18, 2009.

  1. There was a problem I had for a large client that had Windows Media Player 10
    prompting for credentials when the user was trying to view streaming video
    via http. This was even thou they were already authenticated through Internet
    Explorer to use a proxy server on the network. The proxy server being
    addressed was in the format server.domain.net - being referenced fully
    qualified. Windows Media Player was set to "Use proxy settings of the web
    browser". The credentials were not getting passed to WMP.

    This is releated to the article:
    FIX: Windows Media Player 9 Series Prompts User for Credentials with NTLM
    Authenticated Proxy
    http://support.microsoft.com/?kbid=816089

    However, there is no hotfix available for Windows Media Player 10. And the
    fix does not guarantee that it will resolve the problem anyway.

    The actual cause of the issue for my situation is spoken about in this
    article:
    Intranet site is identified as an Internet site when you use an FQDN or an
    IP address
    http://support.microsoft.com/kb/303650/

    It relates to the fact that when given a proxy server to use that contains
    periods, Windows Media Player incorrectly identifies the proxy server as an
    internet site. When this happens, WMP prompts for credentials.

    When I changed Windows Media Player to use the proxy server as a shortname
    (ie not fully qualified server.domain.net. Just "server"), the prompt for
    credentials no longer came up and the player used the proxy server
    successfully.

    Note that another solution could be adding the *.domain.net to the Local
    Intranet under Sites in the Security Tab of Internet Options.

    Both of the above solutions can be deployed to your enterprise by using
    settings in Group Policy.
    (user config\admin templates\windows components\windows media
    player\networking\configure http proxy)
    and
    (user config\admin templates\windows components\internet explorer\internet
    control panel\security page\site to zone assignment list)
    respectively.
     
    Gavin Bloodworth, Jun 18, 2009
    #1
    1. Advertisements

  2. Gavin Bloodworth

    zachd [MSFT] Guest

    I believe you would want to have your autoproxy return the intranet DNS name
    instead of IP address.

    If that's not what you want, I believe you would want to talk to actual
    support. There's a hint of a security issue here that makes it more
    interesting.
     
    zachd [MSFT], Jun 23, 2009
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.