Windows Media Player 11 error C00D11B1 Original code 80070057

Discussion in 'Windows Media Player' started by cev, Sep 22, 2007.

  1. cev

    cev Guest

    Hi,

    I have windows XP sp 2, WMP 11 version 11.0.5721.5230, and a Realtek AC'97
    Audio card. The current driver is now version 5.10.0.6250 but the problems
    started before I upgraded.

    We bought quite a few WMA music files from the Walmart Music Downloads site
    and they seemed to work fine. Then our PC crashed and I had to reinstall XP
    again. We went to the site and the songs were no longer downloadable. When
    I try to download them again, first I get the message: "There is a problem
    with Windows Media DRM in your computer, please email us or call
    1-800-222-8132, from 6 a.m. to 12 a.m. Central Time, seven days a week. "

    I email them and WalMart nicely set the songs so we could download them from
    a special URL. Now I have the file, but when I try to play it I get an error
    message which leads to a web page that says: "You've encountered error
    message C00D11B1 while using Windows Media Player. The following information
    might help you troubleshoot the issue."

    Under Technical Details, Original error message code is 80070057 with the
    following text: "One or more arguments are invalid".

    I know these code have been discussed a lot, but I can't seem to find a
    problem/solution that fits.

    If the DRM was broken by the re-install how do I fix it?
     
    cev, Sep 22, 2007
    #1
    1. Advertisements

  2. cev

    Fabio Guest

    I'm exactly in the same situation described by cev:

    1) succesfully purchased DRM-protected WMA songs from an on-line music shop
    2) played those songs succesfully on my WMP 11 (on Windows XP SP2)
    3) not used the player for a month or so
    4) in the meanwhile, I purchased and installed the Cyberlink Power DVD 7
    (not sure if it has to do with this issue)
    5) Upgraded to WinAmp 5.35 (not sure if it has to do with this issue)
    6) Now, trying to play again my WMA files, I get Error C00D11B1 (original
    code 80070057)

    I looked around the net, and here on , and it seems that this error is
    rather frequent, and there could be several possible reasons for it.
    Suggested solutions (like setting that flag, changing this registry) didn't
    always work. At least they didn't in my case.

    Can any Expert MVP here give us a hint on how to get additional info about
    the error, in order to try to debug it a little deeper than with the simple
    error number?

    thank you
    Fabio
     
    Fabio, Sep 26, 2007
    #2
    1. Advertisements

  3. cev

    Fabio Guest

    Hi,

    anybody from Microsoft listening to this thread? We need help, and we're many!

    thanks
    Fabio
     
    Fabio, Oct 4, 2007
    #3
  4. cev

    Fabio Guest

    I found that someone solved this problem by applying a procedure suggested by
    Microsoft to reset the DRM database to an "virgin" state (see for example
    Microsoft KB article 925705. I found that several articles report the same
    procedure, meaing that the issue was repeatedly reported to Microsoft
    Support).

    Apart from suggesting how to backup your DRM folder (see on the KB how to do
    that), the main point there is to go to the link:

    http://drmlicense.one.microsoft.com/Indivsite/en/indivit.asp

    or another one:

    http://drmlicense.one.microsoft.com/crlupdate/en/crlupdate.html

    Both require to install an ActiveX component and then click an 'Upgrade'
    button to complete the job.

    In some cases these pages don't work (my case).

    Reading the java code behind that button, I found that the aim is just to
    open another Microsoft URL from your WMP, which will do the actual "upgrade",
    or "individualization" of the DRM database (no idea what that exactly mean,
    but forget the terminology...).

    The URL is version-dependent, so you first need to recover your WMP complete
    version string.

    Go to Help-About and take a note of the first three numbers in the version
    string, e.g for "11.0.5721.5145":

    Nr. 1 is 11 (main WMP version)
    Nr. 2 is 0
    Nr. 3 is 5721

    Ok, then you need to decide which URL to open with WMP.

    First case:

    If Nr. 1 is 9 and Nr.3 is greater than 3286, or Nr. 1 is 10 and Nr.3 is
    greater than 3801,
    the URL is http://go.microsoft.com/fwlink/?LinkId=49287

    Second case:

    If Nr. 1 is greater than 10 and Nr. 2 is 0,
    the URL is http://go.microsoft.com/fwlink/?LinkId=49288

    Third case:

    If Nr. 1 is greater than 10 and Nr. 2 is greater than 0 (should be WinVista),
    the URL is http://go.microsoft.com/fwlink/?LinkId=73923

    If you didn't meet any of the cases above (WMP versions older than 9),
    the URL is http://go.microsoft.com/fwlink/?LinkId=49286

    Once you know which URL fits your case, go to WMP File-Open URL and insert
    it there.

    Let me know if it worked for you... as in my case the URLs gave me error
    C00D11B1!
     
    Fabio, Oct 6, 2007
    #4
  5. cev

    Fabio Guest

    EUREKA!!!

    I found the solution. As suggested on the official Microsoft WMP FAQ, simply
    drop the content of the DRM folder. Then, restart the computer and the next
    time you will try to play one of your DRM-protected files you will be
    notified to upgrade the security module. OK, you must be on the internet to
    di that. Then, each time you play again for the first time your files you
    will be redirected to the licence provider (at least that's what happened
    with me).

    Hope this will help you all C00D11B1-frustrated.

    bye
    Fabio
     
    Fabio, Oct 6, 2007
    #5
  6. cev

    zachd [MSFT] Guest

    I thought the exact quote was "We Are Legion"? =\
     
    zachd [MSFT], Oct 11, 2007
    #6
  7. cev

    Max Guest

    Really great!
    I searched so much for a solution and this was it!
    Many many thanks!
    Max
     
    Max, Dec 19, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.