Windows Photo Import Autoplay Option gone

Discussion in 'Windows Vista Music, Pictures and Video' started by Jared, Apr 9, 2007.

  1. Jared

    Jared Guest

    Hey guys, I always use the import feature on Vista whenever I plugin my USB
    Drive with pictures on it. Problem is, it's not there anymore. I can do it
    manually but I'd rather have the convenience of having it pop-up in Autoplay.
    It's a pretty advanced problem, hopefully someone knows how to get through
    it. Thanks
     
    Jared, Apr 9, 2007
    #1
    1. Advertisements

  2. Hi Jared,

    It's possible that another AutoPlay behavior has become the default when
    Windows sesnes pictures on your memory card. To fix that, open the Control
    Panel and then type "Autoplay" in the search box. Click AutoPlay to open the
    AutoPlay Control Panel. Now find the entry for Pictures and set it either to
    "Ask me eery time" or "Import pictures using Windows." Save your changes.

    Hopefully that will fix this problem.
     
    Dave Johnson [MSFT], Apr 9, 2007
    #2
    1. Advertisements

  3. Jared

    Jared Guest

    Thanks man, but unfortunately, the option is completely gone from my Autoplay
    options. So it doesn't even appear on my list nor in the Autoplay options
    menu.
     
    Jared, Apr 9, 2007
    #3
  4. Jared

    Guest Guest

    Type the following in Start Run

    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoVoyager.dll"
    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoAcq.dll"
    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoViewer.dll"
    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoCinematic.dll"
    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoClassic.dll"

    This repairs the autoplay registry settings.
     
    Guest, Apr 9, 2007
    #4
  5. Jared

    Jared Guest

    Thanks for the reply, I'm pretty sure it's my registry that got f'd up
    somehow. All of those worked except the second one. And I'm pretty sure
    that's the one I need (Im guessing Acq stands for accuire which will
    "acquire" my pictures via the import program etc.) I got this error

    http://i32.photobucket.com/albums/d25/Spyder93090/Capture-3.jpg

    sorry for the hassle and thanks for your help. I realy appreciate it.
     
    Jared, Apr 9, 2007
    #5
  6. Jared

    Guest Guest

    C:\Users\David Candy>NET HELPMSG 5

    Access is denied.

    8007nnnn errors mean the rest of the number is a Win 32 error. Net can look
    up the string. Remember Net does it with decimal numbers while 9007nnnn are
    hexidecimal. Use Calc in Scientific mode to convert.

    Also pressing Ctrl + C in an proper windows message box will copy the text
    to the clipboard. I choose one I knew not to work to get an error dialog.

    EG

    [Window Title]
    RegSvr32

    [Content]
    The module "C:\Program Files\Windows Photo Gallery\Photogallery.EXE" failed
    to load.

    Make sure the binary is stored at the specified path or debug it to check
    for problems with the binary or dependent .DLL files.

    The specified module could not be found.
    ..

    [OK]

    http://www.microsoft.com/technet/sysinternals/processesandthreads/processmonitor.mspx

    Set it to monitor regsvr32.exe while running that bcommand. And then look
    for errors. Remember it is normal programing practice to attempt something
    and see if it errors or not. So most errors are just things it looking for.
    That is if one want to see if a registry key exists then one attempt to open
    it. If it doesn't exist it errors and lets you know it doesn't. So look for
    an access denied error.

    I've attached it's registry scripts if you want to see the settings by hand.

    i would have suggested deleing the file in case it ws corrupted, so it new
    version would be installed by Windows Resource Protection but noone has
    security to do so.
     
    Guest, Apr 10, 2007
    #6
  7. Jared,

    Run those commands from an "elevated" Command Prompt. Click Start, type cmd.exe. Right-click cmd.exe in Search results, and choose "Run as Administrator". Try executing the commands which David posted.

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Thanks for the reply, I'm pretty sure it's my registry that got f'd up
    somehow. All of those worked except the second one. And I'm pretty sure
    that's the one I need (Im guessing Acq stands for accuire which will
    "acquire" my pictures via the import program etc.) I got this error

    http://i32.photobucket.com/albums/d25/Spyder93090/Capture-3.jpg

    sorry for the hassle and thanks for your help. I realy appreciate it.
     
    Ramesh, MS-MVP, Apr 10, 2007
    #7
  8. Jared

    Jared Guest

    Ramesh & David:

    IT WORKED !! I can't Thank You guys enough. It works PERFECTLY now. Good
    karma pooints for you guys, haha. I'll definitely be back here if anything
    else comes up, which I doubt will. Vista has been running exceptionally
    smoothly despite what other people say.

    Thanx again,
    Jared
     
    Jared, Apr 11, 2007
    #8
  9. Thanks for the update, Jared. Glad that helped.

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Ramesh & David:

    IT WORKED !! I can't Thank You guys enough. It works PERFECTLY now. Good
    karma pooints for you guys, haha. I'll definitely be back here if anything
    else comes up, which I doubt will. Vista has been running exceptionally
    smoothly despite what other people say.

    Thanx again,
    Jared
     
    Ramesh, MS-MVP, Apr 11, 2007
    #9
  10. Jared

    Monica Guest

    Hello, I have the exact same problem as Jared. It's pretty irritating.
    However, being a comp idiot, the solution seems kind of confusing. I hope
    that some kind soul would retype a proper step by step solution for me.
    Pleaseeee.......

    Regards
    Monica
     
    Monica, Apr 11, 2007
    #10
  11. Click Start, type cmd.exe. Right-click cmd.exe in Search results, and choose "Run as Administrator". In the Command Prompt window, type the following commands one by one and press ENTER after each line.

    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoVoyager.dll"
    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoAcq.dll"
    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoViewer.dll"
    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoCinematic.dll"
    Regsvr32 "C:\Program Files\Windows Photo Gallery\PhotoClassic.dll"

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Hello, I have the exact same problem as Jared. It's pretty irritating.
    However, being a comp idiot, the solution seems kind of confusing. I hope
    that some kind soul would retype a proper step by step solution for me.
    Pleaseeee.......

    Regards
    Monica
     
    Ramesh, MS-MVP, Apr 11, 2007
    #11
  12. Jared

    Monica Guest

    OMG help! after i typed in "C:\program files\windows photo
    gallery\photovoyager.dll", it says:

    'C:\Program' is not recognised as an internal or external command, operable
    program or batch file.

    Help!! And my options still doesnt comes out.

     
    Monica, Apr 11, 2007
    #12
  13. You probably left out the regsvr32 part. To avoid errors, simply copy those commands and paste.

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    OMG help! after i typed in "C:\program files\windows photo
    gallery\photovoyager.dll", it says:

    'C:\Program' is not recognised as an internal or external command, operable
    program or batch file.

    Help!! And my options still doesnt comes out.

     
    Ramesh, MS-MVP, Apr 11, 2007
    #13
  14. Jared

    Monica Guest

    Hi Ramesh

    sorry but I have added in the Regsvr... still it auto imports without the
    options link.

    i'm using vista 32 bit. please help, thanks.

     
    Monica, Apr 17, 2007
    #14
  15. Jared

    Monica Guest

    Hi Ramesh

    sorry but I have added in the Regsvr... still it auto imports without the
    options link.

    i'm using vista 32 bit. please help, thanks.


     
    Monica, Apr 17, 2007
    #15
  16. Tried these steps posted by Dave?

    <quote>

    open the Control
    Panel and then type "Autoplay" in the search box. Click AutoPlay to open the
    AutoPlay Control Panel. Now find the entry for Pictures and set it either to
    "Ask me eery time" or "Import pictures using Windows." Save your changes.

    </quote>

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Hi Ramesh

    sorry but I have added in the Regsvr... still it auto imports without the
    options link.

    i'm using vista 32 bit. please help, thanks.

     
    Ramesh, MS-MVP, Apr 17, 2007
    #16
  17. Jared

    Monica Guest

    Hi Ramesh

    OMG i have tried this but it still doesn't work!

     
    Monica, Apr 18, 2007
    #17
  18. You may the settings are not saved. Or the "Import pictures using Windows" option itself is unavailable?

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Hi Ramesh

    OMG i have tried this but it still doesn't work!
     
    Ramesh, MS-MVP, Apr 18, 2007
    #18
  19. Jared

    Monica Guest

    It is available! Anyway, i dont think this is the solution to my problem,
    isn't it? This is merely the Autoplay options. When i put my card into the
    reader, i always select "Import photos using windows" anyway.

    I need the options.................... rather desperately. i got lots of
    photos to upload.

    Please further adviseeee!! Thanks.

     
    Monica, Apr 18, 2007
    #19
  20. I need the options

    Which options, exactly? Completely rephrasing your question would help. Looks like your problem is different than Jared's.

    <quote>
    I always use the import feature on Vista whenever I plugin my USB
    Drive with pictures on it. Problem is, it's not there anymore.
    </quote>

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    It is available! Anyway, i dont think this is the solution to my problem,
    isn't it? This is merely the Autoplay options. When i put my card into the
    reader, i always select "Import photos using windows" anyway.

    I need the options.................... rather desperately. i got lots of
    photos to upload.

    Please further adviseeee!! Thanks.

     
    Ramesh, MS-MVP, Apr 18, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.