Windows Powershell and WMI access to IIS application pools

Discussion in 'Windows Server' started by theonesuperdave, Jan 8, 2008.

  1. I was wondering if anyone knows how to use WMI and powershell to access
    application pools on a remote machine? I have tried different variation of
    the following command:

    PS C:\Scripts> gwmi -class IIsApplicationPool -namespace
    "root\MicrosoftIISv2" -
    computer [servername] -credential [servername]\testaccount

    Each time, the command returns with, "Get-WmiObject : Access denied." I have
    tried both local and domain accounts for the credentials. Also, I have tried
    things in other posts for setting the Authentication level to PacketPrivacy,
    and none of this seems to get me around the access error. I have also
    verified that I have admin access to the remote server and I can perform view
    and manage the application pools locally using the IIS Admin GUI.

    --Dave
     
    theonesuperdave, Jan 8, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.