Windows Security Center does not identify AntiVirus

Discussion in 'Windows Vista Security' started by Danie_T, Jul 11, 2007.

  1. Danie_T

    Danie_T Guest

    When I installed Vista I used the Live Trial - waiting for Trend to release.

    I uninstalled LiveCAre and installed trend - but Vista does not recognise
    the new software

    Get the message : SecurityCentre - event 3
    "The Windows Security Center Service was unable to establish event queries
    with WMI to monitor third party AntiVirus, AntiSpyware and Firewall."
     
    Danie_T, Jul 11, 2007
    #1
    1. Advertisements

  2. Danie_T

    dean-dean Guest

    You could try this:

    Right-click Command Prompt and Run as Administrator. Type the following
    command:

    winmgmt /verifyrepository

    If the system returns "WMI repository is not consistent", run this command:

    winmgmt /salvagerepository

    The first time you run this it will fail. It will issue stop commands to
    the services causing it to fail. It might take a couple minutes for the
    services to shut down. Run the command again. You actually may have to run
    it 3 times before it finally runs and completes on its own.

    Reboot your system.
     
    dean-dean, Jul 14, 2007
    #2
    1. Advertisements

  3. Danie_T

    Danie_T Guest

    Thank you - it fixed the problem

    C:\>winmgmt /verifyrepository
    WMI repository is INCONSISTENT

    C:\>winmgmt /salvagerepository
    WMI repository salvage failed
    Error code: 0x8007041B
    Facility: Win32
    Description: A stop control has been sent to a service that other running
    se
    vices are dependent on.

    C:\>winmgmt /salvagerepository
    WMI repository has been salvaged
     
    Danie_T, Jul 15, 2007
    #3
  4. Danie_T

    dean-dean Guest

    You're welcome. Thank you for the detailed report. Since my Repository is
    always consistent when I've run the command, I was always curious as to the
    extent of the "winmgmt /salvagerepository" messages that were conveyed when
    repairing an inconsistent Repository. I'm glad things are working for you.
     
    dean-dean, Jul 15, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.