Windows Server 2008 and adprep /forestprep

Discussion in 'Server Setup' started by Agendum, Mar 16, 2009.

  1. Agendum

    Agendum Guest

    I have a Windows Server 2003 R2 DC running a private forest. I have added a
    Windows Server 2008 machine to the domain and want to promote it as a DC in
    the existing forest. I added the Active Directory Domain Services role to
    the server, and rebooted. It asks me to run "Active Directory Domain
    Services Installation Wizard (dcpromo.exe)". As I step through this wizard,
    I get an error:

    ---------------------------
    Active Directory Domain Services Installation Wizard
    ---------------------------
    To install a domain controller into this Active Directory forest, you must
    first prepare the forest using "adprep /forestprep". The Adprep utility is
    available on the Windows Server 2008 installation media in the
    \sources\adprep folder.
    ---------------------------
    OK
    ---------------------------

    So I go to the media and run this command:

    -------------- BEGIN --------------
    Z:\sources\adprep>adprep /forestprep
    Adprep cannot run on this platform because it is not an Active Directory
    Domain Controller.
    [Status/Consequence]
    Adprep stopped without making any changes.
    [User Action]
    Run Adprep on a Active Directory Domain Controller.
    -------------- END --------------

    Oops, looks like I was supposed to run this on the currently active DC. So
    I go over to the Server 2003 R2 DC and run adprep from it's media and it
    seemingly succeeds:

    -------------- BEGIN --------------
    Z:\CMPNENTS\R2\ADPREP>adprep /forestprep

    ADPREP WARNING:

    Before running adprep, all Windows 2000 domain controllers in the forest
    should be upgraded to Windows 2000 Service Pack 1 (SP1) with QFE 265089, or
    to Windows 2000 SP2 (or later).

    QFE 265089 (included in Windows 2000 SP2 and later) is required to prevent
    potential domain controller corruption.

    For more information about preparing your forest and domain see KB article
    Q331161 at http://support.microsoft.com.

    [User Action]
    If ALL your existing Windows 2000 domain controllers meet this requirement,
    type C and then press ENTER to continue. Otherwise, type any other key and
    press ENTER to quit.


    c
    Opened Connection to DOMAIN1
    SSPI Bind succeeded
    Current Schema Version is 30
    Upgrading schema to version 31
    Connecting to "DOMAIN1"
    Logging in as current user using SSPI
    Importing directory from file "C:\WINDOWS\system32\sch31.ldf"
    Loading
    entries............................................................................................................................................
    139 entries modified successfully.

    The command has completed successfully
    Adprep successfully updated the forest-wide information.
    -------------- END --------------

    Returning back to the Server 2008 machine, and running the wizard again I
    still get this error:

    ---------------------------
    Active Directory Domain Services Installation Wizard
    ---------------------------
    To install a domain controller into this Active Directory forest, you must
    first prepare the forest using "adprep /forestprep". The Adprep utility is
    available on the Windows Server 2008 installation media in the
    \sources\adprep folder.
    ---------------------------
    OK
    ---------------------------

    But I just did this. I only have one DC in the forest, so not sure what
    else to do. I tried rebooting the Server 2008 machine, etc, and nothing
    works.

    Anybody know what I might be missing here?

    Thanks!
     
    Agendum, Mar 16, 2009
    #1
    1. Advertisements

  2. Agendum

    Agendum Guest

    Thanks very much for the quick response... I just tried this and it didn't
    have any effect on the existing DC, and the dialog still occurs on the 2008
    machine:

    -------------- BEGIN --------------
    Z:\CMPNENTS\R2\ADPREP>adprep /domainprep
    Running domainprep ...


    Domain-wide information has already been updated.
    [Status/Consequence]
    Adprep did not attempt to rerun this operation.
    -------------- END --------------
     
    Agendum, Mar 17, 2009
    #2
    1. Advertisements

  3. Agendum

    Agendum Guest

    Problem solved! I was running adprep on the DC from the Windows Server 2003
    R2 media. Instead, I used the adprep on the Windows Server 2008 media on the
    2003 DC and everything is now working.

    Thanks!

     
    Agendum, Mar 17, 2009
    #3
  4. Hello Agendum,

    Adprep command has to run on the 2003 Schema master from the 2008 installation
    disk. You have to run /forestprep, then /domainprep and just for the future
    i would also run /rodcprep to prepare for RODC(read-only domain controllers).


    Best regards

    Meinolf Weber


     
    Meinolf Weber [MVP-DS], Mar 17, 2009
    #4
  5. Agendum

    Guest Guest



    You have to run the adprep from the 2008 on the 2003 machine to bring the
    schema upto the 2008 level
     
    Guest, Mar 17, 2009
    #5
  6. Agendum

    Matt Croll Guest

    Hello,

    I noticed that my win2008 r2 x64 Volume license dvd had the adprep folder under support and not sources. And also, adprep32.exe in that support folder successfully allowed a dcpromo of a win2008 r x64 standard server from a win2003 SP2 x86 server.
     
    Matt Croll, Sep 29, 2010
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.