Windows update "Checking for the latest updates for your computer"for a very long time

Discussion in 'Windows Update' started by Bill Arnold, Sep 2, 2006.

  1. Bill Arnold

    Bill Arnold Guest

    This is fresh install of Windows XP Home (version including SP2) on a
    slower machine (800 MHZ VIA, to be used as a print/file server).
    Machine has full internet access via a NAT box.
    Windows Update (or Microsoft Update, either has the same symptoms) gets
    to the page where one choses express or custom. Pressing either causes
    "svchost" to start using nearly 100 percent of the CPU, with IE taking
    the remainder (to draw the endlessly-moving green bar?). The machine is
    essentially unusable; other programs and services won't start (actually
    they do start but it takes minutes or 10s of minutes) If I leave it for
    a long time (hours?) a failure message eventually pops up. The only
    other cure seems to be a power-off/on reboot.

    Same thing happens shortly after startup if automatic updating is
    enabled. (so automatic updating is disabled.)

    Any suggestions?
     
    Bill Arnold, Sep 2, 2006
    #1
    1. Advertisements

  2. Bill Arnold

    NewScience Guest

    It sounds as if your Update database maybe hosed.

    First:

    1. Open C:\Windows\WindowsUpdate.log and see if there are any error codes
    when it hangs

    Second:

    1. Open SERVICES.MSC and make sure that Automatic Update and BITS services
    are started.

    If all looks good:

    1. Start Menu | Run and type: net stop wuauserv
    2. Delete C:\Windows\SoftwareDistribution folder and subfolders (they will
    be automatically created)
    3. Create a .bat script file containing:

    net stop wuauserv

    regsvr32 /s c:\windows\system32\wuapi.dll
    regsvr32 /s c:\windows\system32\wuaueng.dll
    regsvr32 /s c:\windows\system32\wuaueng1.dll
    regsvr32 /s c:\windows\system32\wuauserv.dll
    regsvr32 /s c:\windows\system32\wucltui.dll
    regsvr32 /s c:\windows\system32\wups.dll
    regsvr32 /s c:\windows\system32\wups2.dll
    regsvr32 /s c:\windows\system32\wuweb.dll
    regsvr32 /s c:\windows\system32\MSXML3.dll
    regsvr32 /s c:\windows\system32\qmgr.dll
    regsvr32 /s c:\windows\system32\qmgrprxy.dll
    regsvr32 /s c:\windows\system32\jscript.dll
    regsvr32 /s c:\windows\system32\mucltui.dll
    regsvr32 /s c:\windows\system32\atl.dll

    net start wuauserv

    4. Save file and run it (You will get an error on the net stop wuauserv
    line since it is already stopped - ignore).
    5. Try Windows Update ... it will re-sync and update anything missing of
    itself and then proceed on.
     
    NewScience, Sep 2, 2006
    #2
    1. Advertisements

  3. Bill Arnold

    Bill Arnold Guest

    Unfortunately, this procedure did not fix the problem.
    None. Last lines seen in log are (sorry about the formatting):
    2006-09-02 17:56:16 1028 730 Report *********** Report: Initializing
    static reporting data ***********
    2006-09-02 17:56:16 1028 730 Report * OS Version = 5.1.2600.2.0.66304
    2006-09-02 17:56:17 1028 730 Report * Computer Brand = ASUSTek
    Computer INC.
    2006-09-02 17:56:17 1028 730 Report * Computer Model = C3V
    2006-09-02 17:56:17 1028 730 Report * Bios Revision = ASUS C3V ACPI
    BIOS Revision 1004
    2006-09-02 17:56:17 1028 730 Report * Bios Name = Phoenix - Award BIOS
    v6.00PG
    2006-09-02 17:56:17 1028 730 Report * Bios Release Date =
    2005-01-06T00:00:00
    2006-09-02 17:56:17 1028 730 Report * Locale ID = 1033
    2006-09-02 17:56:17 1028 730 Agent *********
    2006-09-02 17:56:17 1028 730 Agent ** END ** Agent: Finding updates
    [CallerId = WindowsUpdate]
    2006-09-02 17:56:17 1028 730 Agent *************
    2006-09-02 17:56:17 2996 9e4 COMAPI >>-- RESUMED -- COMAPI: Search
    [ClientId = WindowsUpdate]
    2006-09-02 17:56:17 2996 9e4 COMAPI - Updates found = 0
    2006-09-02 17:56:17 2996 9e4 COMAPI ---------
    2006-09-02 17:56:17 2996 9e4 COMAPI -- END -- COMAPI: Search
    [ClientId = WindowsUpdate]
    2006-09-02 17:56:17 2996 9e4 COMAPI -------------
    2006-09-02 17:56:17 2996 bb8 COMAPI -------------
    2006-09-02 17:56:17 2996 bb8 COMAPI -- START -- COMAPI: Search
    [ClientId = WindowsUpdate]
    2006-09-02 17:56:17 2996 bb8 COMAPI ---------
    2006-09-02 17:56:17 2996 bb8 COMAPI - Online = No; Ignore download
    priority = No
    2006-09-02 17:56:17 2996 bb8 COMAPI - Criteria = "IsInstalled = 0 and
    IsHidden = 0"
    2006-09-02 17:56:17 2996 bb8 COMAPI - ServiceID =
    {9482F4B4-E343-43B6-B170-9A65BC822C77}
    2006-09-02 17:56:17 2996 bb8 COMAPI <<-- SUBMITTED -- COMAPI: Search
    [ClientId = WindowsUpdate]
    2006-09-02 17:56:17 1028 730 Agent *************
    2006-09-02 17:56:17 1028 730 Agent ** START ** Agent: Finding updates
    [CallerId = WindowsUpdate]
    2006-09-02 17:56:17 1028 730 Agent *********
    Automatic Updates and Background Intelligent Transfer Service service
    are started.
    Very similar behavior. It took slightly longer to get to the pinned-CPU
    state (task manager says it's svchost); there was about a minute of
    activity fluctuating between 70-100 percent CPU.
     
    Bill Arnold, Sep 2, 2006
    #3
  4. Bill Arnold

    JohnL369 Guest

    I have almost exactly the same problem except mine was much worse with
    Microsoft Update than Windows Update. The first power on cycle of the day
    (when auto update is active) takes minutes (maybe 10s) before the PC reacts
    in anything like a normal manner. Also if I initiated Microsoft Update I got
    the same scrolling green bars until it errored out. I finally dropped back
    to Windows Update and it at least completes.

    I also am bringing a PC back up from scratch (XP Home) after replacing a
    hard drive due to a crash. Everything seemed to be working normally for
    several days until I loaded Office 2003 and enabled Microsoft Update. Do you
    by any chance use Norton AntiVirus 2006? I wonder if there is some
    interaction there. However, before my disk crashed I was using this version
    of Norton, with XP Home, and Office 2000 without any problems. My other data
    point is my laptop (faster uP) with Office 2003 and Norton 2005 which does
    not exhibit any problems with Microsoft Update.
     
    JohnL369, Sep 3, 2006
    #4
  5. Bill Arnold

    Bill Arnold Guest

    This problem appears to be resolved. I turned on automatic updates, left
    the machine untouched for a few days, and when i checked it again, it
    said there were updates to be installed. I allowed windows to install them,
    then rebooted, then Windows Update worked, and I installed all the optional
    updates as well.
     
    Bill Arnold, Sep 10, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.