windows update error 80070057

Discussion in 'Windows Vista Security' started by stu, Jul 24, 2008.

  1. stu

    stu Guest

    When i try to install windows vista update KB947562 i get an error code
    80070057. i do not really know much about this stuff so could someone help me
    stu, Jul 24, 2008
    1. Advertisements

  2. stu

    Peter Foldes Guest

    Windows Vista Update error 80070057 usually occurs due to incorrect HTTP proxy settings.

    Resolution Method

    To resolve this issue, you need to clear the existing proxy settings by performing the following steps:

    1.. Open Start menu, select Run, type cmd, and then press Enter.
    2.. To view the current proxy settings, at Command Prompt, type Proxycfg.exe and then press Enter to run the command.
    3.. To clear the existing proxy settings, type Proxycfg -d and then press Enter.
    4.. Finally, ensure that the Background Intelligent Transfer Service is running on the computer by performing the following steps:
    1.. Open Start menu, select Run, type Services.msc, and then press Enter.
    2.. Scroll down the Services window and double-click on Background Intelligent Transfer Service.
    3.. If the service is not running, on the General tab, click the Start button.
    5.. Run Windows Vista update on the PC again.
    Peter Foldes, Jul 25, 2008
    1. Advertisements

  3. stu

    stu Guest

    stu, Jul 29, 2008
  4. stu

    itzer Guest

    I have the same problem : Proxycfg.exe is not recognized. Did you get
    help? Can you help me?
    itzer, Dec 31, 2008
  5. stu

    myzticc66 Guest

    Same problem here? anyone ever figure this out? Ive had nothing bu
    problems with vista never problems with xp
    myzticc66, Oct 14, 2009
  6. stu

    Malke Guest

    No one can help you since you are not posting on a real forum as you think
    you are and you didn't quote any of the thread to which you are replying.
    You are using a web interface that leeches Usenet posts and most of the rest
    of us are using real newsreaders. We don't see what you do. If you want to
    participate in Usenet, the better way is to set up a newsreader. This is
    very easy to do and I'll give you information about that below. If you
    prefer to use a forum, then here are two excellent ones:

    Since you are using a web interface, you may not realize that this is really
    a newsgroup. You will get far more out of this resource if you learn to use
    a newsreader. There are many good newsreaders for Windows, but you can use
    Outlook Express (XP) or Windows Mail (Vista) since you already have it. Here
    are some links to information about newsgroups:

    About Usenet: - Usenet FAQs from the Internet FAQ Archives - a brief explanation
    of newsgroups

    Outlook Express/Windows Mail as Newsreader:

    How to Post: - How to Ask a Question - How Not to Get Technical Help on
    Usenet - list of MS newsgroups - MS group to test if your newsreader is working
    properly - how to munge email address - crossposting - multiposting

    Other Newsreaders for Windows: - Forte - Thunderbird

    Malke, Oct 14, 2009
  7. stu

    MowGreen Guest

    The parameter is incorrect; One or more arguments are invalid;

    " Windows could not start the Background Intelligent Transfer service on
    the local computer. For more information, review the system event log.
    If this is a non-Microsoft service, contact the service vendor and refer
    to service-specific error code 2147942487. (0x80070057)
    This error indicates that the Windows HTTP proxy settings are invalid.
    To resolve this problem, remove the HTTP proxy settings "

    First, see if the Background Intelligent Transfer service [BITS] has
    been set to Disabled. Click the Start orb, enter services.msc in the
    Start Search field; under Programs click on services.msc, nter a
    password if one is used and/or click the Continue button.
    Locate Background Intelligent Transfer service and click once on it.

    Is the Startup type set to Disabled ? If so, *double left click* on BITS
    and set the Startup type to Manual, click Apply, OK.
    If it is not set to Disabled click the Start the service link to see if
    it starts. If it does not start, *please tell us*.

    Next, check to see if Vista is using proxy settings.
    Open an Elevated Command Prompt by clicking the Start orb, enter
    in the Start Search field. Under Programs, *right* click on cmd.exe and
    choose 'Run as administrator'. Enter a password if one is used and/or
    click the Continue button.
    At the prompt, type in the following and then press Enter

    netsh winhttp show proxy

    The message will look like this:

    Current WinHTTP proxy settings:

    IF a proxy is being used it will now be showing.
    If not, it will state:

    Direct access <no proxy server>

    If a proxy is listed type this in and then press Enter after *each*
    command. Allow the reset proxy command to run prior to entering the next

    netsh winhttp reset proxy

    Try another attempt at updating. If it still fails please post the
    *last* 50 or so lines of the WindowsUpdate.log into your response:

    How to read the Windowsupdate.log file

    *-343-* FDNY
    Never Forgotten
    "Security updates should *never* have *non-security content* prechecked"
    MowGreen, Oct 14, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.