Windows Update Error Code: 80070424

Discussion in 'Windows Vista Installation' started by veloci1992f, Nov 2, 2008.

  1. veloci1992f

    veloci1992f Guest

    PROBLEM -

    Hey every one! I need a little help with my Windows Update.

    On the 25th of October, the update was fine and everything. Now, when
    went to go update on the 31st it said the 25th was the LAST day i
    auto-update on! I went "WTF" so I decided to manually check for th
    updates but I did not expect a slap to my face with a smooching re
    error code: 80070424 ('screenshot of the error
    (http://i5.photobucket.com/albums/y179/ThatOneGuyRulez/Misceleanous Stuff/SSOfError.jpg)).

    I've tried many solutions but none seems to work; at this point m
    brain has literally crashed due to many fail attempts at trying to fin
    a possible fix for my Windows Update. I supposed my moral is decreasin
    and entering into a pessimistic stage of my PC.

    My OS is Windows Vista Premium 64 bit, and no all the programs
    currently have were installed before the 25th but Comodo Interne
    Security (which I uninstalled to check if it was the culprit but i
    wasn't; oh I also checked Comodo Memory Firewall but it wasn't th
    problem either) was on the day that Update failed and gave error cod
    80070424.

    Yes, I've also tried to do a system repair AND restore but none of the
    even worked strangely. :/ Made another user account to check if Window
    Update works but it returned the same code error. Oh and could someon
    check my HiJackThis log and check my system "stuff?" Not sure why I'
    getting that many files missing errors.*

    Please assist me! Very much appreciate it, and yours truly

    ~Veloci

    SOLUTIONS -

    1) REGSVR32 %SYSTEMROOT%\SYSTEM32\WUAUENG.DLL - confirmation bo
    succeeded but it did not fix my Windows Update problem.

    2) I've checked to see if my BiTS was correctly configured an
    everything of the sort and they are correctly configured without m
    intervention - works but it did not fix my Windows Update problem.

    3) The BiTs restore tool thing, the one that repairs if it's corrupte
    or something - it said it's not needed currently so I'm assuming m
    files for Windows Update/BiTs aren't damaged in any way.

    4) regsvr32.exe wuaueng.dll - confirmation box succeeded but it did no
    fix my Windows Update problem.

    5) Regsvr32 QMGR.DLL - I'm suspecting this is the cause of my Window
    Update not working properly as it returns a confirmation box that it wa
    loaded but the entry-point DllRegisterServer was not founded with "Mak
    sure that "'QMGR.DLL'" is a valid DLL or OCX file and then try again."

    6)

    * Click on Start -> Run
    * and paste the command below and enter

    %SYSTEMROOT%\SYSTEM32\REGSVR32.EX
    %SYSTEMROOT%\SYSTEM32\WUAUENG.DLL
    This line use to reregistering WUAUENG.DLL in window.

    * You are done! Launch your windows update again, you should b
    able to perform update now. <-- this solution does not work at all
    given me errors of a register binary for the REGSVR32.exe and n
    association part with WUAUENG.DLL.

    7) windows update error 8E5E0442 - TechNet Forums - the second post b
    Ronnie Vernon MVP works but it does NOT solve my problem at al
    either.**

    8) Ran 3 antivirus scans (at different times) on thorough mode an
    found nothing. Used Malwarebyte's, Spyware Terminator, Ad-Aware, an
    SUPERANtispyware, and found zip.***

    That's ALL the solutions I have tried but it still gives me the sam
    blasted error code; my last resort for this problem is a reformat whic
    I do not want at all since I have yet to invest in an HD that isn't par
    of the PC (not sure of the correct terminology). Well if anyone need
    screenshots of the problems I'm getting I'll gladly post them.

    ASTERICKS LEGEND -

    *I used CCleaner to remove registry errors which is unwise I woul
    believe since if I'm not comfortable in editing my register on my ow
    why should a problem do so itself then? That's what I asked myself so
    have ceased to use CCleaner any longer other than for clearing up cach
    and stuff like that, lol.
    -------------------------------------------------------------------------------------------------
    **I'm also sorry if it's against the TOS or the rules to link to othe
    websites but I have yet to look up the rules except knowing the prope
    etiquette on all forums. Excuse my ignorance. This solution also wiped
    my update history list away so on my screenshot you'll probably see the
    two "Never" word.
    -------------------------------------------------------------------------------------------------
    ***Oh, and my surfing habits are basically this: Check emails and never
    clicking on a link, play Urban Terror, go on youtube, and this forum.
    That's basically all I do so I'm not entirely sure what I have really
    done but if it matters I used Wubi to install Ubuntu on my PC for
    dual-boot and I'm a bit more riskier on Linux so could that perhaps have
    affected my Vista partition?


    +-------------------------------------------------------------------+
    |Filename: hijackthis.txt |
    |Download: http://forums.techarena.in/attachment.php?attachmentid=7314|
    +-------------------------------------------------------------------+
     
    veloci1992f, Nov 2, 2008
    #1
    1. Advertisements

  2. veloci1992f

    super_js Guest

    I can confirm that this works

    Thanks a lot t.j
     
    super_js, Nov 22, 2008
    #2
    1. Advertisements

  3. veloci1992f

    mattjones16 Guest

    This didn't work for me. After running the command I got this erro
    message:

    "The module "C:\Windows\SYSTEM32\WUAUENG.DLL" was loaded but the cal
    to DllRegisterServer failed with error code 0x80070005.
     
    mattjones16, Jan 12, 2009
    #3
  4. veloci1992f

    Mansoor Guest

    I tried but iy didnt worked for me.. it says The module
    "C:\Windows\SYSTEM32\WUAUENG.DLL" was loaded but the call to
    DllRegisterServer failed with error code 0x80070005.
    please help me with this.. i have windows vista home premium and also my
    BITS are working just fine and enabled....
    thank you
     
    Mansoor, Jan 16, 2009
    #4
  5. veloci1992f

    gmctech Guest

    I have the exact same issue as you!!!!! i get the 0x80070005 after i try the
    run command for the dll file!!!!
     
    gmctech, Jan 19, 2009
    #5
  6. veloci1992f

    gmctech Guest

    HEY I FIXED THIS ISSUE!!!!! Go to control panel.....user accounts..... then
    turn user account control (UAC) off!!! this worked for me... i just went in
    and started changing things and this did it!!!!
     
    gmctech, Jan 19, 2009
    #6
  7. veloci1992f

    pras Guest

    Hi,
    the issue is with missing Wuaserv Registry.
    I got the microsoft guys to help me with this and its fixed.
    Mail me at and i'll send the solution
     
    pras, Feb 23, 2009
    #7
  8. veloci1992f

    Un1267 Guest

    It worked for me - but after I rebooted. Thank you
     
    Un1267, May 11, 2010
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.