Windows Update error for Vista code 80040154

Discussion in 'Windows Update' started by Steve, Sep 30, 2007.

  1. Steve

    Steve Guest

    Ok. All day for me, I keep getting an error code 80040154 everytime I click
    on the "Check for Updates" button in the Windows Update window. Does anyone
    know how to fix this?
     
    Steve, Sep 30, 2007
    #1
    1. Advertisements

  2. Steve

    Lora Guest

    Get Dial-a-Fix. After you unzip it, check "Empty temp folders," "Fix
    Windows Installer," and "Fix Windows Update." Click on "Go" hope that
    it will fix your problem.

    Lora
     
    Lora, Sep 30, 2007
    #2
    1. Advertisements

  3. Steve

    Engel Guest

    Engel, Oct 1, 2007
    #3
  4. Steve

    Steve Guest

    Is there a way to fix this that the software IS Vista compatiable?

    Steve
     
    Steve, Oct 1, 2007
    #4
  5. Steve

    Engel Guest

    Engel, Oct 1, 2007
    #5
  6. Steve

    ag Guest

    I've had this problem for a few weeks and it's very very frustrating.

    How can Microsoft not have a fix for this... and for so long?

    I am running Vista on a laptop, and have another error too, got the BSOD
    with a usbccgp.sys error. I foudn a patch on the MS website for this, but
    then when I try to install it, I get the same 80040154 error. So basically,
    I can't do any updates whatsoever...

    I am seriously considering a rebuild and just going back to Windows XP... I
    hope Vista doesn't turn in to the same fiasco as Windows ME.
     
    ag, Oct 24, 2007
    #6
  7. Steve

    The420Guy Guest

     
    The420Guy, Nov 22, 2007
    #7
  8. Steve

    The420Guy Guest

    I get the same exact error code when i try to update Vista Ultimate Error
    Code 80040154.

    also getting an error code with Windows Defender Error Code 0x80244030

    and Norton Anti Virus Error Code 1812

    None of these 3 applications will update.

    PLEASE HELP before i throw this thing in the trash and buy a Mac.
     
    The420Guy, Nov 22, 2007
    #8
  9. Steve

    Jayman Guest

     
    Jayman, Jul 19, 2008
    #9
  10. Steve

    The ITGuy Guest

    I have the exact same thing! This happened right after a BSOD!
     
    The ITGuy, Aug 21, 2008
    #10
  11. Steve

    Jayman Guest

    I finally fix this issue and it is not the outcome that you want!

    I had to reload the software onto my notebook and then downloaded all the
    updates for the system.
    Currently my system is running correctly after 2 weeks now with no issue and
    I have reloading the same software that was previously on the system. What I
    have done is NOT enable windows defender after reading other people's
    comments.

    The thing about this is that a network trojan made its way onto my system
    while performing the widows updates which McAfee found when loaded, after the
    updates. Luv the internet!!
     
    Jayman, Aug 21, 2008
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.