Windows Update on W2K Pro *WAS* hanging; now fixed!

Discussion in 'Windows Update' started by Matt The Hepcat, Aug 29, 2006.

  1. Recently did:
    - Clean install of W2K Pro from CD on two separate machines
    - Manually installed SP 4 over the Internet from MS
    - Manually installed IE 6 over the Internet from MS

    After that Windows Update did nothing but hang for hours, with the very
    annoying message:

    Checking for the latest updates for you computer . . .
    - - - green progress bar - - -

    Here’s what I did (from reading this forum) to solve this issue.

    1) Background Intelligence Transfer Service
    Run | services.msc
    Right mouse click: Set to “Automatic†| Start
    Rebooted for good measure

    2) Registered the following:
    Run | then each command below (waited for the success message); after all
    was done, rebooted for good measure.

    net.exe stop wuauserv
    regsvr32 wuapi.dll
    regsvr32 wups.dll
    regsvr32 wuaueng.dll
    regsvr32 wuaueng1.dll
    regsvr32 wuweb.dll
    regsvr32 jscript.dll
    regsvr32 softpub.dll
    regsvr32 wucltui.dll
    regsvr32 msxml3.dll
    regsvr32 atl.dll
    net.exe start wuauserv

    3) ActiveX controls
    Checked to make sure that ActiveX control were not disabled.

    4) Wireless router questions
    I’m behind a (wired) Linksys WRT54G; so ran “TweakTools†from DSLReports,
    which reported that no tweaks were required


    Thank you to all who posted fixes on this issue!

    Wonderful!
     
    Matt The Hepcat, Aug 29, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.