Windows Update & PWS problem??

Discussion in 'Windows Update' started by Seth, Nov 6, 2003.

  1. Seth

    Seth Guest

    I am using Win98SE, IE6 SP1 and just installed PWS 4.
    Everything went well with the web pages with PWS and I was
    able to run Windows Update once after I installed the PWS.

    However, started last week, I have not been able to use
    Windows Update again. I can go to the Windows Update page,
    but every time I click on "Scan for update" button, it
    freezes up my IE while the scan stays at 0%.

    My NetAdmin says it has to do with my PWS installation. I
    tried to uninstall my PWS and did both two suggested
    solutions (install script engine 5.6 and Repair my IE) in
    Windows Update Troubleshoot, then I tried to "Scan for
    update" again, but have no luck. It still freezes up.

    I really appreciate any help to solve this problem.
     
    Seth, Nov 6, 2003
    #1
    1. Advertisements

  2. Seth,

    Open Internet Explorer or Windows Explorer and type or copy and paste
    this into the Address bar :
    %windir%\windows update.log
    Now press Enter or click OK. Scan down towards the bottom for the latest
    entries. Find the error code(s) associated with the last failed attempt
    to access Windows Update. Then go here :
    http://v4.windowsupdate.microsoft.com/troubleshoot/
    and search for the error code(s) that you found under the
    " Problem reaching Windows Update " heading.

    Some simple thing to check :
    The Date and Time of the system are accurate.
    Open Internet Options via the Control Panel. On the first page,
    General, click the Languages button. Make sure that there is a language
    chosen for IE.
    Click the Connections tab. Click the LAN Settings button. Under
    Automatic Configuration uncheck both boxes ( Check with your Admin over
    this setting, too ).
    See if you can access an SSL-enabled website :
    https://www.stanford.edu/group/idg/leland/samples/secure/test.html
    " If you cannot connect to SSL sites then the Windows Update scan will
    not work. Make sure that the SSL port (port 443) is open on your
    network. " (Once again, check with your Admin)
    Confirm that you have the latest ActiveX controls for the Windows Update
    site and that they are all the same version. For Windows 98 they should
    all be v.5.3.3790.13 . The 3 files are:
    iuctl.dll iuengine.dll and Update Class (iuctl.inf)
    Update Class is located in the Windows\Downloaded Program Files folder.
    Locate all 3 files, right click them, choose Properties,click the
    Version tab .

    If you find any of the files are not of the same version , manually
    download them from here :
    http://v4.windowsupdate.microsoft.com/cab/x86/ansi/iuctl.cab

    and save them to your desktop. Extract the .cab file following the steps
    below:

    1. Go to the desktop and right click the iuctl.cab file.

    2. Click "Extract to."

    3. Point to a known location (like the desktop) and click "OK."

    4. Go to the location you selected and right click on the iuctl.inf file.

    5. Click "Install."

    NOTE: Temporarily disable your antivirus program prior to downloading
    and installing the ActiveX controls. Failure to do so will result in
    corrupted, damaged, or mismatched controls.


    MowGreen [MVP]
    *-343-* Never Forgotten
     
    Mow Green [MVP], Nov 6, 2003
    #2
    1. Advertisements

  3. Seth

    Seth Guest

    Thanks for the reply Mow Green...

    In my Windows Update log, I found this error:

    2003-11-06 11:47:29 19:47:29 Error IUENGINE
    Querying software update catalog from
    https://a248.e.akamai.net/v4.windowsupdate.microsoft.com/ge
    tmanifest.asp (Error 0x800C0005)

    that error is not mentioned in Windows Update Troubleshoot
    page. However, after I searched on the web, I found this
    article on this link ( http://cert.uni-
    stuttgart.de/archive/bugtraq/2003/09/msg00045.html ) which
    mentions that the error is related to Ad-Host Blocking
    method. And they offer a work around for that:


    Quick work-around:
    - Disable all host-blocking mechanisms.

    More refined work-around
    - Users of external firewalls: Allow traffic from and to
    hosts on the Akamai domain (akamai.net).
    - Users using HOSTS file: get the latest version of the
    HOSTS file (for example from http://www.accs-
    net.com/hosts/ ) and check that no hosts from the Akamai
    domain are being blocked.

    Should I apply the suggested work-around?

    I have checked on things you want me to checked:
    - The Date and Time of the system are accurate.
    - Open Internet Options via the Control Panel. On the
    first page, General, click the Languages button. Make sure
    that there is a language chosen for IE.
    ==> I have checked them and they are OK.

    - Click the Connections tab. Click the LAN Settings
    button. Under Automatic Configuration uncheck both boxes (
    Check with your Admin over this setting, too ).
    => Did it, but still cannot access the link you gave me

    - Make sure that the SSL port (port 443) is open on your
    network. " (Once again, check with your Admin)
    How can I check for it? I have my SSL1 and SSL2 options
    checked in my Internet Option setting. Does it matter?

    - Confirm that you have the latest ActiveX controls for
    the Windows Update site and that they are all the same
    version. For Windows 98 they should all be v.5.3.3790.13 .
    The 3 files are: iuctl.dll iuengine.dll and Update
    Class (iuctl.inf).
    ==> I have checked them and they all have same version.
    So, it is OK.

    Does the PWS have anything to do with this problem?

    Thanks.
     
    Seth, Nov 6, 2003
    #3
  4. Should I apply the suggested work-around?

    The HOSTS file is the issue. You don't have to remove every reference to
    Akamai, only this one a248.e.akamai.net . This way you will have a
    tad less ads ;)
    As for adding the Windows Update sites ....

    Add the following to the Trusted sites zone :

    1. Open Internet Explorer.
    2. Click "Tools," and then click "Internet Options."
    3. Click "Security."
    4. Click the Trusted sites icon.
    5. Click "Sites."
    6. Clear the check box "Require server verification (https:)for all sites in
    this zone."
    7. Add all four sites listed .

    http://Windowsupdate.microsoft.com
    http://V4.Windowsupdate.microsoft.com
    https://v4.Windowsupdate.microsoft.com (Note: The https is correct)
    http://Download.Windowsupdate.com
    https://a248.e.akamai.net


    You're welcome, Seth.

    MowGreen [MVP]
     
    Mow Green [MVP], Nov 6, 2003
    #4
  5. Seth

    Seth Guest

    Thanks again for the reply MowGreen...

    and thanks for your suggestions I've finally been able to
    access the Windows Update page again and do updates. The
    problem in my case is because somehow my old Proxy Server
    setting in Internet Option was changed when I changed my
    Opera's setting.

    After I changed the setting to the way it supposed to be,
    I was able to access the Windows Update and run my PWS (it
    does not seem to have anything to do with my problem). I
    also did as you suggest just to make sure... =)

    Thanks once again...

    Seth
     
    Seth, Nov 7, 2003
    #5
  6. You're welcome, Seth. Glad to see you got the issue resolved.

    MowGreen [MVP]
     
    Mow Green [MVP], Nov 7, 2003
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.