Windows Update website - KB953297 does not install - running XP SP

Discussion in 'Windows Update' started by culinarykitchens, Oct 17, 2009.

  1. Hi,

    Two days ago, I went to MS Windows Update and 10 out of 11 updates were
    successfully installed.

    During the installation, a pop-up window opened that stated:

    BEGIN POP-UP WINDOW
    Windows ® Installer. V 4.5.6001.22159

    msiexec /Option <Required Parameter> [Optional Parameter]

    Install Options
    </package | /i> <Product.msi>
    Installs or configures a product
    /a <Product.msi>
    Administrative install - Installs a product on the network
    /j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]
    Advertises a product - m to all users, u to current user
    </uninstall | /x> <Product.msi | ProductCode>
    Uninstalls the product
    Display Options
    /quiet
    Quiet mode, no user interaction
    /passive
    Unattended mode - progress bar only
    /q[n|b|r|f]
    Sets user interface level
    n - No UI
    b - Basic UI
    r - Reduced UI
    f - Full UI (default)
    /help
    Help information
    Restart Options
    /norestart
    Do not restart after the installation is complete
    /promptrestart
    Prompts the user for restart if necessary
    /forcerestart
    Always restart the computer after installation
    Logging Options
    /l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile>
    i - Status messages
    w - Nonfatal warnings
    e - All error messages
    a - Start up of actions
    r - Action-specific records
    u - User requests
    c - Initial UI parameters
    m - Out-of-memory or fatal exit information
    o - Out-of-disk-space messages
    p - Terminal properties
    v - Verbose output
    x - Extra debugging information
    + - Append to existing log file
    ! - Flush each line to the log
    * - Log all information, except for v and x options
    /log <LogFile>
    Equivalent of /l* <LogFile>
    Update Options
    /update <Update1.msp>[;Update2.msp]
    Applies update(s)
    /uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>
    Remove update(s) for a product
    Repair Options
    /f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
    Repairs a product
    p - only if file is missing
    o - if file is missing or an older version is installed (default)
    e - if file is missing or an equal or older version is installed
    d - if file is missing or a different version is installed
    c - if file is missing or checksum does not match the calculated value
    a - forces all files to be reinstalled
    u - all required user-specific registry entries (default)
    m - all required computer-specific registry entries (default)
    s - all existing shortcuts (default)
    v - runs from source and recaches local package
    Setting Public Properties
    [PROPERTY=PropertyValue]

    Consult the Windows ® Installer SDK for additional documentation on the
    command line syntax.

    Copyright © Microsoft Corporation. All rights reserved.
    Portions of this software are based in part on the work of the Independent
    JPEG Group.
    END POP-UP WINDOW

    The only option available with the above pop-up window was to click on the
    OK button, and it closed. Unfortunately, as I discovered, this pop-up window
    was associated with the 11th update that did not install. This 11th, did not
    install and it is defined as:

    Microsoft .NET Framework 1.1 Service Pack 1 Security Update for Windows
    2000, Windows XP, Windows Vista, Windows Server 2008, Windows 7, and Windows
    Server 2008 R2 (KB953297)

    When I check my HISTORY, this update was noted and the ? symbol states:

    Installation Failure
    Error Code: 0x667
    Try to install the update again, or request help from one of the following
    resources.
    For self-help options:
    Frequently Asked Questions
    Find Solutions
    Windows Update Newsgroup
    For assisted support options:
    Microsoft Online Assisted Support (no-cost for issues related to getting
    updates)
    Print | Close

    Prior to posting, I searched the Update Discussion Group and found the
    following member's comment:

    Had same problem.... Solution--Uninstall .Net Framework 1.1 from
    add/remove programs.This automatically removes an earlier hotfix which i
    think is causing the problem.Restart computer and go to windows update as
    normal and check for updates.If all is well you will reinstall .Net Framework
    1.1 and the problem update KB953297 successfully. This worked on both my
    laptops but for some reason i had to try 2 times before the update KB953297
    successfully installed on one of mylaptops. Good luck.. Scott

    I tried Scott's suggestion, and after removing 1.1, I rebooted. Then I went
    to MS Windows Update, it said I needed to install 1.1 - so I did. Then
    rebooted.

    Again, back to MS Windows Update, this time it said I needed to install 1.1
    SP1 (not to be confused with KB953297) - so I did. Then rebooted.

    Once again, back to MS Windows Update, this time it said I needed to install
    KB953297 - so I tried. The same thing happened as described above, during
    the installation, a pop-up window opened that stated... You know the rest.

    I also tried going to the MS Download website, where I downloaded KB953297,
    as the file: NDP1.1sp1-KB953297-X86.exe

    Once again, the same thing happened as described hereinabove, during the
    installation, a pop-up window opened that stated... Once again, you know the
    rest.

    I am running Windows XP SP2 and do not plan on updating to SP3 anytime soon.

    I have Googled this issue and there are TONS of people with the same
    problem, and I have not read a solution that works for most of them - of
    course, Scott's solution appears to work for some - and I am one of those
    people that cannot find a solution.

    Any thoughts?

    Are their any MS-MVPs out there with a solution?

    Thanks in advance,

    Anna
     
    culinarykitchens, Oct 17, 2009
    #1
    1. Advertisements

  2. culinarykitchens

    Glo Guest

    I also had problems installing update KB953297. I received an error message
    ox643. I followed your suggestion of removing Net Framework 1.1. I returned
    to automatic updates and I had no updates to install; therefore it did not
    allow me to update KB953297 or reinstall Net Framework 1.1.
    --
    Glo


     
    Glo, Oct 18, 2009
    #2
    1. Advertisements

  3. Well, Glo, I would suggest you re-read my post - because you will discover
    that it was NOT my suggestion, and you will also discover that you did NOT
    follow Scott's suggestion correctly.

    Still looking for a MS-MVP who can provide the SOLUTION to this issue.

    Calling all MS-MVPs! Calling MS-MVPs!!

    HELP!!!

    Anna
     
    culinarykitchens, Oct 19, 2009
    #3
  4. culinarykitchens

    WYoung Guest

    GMichaels:

    I wasn't able to get this to work with the method you describe. You don't
    need WinRAR for this to work either.

    When you say, "Start this program, then when you
    get the error message, click "browse" and change the folder name to
    where the NETFX* files are located"

    I don't get a browse option only the windows installer command line options
    with OK on the dialog.

    The way I got the update to work is open a command prompt and change the
    directory to where NDP1.1sp1-KB953297-X86.exe is saved.

    For example, if the file is saved at the root c:\ you would execute the
    following command

    C:\>NDP1.1sp1-KB953297-X86.exe /? which will give you the command line
    options for the update.

    You can either run the following command:
    C:\>NDP1.1sp1-KB953297-X86.exe /extract

    Then you will be asked to specify a target directory. Choose a directory
    and a file named NDP1.1sp1-KB953297-X86.msp will be extracted.

    Run this file and you'll be fine.

    You can also specify the target directory in the command line, ex:

    C:\>NDP1.1sp1-KB953297-X86.exe /extract c:\

    Hope this helps!
     
    WYoung, Oct 20, 2009
    #4
  5. culinarykitchens

    WYoung Guest

    What you describe is not an answer to the original post because you're
    getting some prompt that "netfx.msi" is missing. The scenario I'm describing
    is exactly the same as what the OP is getting in which the Windows Installer
    window appears:
    There is only one OK button to close the popup and nothing else. After I
    press OK, nothing happens.

    Some of the steps I described are optional and I explained the easiest, most
    straightforward way which is:
    I don't see how you find my method more difficult to open a command prompt
    and run one command line option on the file than your method using WinRAR.
    Most people I know don't have WinRAR installed and would need to download the
    free trial as well.

     
    WYoung, Oct 21, 2009
    #5
  6. culinarykitchens

    LoynoMOM Guest

    I need to know two things:

    1. Which dir do I choose? what do I type on the command line
    2. How do I run the file? what do I type on the command line

    Novice/Advance user

    LoynoMOM
     
    LoynoMOM, Oct 23, 2009
    #6
  7. PA Bear [MS MVP], Oct 23, 2009
    #7
  8. culinarykitchens

    TECH1 Guest

    Hello,

    I've had the same problem. It just would not update. I tried the easiest way
    possible without opening any command prompts.

    In my add/remove programs I did show Microsoft .NET Framework 1.1 but I
    couldn't remove it, so I downloaded it again which is Microsoft .NET
    Framework Version 1.1 Redistributable Package. After that I downloaded the
    service pack 1.

    I went back to Microsoft Update and it(KB953297) installed successfully.

    1.
    http://www.microsoft.com/downloads/...E3-F589-4842-8157-034D1E7CF3A3&displaylang=en

    2.
    http://www.microsoft.com/downloads/...4f-088e-40b2-bbdb-a83353618b38&displaylang=en

    I hope this helps you and anyone else that ran into this problem.

     
    TECH1, Oct 25, 2009
    #8
  9. culinarykitchens

    tommycn Guest

     
    tommycn, Oct 29, 2009
    #9
  10. culinarykitchens

    hcrone Guest

    I deleted kb953297 and installed the 3.5 version of microsoft .net framework,
    and no more popping op.
     
    hcrone, Oct 29, 2009
    #10
  11. The many more people who have not had any issue installing the patches in
    this thread... I'm sure their systems are just broken in a different way
    than those who have had issues. ;-)

    It's not the patches - it's the systems in 99% of the cases. Not saying
    that Microsoft has not released some bum patches in their day (they
    have/do - most seem to center around hardware (thus my suggestion to not get
    hardware patches from Microsoft for non-Microsoft hardware)) but when a
    patch (or set of patches) does not present trouble on all systems and the
    percentage of issues is relatively small - it is logical to perceive that
    the trouble is not with the patch, but with some unique attribute (set of
    circumstances) on the machines in questions.

    Case in point - SP3. When installed on some HP factory installed systems
    with AMD processors, bad things happened. Turns out that SP3 didn't have
    problems with AMD processors or HP computers or the particular users that
    chose to purchase said combination (whether or not they dutifully kept their
    systems well maintained or not) - but with the original image applied to
    the system by HP being based off their same systems with Intel based
    processors (thus not including some things SP3 patched for when it detected
    AMD processors.)

    This may/may not turn out to be the same case - but so far I have not
    witnessed this issue firsthand - and that is several thousand computers of
    varying configurations and ages and the likes. Doesn't mean I won't,
    doesn't mean much more than I am lucky not to have whatever combination of
    circumstances in any of these machines that causes the issues with these
    patches. However - it does mean that the problem is not universal. Pulling
    the patch because something is wrong with some people's systems - doesn't
    seem to be the right move. ;-)
     
    Shenan Stanley, Oct 29, 2009
    #11
  12. Sorry for the late response, GMichaels. I have been out of town attending
    to family matters.

    I read your supportive reply and then I read WYoung's. With what appeared
    to be less effort, I tried WYoung's first. In short, it worked.

    Thank you for your reply and support - it truly helped to resolve my problem.

    With kindest regards,

    Anna :eek:)
     
    culinarykitchens, Oct 31, 2009
    #12
  13. Sorry for the late response, WYoung. I have been out of town attending to
    family matters.

    It WORKED - - just as you described - - IT WORKED PERFECTLY!!

    Thank you for your reply and support - it resolved my problem in less than 2
    minutes.

    With kindest regards,

    Anna :eek:)
     
    culinarykitchens, Oct 31, 2009
    #13
  14. I'm also having no luck with the update. MS, help!!!!! We need a fix! My
    computer is continually trying to install it to no avail and it's driving me
    nuts!
     
    West Coast Guy, Nov 3, 2009
    #14
  15. By 'luck' - does that mean you just keep trying to install it over and over
    hoping what ever is wrong with your system is fixed without anything being
    done from the last time? *smile*

    1. Download the .NET Cleanup Utility from the following link:
    http://blogs.msdn.com/astebner/attachment/8904493.ashx

    2. Using the .NET Cleanup Utility, uninstall .NET Framework 1.0, 1.1, 2.0,
    3.0 and 3.5. (You'll have to unzip it, run it, etc.)

    3. Restart the computer

    4. Download (save) the following components:
    .. .NET Framework 3.5 SP1 (this will also install .NET Framework 2.0 SP2 and
    3.0 SP2)
    http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7
    .. .NET Framework 1.1
    http://www.microsoft.com/downloads/...FamilyID=262d25e3-f589-4842-8157-034d1e7cf3a3
    .. .NET Framework 1.1 SP1
    http://www.microsoft.com/downloads/details.aspx?familyid=A8F5654F-088E-40B2-BBDB-A83353618B38

    5. Install the downloaded updates in this order (the order is very
    important):
    .. .NET Framework 3.5 SP1
    .. .NET Framework 1.1
    .. .NET Framework 1.1 SP1

    6. Restart the computer

    7. Go to Windows Update then choose CUSTOM update
    http://windowsupdate.microsoft.com/

    8. Under Optional Software Update, check if other versions of .Net Framework
    are being offered
    .. IF No: You are DONE!
    .. IF Yes: See Below...

    If Windows Update is offering .NET Framework and other update(s), install
    the other update(s) before dealing with .NET Framework updates. Reboot
    after installing the other updates and before re-checking for the .NET
    updates. You do not *need* Internet Explorer 8, Windows Live or Office Live
    updates. Everything else - excluding any and all hardware updates - fair
    game. (I did say *need* - so that doesn't mean you should not install those
    things - just that IMO, most people don't *need* them.)
     
    Shenan Stanley, Nov 3, 2009
    #15
  16. culinarykitchens

    slack7639

    Joined:
    Nov 12, 2009
    Messages:
    2
    Likes Received:
    0
    KB953297 won't install

    (these two might be reversed)
    I used the Cleanup Tool to un-install Framework 1.0, and Add/Remove to un-install 1.1 Hotfix

    This MS link led me to the second link (keywords, won't let me post links)

    Article ID: 824643 - Last Review: January 14, 2008 - Revision: 3.4, How to troubleshoot Microsoft .NET Framework 1.1 installation issues in Windows XP or in Windows 2000

    Aaron Stebner's WebLog, More detailed steps to fix .NET Framework install errors that ask for tmpXXXX.tmp

    **********************************

    Windows Update later wants to re-install Framework 1.0 . . .
    so I put Framework 1.0 in my Hidden Updates
    Framework 3.5, and before, can do the job

    *****************************************************

    Summary from:

    Whirlpool . . . » Forums » Windows » Do I need Microsoft .NET Framework ?

    1.1 is stand alone. You have to install it by itself.
    3.5 uses parts of 2.0, it extends it
    3.5 will update 2.0 when you install it

    The version of Framework you need is usually installed, when you install an application that needs it.
    The application might tell you what it needs.
     
    slack7639, Nov 13, 2009
    #16
  17. culinarykitchens

    slack7639

    Joined:
    Nov 12, 2009
    Messages:
    2
    Likes Received:
    0
    .NET Framework and Toggle Flash

    On this page, I read about Toggle Flash: Beware 'frighteningly bad' Flash flaw, say researchers: [LINK - unable to provide the links]

    I installed Toggle Flash, and received this error:
    togflash.exe - Application Error, The application failed to initialize properly (0xc0000135)
    Click on OK to terminate the application

    I read that this error is due to a problem with Framework!

    RealtyWare : Support : Error Messages : The application failed to initialize properly (0xc0000135)
    Cause: The Microsoft .NET Framework is not installed
    Solution: Download and install the Microsoft .NET Framework 2.0
    [LINK]

    At this time, my Framework installation status was as follows:

    I had de-installed:
    1.0
    1.1

    What was installed:
    2.0 SP2
    3.0 SP2
    3.5 SP1

    So why was I getting this error?

    I read: If Framework is already installed, run a repair, by selecting Change/Remove on the Microsoft.NET Framework 2, in Add/Remove programs. This may take 5 or more minutes. Don't forget to reboot after running the repair before re-trying AyaNova again.

    I ran the repair for Framework 2.0, and Toggle Flash still didn't work.

    ********************************************

    I read up on Framework, on wikipedia: [LINK]

    .NET Framework 1.0 is the first release of the .NET Framework, released on 13 February 2002 and available for Windows 98, Me, NT 4.0, 2000, and XP. Mainstream support by Microsoft for this version ended 10 July 2007, and extended support ended 14 July 2009.

    Mainstream support for .NET Framework 1.1 ended on 14 October 2008, and extended support ends on 8 October 2013. Since .NET 1.1 is a component of Windows Server 2003, extended support for .NET 1.1 on Server 2003 will run out with that of the OS - currently 14 July 2015.

    Conclusion: I don't think that I need .NET Framework 1.0, at all.

    ********************************************

    As of today, 11/13/09, per wikipedia, the stable release of Framework is:
    Version 3.5.30729.1 (3.5 SP1) / 2008-08-11; 14 months ago
    [LINK]

    .NET Framework 3.5 was released on 19 November 2007, but it is not included with Windows Server 2008. As with .NET Framework 3.0, version 3.5 uses the CLR of version 2.0. In addition, it installs .NET Framework 2.0 SP1, (installs .NET Framework 2.0 SP2 with 3.5 SP1) and .NET Framework 3.0 SP1 (installs .NET Framework 3.0 SP2 with 3.5 SP1), which adds some methods and properties to the BCL classes in version 2.0 which are required for version 3.5 features such as Language Integrated Query (LINQ). These changes do not affect applications written for version 2.0, however.

    I read up on what the Bootstrapper version is - it figures out what you need, and only installs that:
    [LINK]

    The bootstrapper file is small: dotnetfx35setup.exe, 2.82 MB
    When run, it then downloads another 50MB - this is as opposed to downloading the Full Package of Framework 3.5, 231MB!

    ********************************************

    Since repairing version 2.0 didn't work, it seemed like I needed to do a full de-install, disabling of Startup Programs and Services, running of CCleaner, and a few restarts:

    ********************************************

    I re-ran the Framework clean up tool from here:
    Aaron Stebner's WebLog, More detailed steps to fix .NET Framework install errors that ask for tmpXXXX.tmp
    dotnetfx_cleanup_tool.zip
    [LINK]

    ... but, de-installed *all* versions of Framework this time, not just 1.0 and 1.1

    Results from selecting the different options:
    All - failed - it took a few minutes for me to learn this
    1.0 successful, but it was already de-installed
    1.1 successful, but it was already de-installed
    2.0 successful
    3.0 successful
    3.5 successful
    All - it worked this time, successful
    Restart

    Next:

    msconfig / "Startup" tab / note what's checked / un-check all
    (one may be able to uncheck more, and free up memory, see the Full List at sysinfo org)
    msconfig / "Services" tab / hide all microsoft services / note what's unchecked / disable all
    (8 are there, but "LightScribeService Direct Disc Labeling Service" is not checked)
    Restart

    Run CCleaner - clean Windows, Applications, and Registry
    Restart

    Verify that the Windows files are intact
    (I didn't do this to get Framework to work, but did to get AVG 9.0 Free to work, recently. It think it was causing Standby to hang intermittently. I don't know if this fixed anything, but it's not a bad idea)
    From a DOS prompt - run the System File Checker
    C:\>sfc /purgecache . . . takes one minute - won't work in Safe Mode, the RPC server is unavailable
    C:\>sfc /scannow . . . to verify that all protected Windows files are intact and in their original versions, 10/17/09 24 mins
    Restart

    Install Framework 3.5 through Add/Remove Programs
    Results - It put these back!
    2.0 SP2
    3.0 SP2 . . . in addition to
    3.5 SP1
    Restart

    Put check marks back in "Startup" programs" and "Services"
    Restart

    Toggle Flash works now!

    ********************************************

    And now - Windows Update wants to install:

    Update to .NET Framework 3.5 Service Pack 1 for the .NET Framework Assistant 1.0 x86 (KB963707), Download size: 741 KB , less than 1 minute
    The update to .NET Framework 3.5 Service Pack 1 for the .NET Framework Assistant 1.0 for Firefox addresses several compatibility issues with version 1.0 of the extension.

    Microsoft .NET Framework 3.5 Family Update (KB959209) x86, Download size: 16.8 MB , 2 minutes
    The Microsoft .NET Framework 3.5 Family Update provides compatibility roll-up updates for customer reported issues found after the release of Microsoft .NET Framework 3.5 SP1.

    In an attempt to not run into any glitches, I tried doing these two updates separately, with a Restart in between - starting with the small one first. When I went to do the second one, I found that the small one had not been installed. It appears that they need to be done together at the same time. They installed with no errors.

    Windows Update then had another patch for Framework 2.0 that I found in my Hidden Updates. I don't remember putting it there. I was able to install that also, with no errors.

    ********************************************

    Microsoft .NET Framework version 1.1 remains in my Hidden Updates

    Toggle Flash still works!
     
    slack7639, Nov 14, 2009
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.