Windows Virtual PCs Frequently Stop Responding For Short Periods

Discussion in 'Virtual PC' started by ssarthur2, Nov 24, 2009.

  1. ssarthur2

    ssarthur2 Guest

    I have recently upgraded my computer from Vista to Windows 7 and from Virtual
    PC 2007 to Windows Virtual PC. I have migrated all my Virtual PCs by
    "Upgrading Integration Components".

    But I am experiencing problems which I did not had before. The VPCs
    frequently (once or twice a minute) stop responding for 3 - 5 seconds. This
    is exhibited by the screen stops refreshing and it does not respond to mouse
    or keyboard. When it starts responding again, it typically catches up to
    whatever was being done while it was down.

    The hardware is more than capable (Intel quad core with 8GB RAM), so I don't
    believe its a hardware issue. I have tried running both with Integration
    Feature disabled and enabled, but it doesn't seem to make a difference.

    Has anyone else experienced this? Is there a workaround? This is bad
    enough to drive me back to VPC 2007 which I really don't want to do.
     
    ssarthur2, Nov 24, 2009
    #1
    1. Advertisements

  2. ssarthur2

    Robert Comer Guest

    I've never seen this on a quad core machine, but it's a power
    management issue. You can try setting the power management to highest
    performance but it might not help.

    The only thing I've seen that can effect it is to run a low priority
    task in the background that forces the CPU to stay in the full
    performance state. I use [email protected] Boinc project on my laptop when
    I'm running a VM...

    No other workaround at present. Apparently the one's who programmed
    the BIOS on some machines turn off bits in a power management state
    that WVPC rely on.
     
    Robert Comer, Nov 24, 2009
    #2
    1. Advertisements

  3. ssarthur2

    ssarthur2 Guest

    Thanks Bob. I appreciate the help. I am running the BOINC Manager in one
    Virtual PC and it seems to do the trick. More than that, if I have multiple
    Virtual PCs running, it actually seems to eliminate the problem in all open
    PCs at the same time.

    I do hope this is an issue that's being worked by the Virtual PC team.
    While this does work, it's a pretty cheesy work-around.
     
    ssarthur2, Nov 30, 2009
    #3
  4. ssarthur2

    Robert Comer Guest

    I do hope this is an issue that's being worked by the Virtual PC team.
    Agreed.
     
    Robert Comer, Nov 30, 2009
    #4
  5. ssarthur2

    ssarthur2 Guest

    Just thought I would post a followup here for anyone who has experienced the
    same issue.

    Running a low-priority task did not fix the problem as I originally thought.
    Rather, this is an issue that seems to vary with time, sometimes worse,
    sometimes better. After watching things for a while, I decided that the
    low-priority task was not making a difference in my performance.

    I finally ended up abandoning Windows Virtual PC and returning to Virtual PC
    2007. It saddens me to lose some of the nice features in the newer software,
    but I had no choice because the loss of productivity was becoming
    significant. Rolling back immediately sped up all my virtual machines.

    I will say that going back was fairly painless. I just had to reinstall the
    Virtual Machine Additions.
     
    ssarthur2, Mar 13, 2010
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.