Windows Vista strange settings on temp folder AppData\Local\Temp\1

Discussion in 'Windows Vista Security' started by Nick, May 6, 2009.

  1. Nick

    Nick Guest

    First off, i am trying to figure out what causes my temp folder to move from
    AppData\Local\Temp to AppData\Local\Temp\1. When i log out and log back in,
    then it becomes AppData\Local\Temp\2.

    Secondly, the AppData\Local\Temp\1 folder has strange permissions, where it
    has these users and groups listed:
    NULL SID
    Everyone
    SYSTEM
    CREATOR OWNER
    CREATOR GROUP

    each item has 0 permssions.

    Lastly, my app trys to write to this folder using C++ ::CopyFile. It
    crashes rather than returning fasle.
    Thanks for any suggestions.
    Nick Bauer
     
    Nick, May 6, 2009
    #1
    1. Advertisements

  2. Ǝиçεl, May 7, 2009
    #2
    1. Advertisements

  3. Nick

    Mordecai Guest

    I too am having this problem. What's really strange is that %TEMP% takes me
    to the AppData\Local\Temp\2 directory, but the value for TEMP in advanced
    system settings -> Environment Variables is set to AppData\Local\Temp
    (without the 2). These settings are the same for the administrator and the
    user (obviously they are using different base directories).

    Another note: It appears that some files are dumped to AppData\Local\Temp
    while others are dumped to AppData\Local\Temp\2. I don't see any patterns
    here yet except that the \2 directory has less files.
     
    Mordecai, May 13, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.