WindowsUpdate_00000643

Discussion in 'Windows Update' started by DarkStone1979, Jul 18, 2007.

  1. I keep getting this error no matter how many reboots I attempt- it's for the
    installation of the recent KB929729 security update.

    Any insight?
     
    DarkStone1979, Jul 18, 2007
    #1
    1. Advertisements

  2. See if this helps to resolve the issue:

    When you try to install an update for the .NET Framework 1.0, 1.1, or
    2.0, you may receive Windows Update error code "0x643" or Windows
    Installer error code "1603"
    http://support.microsoft.com/kb/923100/


    MowGreen [MVP 2003-2007]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen [MVP], Jul 19, 2007
    #2
    1. Advertisements

  3. It's a no-go; running the uninstall on .Net Framework 1.1 just fails after I
    confirm that I want to remove it. I decided I could run the clean up app
    anyway, but still no luck with the update.

     
    DarkStone1979, Jul 19, 2007
    #3
  4. DarkStone1979

    JCO Guest

    If it fails on the uninstall, try the repair first. After the repair, you
    should be able to uninstall it.

     
    JCO, Jul 20, 2007
    #4

  5. Before allowing the reboot try to find out what it wants to do.
    E.g. use the Event viewer which will show you what modules were in use
    and hence have to be put in the PendingFileRenameOperations list.

    Find the PendingFileRenameOperations list in the registry and verify
    that all of the modules mentioned in the Event viewer are there.
    It is useful to capture that list in a Notepad window and save it,
    since it will not survive a boot and you will want to refer to it after
    the boot.

    (Optionally) check the versions of those modules and compare them against
    the appropriate File Information list in here:

    http://www.microsoft.com/technet/security/bulletin/ms07-040.mspx


    Do you have any security apps active (or which will become active after
    the boot) which might interfere with those PendingFileRenameOperations?
    If so, disable them. In some cases it is known that an app's disabling feature
    is not sufficient (e.g. it may still leave bits of itself active enough to continue
    interfering), in which case it may have to be uninstalled.

    Allow the boot.

    After the boot recheck the modules which should have been updated
    by the PendingFileRenameOperations. If they *all* haven't been copied
    (or the copies renamed) it would explain your symptom.


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Jul 20, 2007
    #5
  6. I get the same error message when trying to install the update.

    I don't understand how to fix it. The update tries to reload every day,
    based on my settings, and I can't get it to take.
     
    Michael Heggarty, Jul 23, 2007
    #6
  7. DarkStone1979

    dntbegley Guest

    I have Vista Home Premium too and also had the 643 error message trying
    download the .NET 1.1 security update. However, I found a different way to
    install it, and it worked.

    After it goes RED saying that the update failed, click on the 'View missing
    updates' link and it will list that download again.

    Select it and click Install at the bottom.

    I dont know if it's just plain luck but it worked for me!!!
    --
    dnt


     
    dntbegley, Jul 26, 2007
    #7
  8. DarkStone1979

    Houdi Guest

    Hi Michael
    I have managed to solve this problem. Go to the link below
    http://support.microsoft.com/kb/922377
    Scroll down to Method 2 point 9 click on the link and install .Net 1.1. once
    the down load has been completed download the service pack and restart the
    computer. If the download icon still remains on your task bar download again
    and should be accepted and the icon will disappear.

    Good luck
     
    Houdi, Jul 30, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.