Wireless networking - "Identifying ...(Public Network).."

Discussion in 'Windows Vista Networking' started by The Thinker, Feb 4, 2007.

  1. The Thinker

    The Thinker Guest

    Hi,

    I'm having a strange wireless networking problem. I defined a private
    network in Vista, complete with wireless network connection & key.

    When I reboot my laptop, it does not auto re-connect to this (only
    network I have defined), instead it tries to create a new public
    network (message "Identifying ...(Public Network).." appear in Network
    and Sharing Centre), with access type of Local Only - i.e. no internet
    access - but it does pick up the wireless sid name / key etc.

    At this point, the machine has a local ip address 169.254 ..., it has
    not picked up one from the router (but has picked up the DNS server
    addresses).

    The only way I can resolve this is to click on the red cross that
    appears in the network and sharing center window on the link to the
    world / internet image, where upon I get various options, 1 of which
    is renew IP address for the wireless adaptor. Do this and then it
    connects fine to my pre-defined private network.

    My network works fine on XP machines.

    Any help greatly appreciated!

    Thanks,
    Josh
     
    The Thinker, Feb 4, 2007
    #1
    1. Advertisements

  2. The Thinker

    Birdman2000 Guest

    I noticed that this post was written in 2007. I'm having the exact same
    problem and we are now in 2008!!!! Microsoft, where is the
    solution????? Does anyone have the solution to this very irritating
    problem?

    Thank you!

    Rick
     
    Birdman2000, Jul 2, 2008
    #2
    1. Advertisements

  3. The Thinker

    Birdman2000 Guest

    I found the solution to this irritating problem on a different support
    website. I can't find the original solution post to give them proper
    credit (and post a thank you). Anyway, here is the Microsoft KB for the
    solution: 'Windows Vista cannot obtain an IP address from certain
    routers or from certain non-Microsoft DHCP servers'
    (http://support.microsoft.com/kb/928233)
     
    Birdman2000, Jul 3, 2008
    #3
  4. The Thinker

    WitchyAnne Guest

    OK,new to this side of things

    Should it really say {guid} or can it be a series of numbers an
    letters

    Mine don't look like

    Code
     
    WitchyAnne, Aug 7, 2008
    #4
  5. The Thinker

    jliming Guest

    By the way, I did find and already tried the Microsoft KB solution:

    'Windows Vista cannot obtain an IP address from certain routers or fro
    certain non-Microsoft DHCP servers
    (http://support.microsoft.com/kb/928233

    with no success

    Ja
     
    jliming, Sep 3, 2008
    #5
  6. The Thinker

    gtghip Guest

    Try this!:)

    I had this problem with my laptop also.
    I restarted the laptop with the wireless connection switch shut off.
    After reboot was complete, then I turned the switch back on.
    Then open control panel, Network & Sharing Center.
    Should be your default network now & private network status.
    Across from that click Customize.
    At the bottom of the pop-up click 'Merge or delete Network Locations'.
    In the pop-up if there is a Network that is not in use delete it, the
    close/cancel the remaining open windows.
    I have a third party software firewall (Comodo) installed on my lapto
    which I use and thought I had the windows firewall disable but I guesse
    wrong.
    So I went to start menu, control panel, windows firewall, and foun
    that even though I had it turned off it was still monitoring my system.
    To disable the Windows Firewall on a network connection:

    1. Click Start and click Control Panel.
    2. Click then select Windows Firewall.
    3. Click Change Settings.
    4. From the window that appears, click the Advanced tab.
    5. Remove the check beside the connection that you want to disabl
    the Windows Firewall for.
    6. Click OK.
    Then from the start menu, run command, type 'services.msc' without th
    quotation marks.
    Find windows firewall, highlight and right click, then clic
    properties.
    At service status click Stop.
    Then from the 'startup type' drop down menu click 'Disabled'.
    Click Apply, then OK.
    Reboot.
    After the reboot I received a window asking what type of network
    would like, I chose Home/Private.
    Then Control Panel, Network & Sharing Center.
    Should be a Private Network now, click Customize.
    In open window click Merge or Delete Network locations.
    If there are 2 click on the 1 not being used then click Merge.
    In the open window select the 1 being used and click Merge, Apply/OK.
    That's all folks, good to go
     
    gtghip, Apr 16, 2010
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.