WLAN AutoConfig Service failed to start

Discussion in 'Windows Vista Networking' started by Dylan, Nov 27, 2007.

  1. Dylan

    Dylan Guest

    Hi,

    I'm getting event id 4002. Message says "WLAN AutoConfig Service has failed
    to Start." Error Code 2147746132. Second event ID 7023. Message says "The
    WLAN AutoConfig service terminated with the following error: Class not
    registered.

    I'm not able to connect to any wireless network due to this service not
    starting. Any suggestion on what may be the problem and how to fix it?

    Thanks,
    Dylan
     
    Dylan, Nov 27, 2007
    #1
    1. Advertisements

  2. Dylan

    david.hefner Guest

    I'm getting the same thing after installing the newest Zune 2.1
    software. and not finding much out there about fixing it either :(.
     
    david.hefner, Nov 28, 2007
    #2
    1. Advertisements

  3. Dylan

    Dylan Guest

    I started having this problem after installing Zune 2.1 as well. I didn't
    mention it in my first post because I wasn't sure if that's really the cause.
    Now that you and I are having the same issue, I think its no coincident.
    Normally the fix for this type of error is to re-register the dll for the
    service but I couldn't find any reference to it. I ended up using the
    original Vista CD that I installed my notebook with and "upgraded" itself
    again. Essentially, its a repair of the system file and registry keys and
    leaving third party programs and files untouched. I did also ran this,
    http://remove-it.org/tools/unzoone, before the "upgrade".
     
    Dylan, Nov 28, 2007
    #3
  4. Dylan

    david.hefner Guest

    I'm going to try the same thing when I get home this evening (usually
    carry my DVD in my bag, but took all that stuff out last week, lol).
    I figured the repair install would fix it though. Have you reinstall
    the Zune 2.1 software after the 'upgrade'? Also, did you initially
    have problems upgrading the Zune software before you had problems with
    the wlan? My firewall was turned off, so the install kept failing at
    100%, so I removed the old zune software, rebooted, reinstalled the
    new software, and that's when I noticed I was having wlan problems...
     
    david.hefner, Nov 28, 2007
    #4
  5. Dylan

    Dylan Guest

    After the "upgrade", zune 2.1 installed perfectly. I pretty much went
    through the same thing you did. WLAN was working fine before the Zune
    upgrade. Everything hit the fan after 2.1 install failed. I tried the Zune
    package that the error screen linked but the xml patch in the package is
    what's not installing. I too noticed I have no wireless connection after
    rebooting the PC.
     
    Dylan, Nov 28, 2007
    #5
  6. Dylan

    mylespInNZ Guest

    I had the exact same error (Error code 3 - path not found - The syste
    cannot find the path specified.). By using process monitor, I foun
    that it was looking for a folder C:\Windows\L2Schemas\.

    This did not exist on my install. By creating this folder (with th
    correct access rights) and then getting the files that are require
    (WLAN_profile_v1.xsd etc - these are the Zero config Wireless la
    config files ) from another install fixed the problem.

    I found if the content of these files is corrupted, then the servic
    starts to fail with all sorts of errors e.g. 2147500037, 2148270086
    depending on the actual file contents - i.e valid XML etc. The order o
    the content is also important according to the microsoft techne
    documentation
     
    mylespInNZ, May 23, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.