WM5 can not sync to exchange

Discussion in 'Windows Small Business Server' started by John, Jan 15, 2007.

  1. John

    John Guest

    My mobile device is running WM5 and my exchange server is a SBS2003 SP1
    running ISA 2004

    The Exchange server has a self issued certificate that is trusted by the
    mobile device.

    The system worked correctly for over a year, but began failing last night
    after changing some DNS entries. these entries have been changed back but
    errors continue.

    No errors are found in the event log.

    The mobile device is able to access the server, both when connected to a
    internal desktop computer, and over the mobile GPRS but it fails to sync in
    both cases.

    The following error message is received from active sync. Activesync
    encountered a problem on the server. Support Code:85010014

    Please note the HTTP 500 error received at the end of the Activesync log.

    __________________________________________________________________________
    Below are 2 connection attempts, the first internal, the second external.
    IIS Log
    //internal
    24.41.36.98, myDomain\userName, 1/14/2007, 18:16:44, W3SVC1, myServer,
    10.0.0.1, 15, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    24.41.36.98, myDomain\userName, 1/14/2007, 18:16:50, W3SVC1, myServer,
    10.0.0.1, 5438, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    24.41.36.98, myDomain\userName, 1/14/2007, 18:17:02, W3SVC1, myServer,
    10.0.0.1, 0, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    24.41.36.98, myDomain\userName, 1/14/2007, 18:17:08, W3SVC1, myServer,
    10.0.0.1, 5375, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    //external
    208.54.14.19, myDomain\userName, 1/14/2007, 18:23:17, W3SVC1, myServer,
    10.0.0.1, 15, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    208.54.14.19, myDomain\userName, 1/14/2007, 18:23:25, W3SVC1, myServer,
    10.0.0.1, 5500, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    208.54.14.19, myDomain\userName, 1/14/2007, 18:23:31, W3SVC1, myServer,
    10.0.0.1, 0, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    208.54.14.19, myDomain\userName, 1/14/2007, 18:23:38, W3SVC1, myServer,
    10.0.0.1, 5391, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    _________________________________________________________________________

    Below is an activesync verbose error log
    _________________________________________________________________________
    =-= Build 14847 =-=
    =-= No XIP Information Available =-=
    myExternalFQDN

    =-=- [14/1/2007 18:29:50.0] -=-=
    =-=-=-= Client Request =-=-=-=
    OPTIONS
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone
    Accept-Language: en-us
    MS-ASProtocolVersion: 2.5
    X-MS-PolicyKey: 0

    -=-=-=- Start of Body -=-=-=-


    =-=- [14/1/2007 18:29:51.0] -=-=
    =-=-=-= Server Response =-=-=-
    HTTP/1.1 200 OK
    Connection: Keep-Alive
    Content-Length: 0
    Date: Mon, 15 Jan 2007 02:29:51 GMT
    Server: Microsoft-IIS/6.0
    MicrosoftOfficeWebServer: 5.0_Pub
    X-Powered-By: ASP.NET
    Pragma: no-cache
    Public: OPTIONS, POST
    Allow: OPTIONS, POST
    MS-Server-ActiveSync: 6.5.7638.1
    MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
    MS-ASProtocolCommands:
    Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping


    -=-=-=- Start of Body -=-=-=-


    =-=- [14/1/2007 18:29:51.0] -=-=
    =-=-=-= Client Request =-=-=-=
    POST
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync
    Accept-Language: en-us
    MS-ASProtocolVersion: 2.5
    Content-Type: application/vnd.ms-sync.wbxml
    X-MS-PolicyKey: 0

    -=-=-=- Start of Body -=-=-=-
    <?xml version="1.0" encoding="utf-8"?><FolderSync
    xmlns="FolderHierarchy:"><SyncKey>0</SyncKey></FolderSync>

    =-=- [14/1/2007 18:29:57.0] -=-=
    =-=-=-= Server Response =-=-=-
    HTTP/1.1 500 Internal Server Error
    Connection: Keep-Alive
    Content-Length: 56
    Date: Mon, 15 Jan 2007 02:29:57 GMT
    Content-Type: text/html
    Server: Microsoft-IIS/6.0
    MicrosoftOfficeWebServer: 5.0_Pub
    X-Powered-By: ASP.NET
    Pragma: no-cache
    MS-Server-ActiveSync: 6.5.7638.1



    Thank you for looking this over,
    John
     
    John, Jan 15, 2007
    #1
    1. Advertisements

  2. Hello John,

    Thanks for posting here.

    From your post, my understanding on this issue is: You encountered support
    code 85010014 during ActiveSync with SBS. If I'm off base, please feel free
    to let me know.

    Based on my knowledge, support code 85010014 means error HTTP 500. I
    suggest we try the following steps to see if we can resolve this issue:

    Step 1: For you change the DNS, I suggest you to Rerun CEICW to recreate
    the self issued certificate

    Go through the follow KB and Rerun CEICW again carefully.

    How to configure Internet access in Windows Small Business Server 2003
    http://support.microsoft.com/kb/825763/en-us

    Detailed steps for your reference:

    1. On the SBS 2003 Server open the Server Management console. Go to
    Standard Management\To Do List.

    2. Click the "Connect to the Internet" link.

    3. When navigating to the Firewall page, select "Enable firewall" and click
    Next (I suppose you have 2 network adapters in SBS 2003).

    4. On the "Services Configuration" page, select all the items and then
    click Next.

    5. On the "Web Services Configuration" page, make sure "Allow access to the
    entire Web site from the Internet" is selected. If you select "Allow access
    to only the following Web site services from the Internet", make sure all
    item in the list are selected. Click Next.

    6. On the "Web Server Certificate" page, choose to create a new Web server
    certificate and then type the public FQDN (your new DNS name) that you will
    use to access ActiveSync and OMA (for example, if your public FQDN that you
    use to access the sites is mail.xyz.com, you should type mail.xyz.com as
    the new certificate name).

    7. Go through the remaining steps.

    Step 2: The error often happens when the authentication method is not
    configured correctly in ActiveSync, OMA and Exchange-OMA virtual directory.

    Please verify Authentication settings by the following steps.

    For Exchange-oma virtual directory:

    1. Open IIS Manager
    2. Open properties of virtual directory Exchange-oma
    3. Select Directory Security tab
    4. Select Edit in Authentication and access control box. Make sure the
    authentication setting as below:

    Authentication Methods
    Enabled Basic authentication
    Enabled Integrated Windows authentication
    Disabled anonymous access

    For OMA virtual directory and Microsoft-Server-ActiveSync virtual directory:

    1. Open IIS Manager
    2. Open properties of OMA virtual directory and Microsoft-Server-ActiveSync
    virtual directory respectively.
    3. Select Directory Security tab
    4. Select Edit in Authentication and access control box. Make sure the
    authentication setting as below:

    Authentication Methods
    Uncheck Enable anonymous access
    Uncheck Integrated Windows authentication
    Check Basic authentication

    After that, please restart the IIS Admin Service (services.msc) and then
    verify the issue.

    If the issue persists after steps above, in order to have a more concrete
    idea about the issue, please let me know the following info.

    1. Does issue happen to accessing mailbox by OMA? For further test, please
    login Exchange Server itself, and access URL: http://SBS_Server/OMA, verify
    whether you can access the mailbox successfully.

    2. Do all the users have such issue or just specific users? Please create a
    new mail-enabled user and verify whether he can access mailbox by
    ActiveSync.

    3. Collect the IIS metabase on Exchange Server and send to me:
    for further analysis:

    1). On Exchange Server, install .NET Framework Version 1.1:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=262d25e3-f589-4842-
    8157-034d1e7cf3a3&DisplayLang=en.
    2). Install MBExplorer by installing IIS 6 Resource Kit Tools:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=56FC92EE-A71A-4C73-
    B628-ADE629C89499&displaylang=en.
    3). Once it is installed, access it from Start, Programs, IIS Resources,
    Metabase Explorer.
    4). In the left pane, right click ''LM'' (under your server computer name)
    to choose ''Export to file'', and then save it as IIS.mbk.
    5). Compress this mbk file and send it to me for analysis. Please let me
    know the password if you set on this iis mbk file.

    4. Please collect the IIS log on Exchange Server so that I can perform
    further research:

    1). On Exchange Serves, open IIS MMC, right click Default Web Site and then
    click Properties.
    2). Click Website tab and then check Enable logging.
    3). Stop the Default Website and RENAME the existing IIS log files under
    C:\WINDOWS\system32\LogFiles\W3SVC1.
    4). Restart the Default Website and reproduce the problem, which will
    generate new IIS log file with the exact error.
    5). Wait for a while so that IIS Log can be synced. And then go to the
    following folder on Exchange Server: C:\WINDOWS\system32\LogFiles\W3SVC1.
    6). Send me the log files to my working email address
    . And please let me know the alias of the user who
    encountered the issue.

    5. For further test, please temporarily disable SSL if you enable it for
    ActiveSync; create a new test account and let me know the following
    information.

    - Credential of this test account
    - The public URL of your Exchange Server
    - Domain name

    I will access the mailbox by ActiveSync in my side to verify the issue. To
    keep these confidential, please let me know by mail:

    Hope this helps. Please let me know the results so that I can provide
    further assistance on this problem. I am looking forward to your reply.

    Thanks and have a nice day!

    Best regards,

    Terence Liu(MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
    | From: "John" <johnAtUnwantedmailDotCom>
    | Subject: WM5 can not sync to exchange
    | Date: Sun, 14 Jan 2007 18:37:47 -0800
    | Lines: 122
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
    | X-RFC2646: Format=Flowed; Original
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
    | Message-ID: <>
    | Newsgroups:
    microsoft.public.exchange.admin,microsoft.public.exchange.mobility,microsoft
    .public.windows.server.sbs
    | NNTP-Posting-Host: user-0c2i932.cable.earthlink.net 24.41.36.98
    | Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP04.phx.gbl
    | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.exchange.mobility:129
    microsoft.public.windows.server.sbs:10194
    microsoft.public.exchange.admin:6974
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | My mobile device is running WM5 and my exchange server is a SBS2003 SP1
    | running ISA 2004
    |
    | The Exchange server has a self issued certificate that is trusted by the
    | mobile device.
    |
    | The system worked correctly for over a year, but began failing last night
    | after changing some DNS entries. these entries have been changed back but
    | errors continue.
    |
    | No errors are found in the event log.
    |
    | The mobile device is able to access the server, both when connected to a
    | internal desktop computer, and over the mobile GPRS but it fails to sync
    in
    | both cases.
    |
    | The following error message is received from active sync. Activesync
    | encountered a problem on the server. Support Code:85010014
    |
    | Please note the HTTP 500 error received at the end of the Activesync log.
    |
    | __________________________________________________________________________
    | Below are 2 connection attempts, the first internal, the second external.
    | IIS Log
    | //internal
    | 24.41.36.98, myDomain\userName, 1/14/2007, 18:16:44, W3SVC1, myServer,
    | 10.0.0.1, 15, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | 24.41.36.98, myDomain\userName, 1/14/2007, 18:16:50, W3SVC1, myServer,
    | 10.0.0.1, 5438, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | 24.41.36.98, myDomain\userName, 1/14/2007, 18:17:02, W3SVC1, myServer,
    | 10.0.0.1, 0, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | 24.41.36.98, myDomain\userName, 1/14/2007, 18:17:08, W3SVC1, myServer,
    | 10.0.0.1, 5375, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | //external
    | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:17, W3SVC1, myServer,
    | 10.0.0.1, 15, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:25, W3SVC1, myServer,
    | 10.0.0.1, 5500, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:31, W3SVC1, myServer,
    | 10.0.0.1, 0, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:38, W3SVC1, myServer,
    | 10.0.0.1, 5391, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | _________________________________________________________________________
    |
    | Below is an activesync verbose error log
    | _________________________________________________________________________
    | =-= Build 14847 =-=
    | =-= No XIP Information Available =-=
    | myExternalFQDN
    |
    | =-=- [14/1/2007 18:29:50.0] -=-=
    | =-=-=-= Client Request =-=-=-=
    | OPTIONS
    |
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=Sma
    rtPhone
    | Accept-Language: en-us
    | MS-ASProtocolVersion: 2.5
    | X-MS-PolicyKey: 0
    |
    | -=-=-=- Start of Body -=-=-=-
    |
    |
    | =-=- [14/1/2007 18:29:51.0] -=-=
    | =-=-=-= Server Response =-=-=-
    | HTTP/1.1 200 OK
    | Connection: Keep-Alive
    | Content-Length: 0
    | Date: Mon, 15 Jan 2007 02:29:51 GMT
    | Server: Microsoft-IIS/6.0
    | MicrosoftOfficeWebServer: 5.0_Pub
    | X-Powered-By: ASP.NET
    | Pragma: no-cache
    | Public: OPTIONS, POST
    | Allow: OPTIONS, POST
    | MS-Server-ActiveSync: 6.5.7638.1
    | MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
    | MS-ASProtocolCommands:
    |
    Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateColle
    ction,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,F
    olderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,Vali
    dateCert,Provision,Search,Notify,Ping
    |
    |
    | -=-=-=- Start of Body -=-=-=-
    |
    |
    | =-=- [14/1/2007 18:29:51.0] -=-=
    | =-=-=-= Client Request =-=-=-=
    | POST
    |
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=Sma
    rtPhone&Cmd=FolderSync
    | Accept-Language: en-us
    | MS-ASProtocolVersion: 2.5
    | Content-Type: application/vnd.ms-sync.wbxml
    | X-MS-PolicyKey: 0
    |
    | -=-=-=- Start of Body -=-=-=-
    | <?xml version="1.0" encoding="utf-8"?><FolderSync
    | xmlns="FolderHierarchy:"><SyncKey>0</SyncKey></FolderSync>
    |
    | =-=- [14/1/2007 18:29:57.0] -=-=
    | =-=-=-= Server Response =-=-=-
    | HTTP/1.1 500 Internal Server Error
    | Connection: Keep-Alive
    | Content-Length: 56
    | Date: Mon, 15 Jan 2007 02:29:57 GMT
    | Content-Type: text/html
    | Server: Microsoft-IIS/6.0
    | MicrosoftOfficeWebServer: 5.0_Pub
    | X-Powered-By: ASP.NET
    | Pragma: no-cache
    | MS-Server-ActiveSync: 6.5.7638.1
    |
    |
    |
    | Thank you for looking this over,
    | John
    |
    |
    |
     
    Terence Liu [MSFT], Jan 16, 2007
    #2
    1. Advertisements

  3. John

    John Guest

    Hi Terence,

    Thank you for your help.

    I ran the internet connection wizard as you requested, I also configured my
    ISA listeners to use a certificate issued by a CA trusted by my device.

    I checked all the authentication settings and they are as you requested.
    After running the internet connection wizard I had to uncheck the Require
    SSL box in the Exadmin virtual directory so that the mobileadmin would work.

    The mobile device is able to access OMA

    I created another user, this new user account experienced the same problems.

    I haven't had the chance to install the programs you requested but I did
    gather my IIS information for you.

    I'm not sure how to disable SSL for activesync the
    Microsoft-Server-Activesync folder doesn't require SSL, I hope that is as
    you requested.

    I have emailed you the test user information and also the files.



     
    John, Jan 16, 2007
    #3
  4. John

    Mike Cook Guest

    John

    I have run into similar situations using WM5 on Verizon's EVDO network. My
    symptoms were:
    Verizon wireless customers were unable to sync, but I don't remember the
    exact error code
    Sprint wireless customers were able to sync.
    I finally tracked down the problem with the help of the Verizon Wireless
    techsupport people. Verizon was compressing the data and Exchange 2003 SP2
    comes with compression turned on. The thought was the 2 compression
    algorithms were incompatible. The Verizon tech stepped me through disabling
    compression for the HTTP virtual server using MetaBase editor and that
    solved my problem.
     
    Mike Cook, Jan 16, 2007
    #4
  5. John

    John Guest

    Thanks for the input Mike,

    My connection also fails when connected to a desktop computer or over WiFi.
    I think my problem lies on my server and not on my carrier.

    -John

     
    John, Jan 16, 2007
    #5
  6. John

    John Guest

    I'm having trouble emailing the files to you.

    Below is the message I've received.

    --------------------------------------------
    Reporting-MTA: dns;MYDOMAIN.com

    Final-Recipient: rfc822;
    Action: delayed
    Status: 4.4.7
    Will-Retry-Until: Thu, 18 Jan 2007 02:06:53 -0800
    X-Display-Name: ''

    --------------------------------------------------------------


     
    John, Jan 17, 2007
    #6
  7. Hello John,

    Thank you for kind update.

    Please send email to my work mailbox: with subject
    of this post's title.

    Note: please gather IIS metabase via the tool and send it to me, it is
    important for troubleshooting this issue.

    Synchronizing your Pocket PC with Outlook (client sync) or Exchange server
    directly (server sync): SBS 2003 supports ActiveSync via a client, or
    Server ActiveSync if you have remote connectivity to the server via the
    PDA. For example, you could use a Pocket PC Phone Edition 2003 device, or
    SmartPhone to use Server ActiveSync to sync your Inbox, Calendar, and/or
    Contacts.

    If you are using client ActiveSync, as this feature is closely related to
    the Pocket PC model you are using and the manufacturer's design, please
    contact the Pocket PC provider or the Microsoft public Pocket PC newsgroup
    for assistance. The public newsgroups are:

    news://news.microsoft.com/microsoft.public.pocketpc
    news://news.microsoft.com/microsoft.public.pocketpc.activesync

    This is in order to make sure that this issue is efficiently addressed.
    Thank you for your understanding.

    Meanwhile, the client host machine must be configured using the SBS Set Up
    Computer Wizard. During the Set Up Computer Wizard, the option to install
    ActiveSync 3.7 must be configured as well. If this is pushed to the client
    machine, then there will be an option in the Start Menu called Mobile
    Device Configuration. Then, it should be able to provision your phone or
    PPC (including installing the certificat) so that the Server ActiveSync
    works.

    Please also let me know some more info:

    1. Try to use another mobile device to do ActiveSync, does it work?

    2. Does the account admin can access activeSync?

    3. Does the new account can access OMA?

    Hope this helps. Please let me know the results so that I can provide
    further assistance on this problem. I am looking forward to your reply.

    Thanks and have a nice day!

    Best regards,

    Terence Liu(MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
    | From: "John" <johnAtUnwantedmailDotCom>
    | References: <>
    <>
    | Subject: Re: WM5 can not sync to exchange
    | Date: Tue, 16 Jan 2007 18:00:12 -0800
    | Lines: 386
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
    | X-RFC2646: Format=Flowed; Original
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
    | Message-ID: <#P$>
    | Newsgroups: microsoft.public.windows.server.sbs
    | NNTP-Posting-Host: user-0c2i932.cable.earthlink.net 24.41.36.98
    | Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP02.phx.gbl
    | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:10809
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | I'm having trouble emailing the files to you.
    |
    | Below is the message I've received.
    |
    | --------------------------------------------
    | Reporting-MTA: dns;MYDOMAIN.com
    |
    | Final-Recipient: rfc822;
    | Action: delayed
    | Status: 4.4.7
    | Will-Retry-Until: Thu, 18 Jan 2007 02:06:53 -0800
    | X-Display-Name: ''
    |
    | --------------------------------------------------------------
    |
    |
    | | > Hello John,
    | >
    | > Thanks for posting here.
    | >
    | > From your post, my understanding on this issue is: You encountered
    support
    | > code 85010014 during ActiveSync with SBS. If I'm off base, please feel
    | > free
    | > to let me know.
    | >
    | > Based on my knowledge, support code 85010014 means error HTTP 500. I
    | > suggest we try the following steps to see if we can resolve this issue:
    | >
    | > Step 1: For you change the DNS, I suggest you to Rerun CEICW to recreate
    | > the self issued certificate
    | >
    | > Go through the follow KB and Rerun CEICW again carefully.
    | >
    | > How to configure Internet access in Windows Small Business Server 2003
    | > http://support.microsoft.com/kb/825763/en-us
    | >
    | > Detailed steps for your reference:
    | >
    | > 1. On the SBS 2003 Server open the Server Management console. Go to
    | > Standard Management\To Do List.
    | >
    | > 2. Click the "Connect to the Internet" link.
    | >
    | > 3. When navigating to the Firewall page, select "Enable firewall" and
    | > click
    | > Next (I suppose you have 2 network adapters in SBS 2003).
    | >
    | > 4. On the "Services Configuration" page, select all the items and then
    | > click Next.
    | >
    | > 5. On the "Web Services Configuration" page, make sure "Allow access to
    | > the
    | > entire Web site from the Internet" is selected. If you select "Allow
    | > access
    | > to only the following Web site services from the Internet", make sure
    all
    | > item in the list are selected. Click Next.
    | >
    | > 6. On the "Web Server Certificate" page, choose to create a new Web
    server
    | > certificate and then type the public FQDN (your new DNS name) that you
    | > will
    | > use to access ActiveSync and OMA (for example, if your public FQDN that
    | > you
    | > use to access the sites is mail.xyz.com, you should type mail.xyz.com as
    | > the new certificate name).
    | >
    | > 7. Go through the remaining steps.
    | >
    | > Step 2: The error often happens when the authentication method is not
    | > configured correctly in ActiveSync, OMA and Exchange-OMA virtual
    | > directory.
    | >
    | > Please verify Authentication settings by the following steps.
    | >
    | > For Exchange-oma virtual directory:
    | >
    | > 1. Open IIS Manager
    | > 2. Open properties of virtual directory Exchange-oma
    | > 3. Select Directory Security tab
    | > 4. Select Edit in Authentication and access control box. Make sure the
    | > authentication setting as below:
    | >
    | > Authentication Methods
    | > Enabled Basic authentication
    | > Enabled Integrated Windows authentication
    | > Disabled anonymous access
    | >
    | > For OMA virtual directory and Microsoft-Server-ActiveSync virtual
    | > directory:
    | >
    | > 1. Open IIS Manager
    | > 2. Open properties of OMA virtual directory and
    | > Microsoft-Server-ActiveSync
    | > virtual directory respectively.
    | > 3. Select Directory Security tab
    | > 4. Select Edit in Authentication and access control box. Make sure the
    | > authentication setting as below:
    | >
    | > Authentication Methods
    | > Uncheck Enable anonymous access
    | > Uncheck Integrated Windows authentication
    | > Check Basic authentication
    | >
    | > After that, please restart the IIS Admin Service (services.msc) and then
    | > verify the issue.
    | >
    | > If the issue persists after steps above, in order to have a more
    concrete
    | > idea about the issue, please let me know the following info.
    | >
    | > 1. Does issue happen to accessing mailbox by OMA? For further test,
    please
    | > login Exchange Server itself, and access URL: http://SBS_Server/OMA,
    | > verify
    | > whether you can access the mailbox successfully.
    | >
    | > 2. Do all the users have such issue or just specific users? Please
    create
    | > a
    | > new mail-enabled user and verify whether he can access mailbox by
    | > ActiveSync.
    | >
    | > 3. Collect the IIS metabase on Exchange Server and send to me:
    | > for further analysis:
    | >
    | > 1). On Exchange Server, install .NET Framework Version 1.1:
    | >
    http://www.microsoft.com/downloads/details.aspx?FamilyID=262d25e3-f589-4842-
    | > 8157-034d1e7cf3a3&DisplayLang=en.
    | > 2). Install MBExplorer by installing IIS 6 Resource Kit Tools:
    | >
    http://www.microsoft.com/downloads/details.aspx?FamilyId=56FC92EE-A71A-4C73-
    | > B628-ADE629C89499&displaylang=en.
    | > 3). Once it is installed, access it from Start, Programs, IIS Resources,
    | > Metabase Explorer.
    | > 4). In the left pane, right click ''LM'' (under your server computer
    name)
    | > to choose ''Export to file'', and then save it as IIS.mbk.
    | > 5). Compress this mbk file and send it to me for analysis. Please let me
    | > know the password if you set on this iis mbk file.
    | >
    | > 4. Please collect the IIS log on Exchange Server so that I can perform
    | > further research:
    | >
    | > 1). On Exchange Serves, open IIS MMC, right click Default Web Site and
    | > then
    | > click Properties.
    | > 2). Click Website tab and then check Enable logging.
    | > 3). Stop the Default Website and RENAME the existing IIS log files under
    | > C:\WINDOWS\system32\LogFiles\W3SVC1.
    | > 4). Restart the Default Website and reproduce the problem, which will
    | > generate new IIS log file with the exact error.
    | > 5). Wait for a while so that IIS Log can be synced. And then go to the
    | > following folder on Exchange Server:
    C:\WINDOWS\system32\LogFiles\W3SVC1.
    | > 6). Send me the log files to my working email address
    | > . And please let me know the alias of the user who
    | > encountered the issue.
    | >
    | > 5. For further test, please temporarily disable SSL if you enable it for
    | > ActiveSync; create a new test account and let me know the following
    | > information.
    | >
    | > - Credential of this test account
    | > - The public URL of your Exchange Server
    | > - Domain name
    | >
    | > I will access the mailbox by ActiveSync in my side to verify the issue.
    To
    | > keep these confidential, please let me know by mail:
    | >
    | >
    | > Hope this helps. Please let me know the results so that I can provide
    | > further assistance on this problem. I am looking forward to your reply.
    | >
    | > Thanks and have a nice day!
    | >
    | > Best regards,
    | >
    | > Terence Liu(MSFT)
    | >
    | > Microsoft CSS Online Newsgroup Support
    | >
    | > Get Secure! - www.microsoft.com/security
    | >
    | > =====================================================
    | > This newsgroup only focuses on SBS technical issues. If you have issues
    | > regarding other Microsoft products, you'd better post in the
    corresponding
    | > newsgroups so that they can be resolved in an efficient and timely
    manner.
    | > You can locate the newsgroup here:
    | > http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    | >
    | > When opening a new thread via the web interface, we recommend you check
    | > the
    | > "Notify me of replies" box to receive e-mail notifications when there
    are
    | > any updates in your thread. When responding to posts via your
    newsreader,
    | > please "Reply to Group" so that others may learn and benefit from your
    | > issue.
    | >
    | > Microsoft engineers can only focus on one issue per thread. Although we
    | > provide other information for your reference, we recommend you post
    | > different incidents in different threads to keep the thread clean. In
    | > doing
    | > so, it will ensure your issues are resolved in a timely manner.
    | >
    | > For urgent issues, you may want to contact Microsoft CSS directly.
    Please
    | > check http://support.microsoft.com for regional support phone numbers.
    | >
    | > Any input or comments in this thread are highly appreciated.
    | > =====================================================
    | >
    | > This posting is provided "AS IS" with no warranties, and confers no
    | > rights.
    | >
    | > --------------------
    | > | From: "John" <johnAtUnwantedmailDotCom>
    | > | Subject: WM5 can not sync to exchange
    | > | Date: Sun, 14 Jan 2007 18:37:47 -0800
    | > | Lines: 122
    | > | X-Priority: 3
    | > | X-MSMail-Priority: Normal
    | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
    | > | X-RFC2646: Format=Flowed; Original
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
    | > | Message-ID: <>
    | > | Newsgroups:
    | >
    microsoft.public.exchange.admin,microsoft.public.exchange.mobility,microsoft
    | > public.windows.server.sbs
    | > | NNTP-Posting-Host: user-0c2i932.cable.earthlink.net 24.41.36.98
    | > | Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP04.phx.gbl
    | > | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.exchange.mobility:129
    | > microsoft.public.windows.server.sbs:10194
    | > microsoft.public.exchange.admin:6974
    | > | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | > |
    | > | My mobile device is running WM5 and my exchange server is a SBS2003
    SP1
    | > | running ISA 2004
    | > |
    | > | The Exchange server has a self issued certificate that is trusted by
    the
    | > | mobile device.
    | > |
    | > | The system worked correctly for over a year, but began failing last
    | > night
    | > | after changing some DNS entries. these entries have been changed back
    | > but
    | > | errors continue.
    | > |
    | > | No errors are found in the event log.
    | > |
    | > | The mobile device is able to access the server, both when connected
    to a
    | > | internal desktop computer, and over the mobile GPRS but it fails to
    sync
    | > in
    | > | both cases.
    | > |
    | > | The following error message is received from active sync. Activesync
    | > | encountered a problem on the server. Support Code:85010014
    | > |
    | > | Please note the HTTP 500 error received at the end of the Activesync
    | > log.
    | > |
    | > |
    | >
    __________________________________________________________________________
    | > | Below are 2 connection attempts, the first internal, the second
    | > external.
    | > | IIS Log
    | > | //internal
    | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:16:44, W3SVC1, myServer,
    | > | 10.0.0.1, 15, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:16:50, W3SVC1, myServer,
    | > | 10.0.0.1, 5438, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:17:02, W3SVC1, myServer,
    | > | 10.0.0.1, 0, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:17:08, W3SVC1, myServer,
    | > | 10.0.0.1, 5375, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | > | //external
    | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:17, W3SVC1,
    myServer,
    | > | 10.0.0.1, 15, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:25, W3SVC1,
    myServer,
    | > | 10.0.0.1, 5500, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:31, W3SVC1,
    myServer,
    | > | 10.0.0.1, 0, 422, 587, 200, 0, OPTIONS, /Microsoft-Server-ActiveSync,
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:38, W3SVC1,
    myServer,
    | > | 10.0.0.1, 5391, 493, 313, 500, 0, POST, /Microsoft-Server-ActiveSync,
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | > |
    | >
    _________________________________________________________________________
    | > |
    | > | Below is an activesync verbose error log
    | > |
    | >
    _________________________________________________________________________
    | > | =-= Build 14847 =-=
    | > | =-= No XIP Information Available =-=
    | > | myExternalFQDN
    | > |
    | > | =-=- [14/1/2007 18:29:50.0] -=-=
    | > | =-=-=-= Client Request =-=-=-=
    | > | OPTIONS
    | > |
    | >
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=Sma
    | > rtPhone
    | > | Accept-Language: en-us
    | > | MS-ASProtocolVersion: 2.5
    | > | X-MS-PolicyKey: 0
    | > |
    | > | -=-=-=- Start of Body -=-=-=-
    | > |
    | > |
    | > | =-=- [14/1/2007 18:29:51.0] -=-=
    | > | =-=-=-= Server Response =-=-=-
    | > | HTTP/1.1 200 OK
    | > | Connection: Keep-Alive
    | > | Content-Length: 0
    | > | Date: Mon, 15 Jan 2007 02:29:51 GMT
    | > | Server: Microsoft-IIS/6.0
    | > | MicrosoftOfficeWebServer: 5.0_Pub
    | > | X-Powered-By: ASP.NET
    | > | Pragma: no-cache
    | > | Public: OPTIONS, POST
    | > | Allow: OPTIONS, POST
    | > | MS-Server-ActiveSync: 6.5.7638.1
    | > | MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
    | > | MS-ASProtocolCommands:
    | > |
    | >
    Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateColle
    | >
    ction,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,F
    | >
    olderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,Vali
    | > dateCert,Provision,Search,Notify,Ping
    | > |
    | > |
    | > | -=-=-=- Start of Body -=-=-=-
    | > |
    | > |
    | > | =-=- [14/1/2007 18:29:51.0] -=-=
    | > | =-=-=-= Client Request =-=-=-=
    | > | POST
    | > |
    | >
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=Sma
    | > rtPhone&Cmd=FolderSync
    | > | Accept-Language: en-us
    | > | MS-ASProtocolVersion: 2.5
    | > | Content-Type: application/vnd.ms-sync.wbxml
    | > | X-MS-PolicyKey: 0
    | > |
    | > | -=-=-=- Start of Body -=-=-=-
    | > | <?xml version="1.0" encoding="utf-8"?><FolderSync
    | > | xmlns="FolderHierarchy:"><SyncKey>0</SyncKey></FolderSync>
    | > |
    | > | =-=- [14/1/2007 18:29:57.0] -=-=
    | > | =-=-=-= Server Response =-=-=-
    | > | HTTP/1.1 500 Internal Server Error
    | > | Connection: Keep-Alive
    | > | Content-Length: 56
    | > | Date: Mon, 15 Jan 2007 02:29:57 GMT
    | > | Content-Type: text/html
    | > | Server: Microsoft-IIS/6.0
    | > | MicrosoftOfficeWebServer: 5.0_Pub
    | > | X-Powered-By: ASP.NET
    | > | Pragma: no-cache
    | > | MS-Server-ActiveSync: 6.5.7638.1
    | > |
    | > |
    | > |
    | > | Thank you for looking this over,
    | > | John
    | > |
    | > |
    | > |
    | >
    |
    |
    |
     
    Terence Liu [MSFT], Jan 17, 2007
    #7
  8. Hello John,

    Thank you for your email.

    From the CEICW log, I find error:

    *** Getting Sbs web listener certificate hash returned ERROR 8007007a

    For this error, I suggest you to reinstall ISA to resolve it:
    1. Uninstall the ISA from the add/remove program

    2. Reboot the server.

    3. Install the ISA again from the SBS CD

    4. Rerun the CEICW through the following KB:

    How to configure Internet access in Windows Small Business Server 2003
    http://support.microsoft.com/kb/825763/en-us

    If you can success run CEICW, the Exchange-oma folder will be created
    automatic.

    If we still can not run CEICW success, we have to create Exchange-oma
    folder manually:
    1. Start Internet Information Services (IIS) Manager.

    2. Locate the Exchange virtual directory. The default location is the
    following:

    Web Sites\Default Web Site\Exchange

    3. Right-click the Exchange virtual directory, click All Tasks, and then
    click Save Configuration to a File.

    4. In the File name box, type a name. For example, type ExchangeVDir. Click
    OK.

    5. Right-click the root of this Web site. Typically, this is Default Web
    Site. Click New, and then click Virtual Directory (from file).

    6. In the Import Configuration dialog box, click Browse, locate the file
    that you created in step 4, click Open, and then click Read File.

    7. Under Select a configuration to import , click Exchange, and then click
    OK.

    A dialog box will appear that states that the "virtual directory already
    exists."

    8. In the Alias box, type a name for the new virtual directory that you
    want Exchange ActiveSync and Outlook Mobile Access to use. For example,
    type exchange-oma. Click OK.

    9. Right-click the new virtual directory. In this example, click
    exchange-oma. Click Properties.

    10. Click the Directory Security tab.

    11. Under Authentication and access control, click Edit.

    12. Make sure that only the following authentication methods are enabled,
    and then click OK:

    Integrated Windows authentication
    Basic authentication

    13. Under IP address and domain name restrictions, click Edit.

    14. Click Denied access, click Add, click Single computer, type the IP
    address of the server that you are configuring, and then click OK.

    15. Under Secure communications, click Edit. Make sure that Require secure
    channel (SSL) is not enabled, and then click OK.

    16. Click OK, and then close the IIS Manager.

    17. Click Start, click Run, type regedit, and then click OK.

    18. Locate the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters

    19. Right-click Parameters, click to New, and then click String Value.

    20. Type ExchangeVDir, and then press ENTER. Right-click ExchangeVDir, and
    then click Modify.

    NoteExchangeVDir is case-sensitive. If you do not type ExchangeVDir exactly
    as it appears in this article, ActiveSync does not find the key when it
    locates the exchange-oma folder.

    21. In the Value data box, type the name of the new virtual directory that
    you created in step 8. For example, type exchange-oma. Click OK.

    22. Quit Registry Editor.

    23. Restart the IIS Admin service. To do this, follow these steps:

    a. Click Start, click Run, type services.msc, and then click OK.
    b. In the list of services, right-click IIS Admin service, and then click
    Restart.

    For detail info, please go through the following KB:

    Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or
    forms-based authentication is required for Exchange Server 2003
    http://support.microsoft.com/?id=817379

    If the issue persists, please kindly help me collect some information for
    further investigation:

    1. Gather CEICW log again if it still fail

    2. Gather IIS log and IIS metabase again

    Hope these steps will give you some help.

    Thanks and have a nice day!

    Best regards,

    Terence Liu(MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
    | X-Tomcat-ID: 198727761
    | References: <>
    <>
    <#P$>
    | MIME-Version: 1.0
    | Content-Type: text/plain
    | Content-Transfer-Encoding: 7bit
    | From: (Terence Liu [MSFT])
    | Organization: Microsoft
    | Date: Wed, 17 Jan 2007 10:11:40 GMT
    | Subject: Re: WM5 can not sync to exchange
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | Message-ID: <5xQ$k$>
    | Newsgroups: microsoft.public.windows.server.sbs
    | Lines: 494
    | Path: TK2MSFTNGHUB02.phx.gbl
    | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:10882
    | NNTP-Posting-Host: tomcatimport2.phx.gbl 10.201.218.182
    |
    | Hello John,
    |
    | Thank you for kind update.
    |
    | Please send email to my work mailbox: with subject
    | of this post's title.
    |
    | Note: please gather IIS metabase via the tool and send it to me, it is
    | important for troubleshooting this issue.
    |
    | Synchronizing your Pocket PC with Outlook (client sync) or Exchange
    server
    | directly (server sync): SBS 2003 supports ActiveSync via a client, or
    | Server ActiveSync if you have remote connectivity to the server via the
    | PDA. For example, you could use a Pocket PC Phone Edition 2003 device, or
    | SmartPhone to use Server ActiveSync to sync your Inbox, Calendar, and/or
    | Contacts.
    |
    | If you are using client ActiveSync, as this feature is closely related to
    | the Pocket PC model you are using and the manufacturer's design, please
    | contact the Pocket PC provider or the Microsoft public Pocket PC
    newsgroup
    | for assistance. The public newsgroups are:
    |
    | news://news.microsoft.com/microsoft.public.pocketpc
    | news://news.microsoft.com/microsoft.public.pocketpc.activesync
    |
    | This is in order to make sure that this issue is efficiently addressed.
    | Thank you for your understanding.
    |
    | Meanwhile, the client host machine must be configured using the SBS Set
    Up
    | Computer Wizard. During the Set Up Computer Wizard, the option to install
    | ActiveSync 3.7 must be configured as well. If this is pushed to the
    client
    | machine, then there will be an option in the Start Menu called Mobile
    | Device Configuration. Then, it should be able to provision your phone or
    | PPC (including installing the certificat) so that the Server ActiveSync
    | works.
    |
    | Please also let me know some more info:
    |
    | 1. Try to use another mobile device to do ActiveSync, does it work?
    |
    | 2. Does the account admin can access activeSync?
    |
    | 3. Does the new account can access OMA?
    |
    | Hope this helps. Please let me know the results so that I can provide
    | further assistance on this problem. I am looking forward to your reply.
    |
    | Thanks and have a nice day!
    |
    | Best regards,
    |
    | Terence Liu(MSFT)
    |
    | Microsoft CSS Online Newsgroup Support
    |
    | Get Secure! - www.microsoft.com/security
    |
    | =====================================================
    | This newsgroup only focuses on SBS technical issues. If you have issues
    | regarding other Microsoft products, you'd better post in the
    corresponding
    | newsgroups so that they can be resolved in an efficient and timely
    manner.
    | You can locate the newsgroup here:
    | http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    |
    | When opening a new thread via the web interface, we recommend you check
    the
    | "Notify me of replies" box to receive e-mail notifications when there are
    | any updates in your thread. When responding to posts via your newsreader,
    | please "Reply to Group" so that others may learn and benefit from your
    | issue.
    |
    | Microsoft engineers can only focus on one issue per thread. Although we
    | provide other information for your reference, we recommend you post
    | different incidents in different threads to keep the thread clean. In
    doing
    | so, it will ensure your issues are resolved in a timely manner.
    |
    | For urgent issues, you may want to contact Microsoft CSS directly. Please
    | check http://support.microsoft.com for regional support phone numbers.
    |
    | Any input or comments in this thread are highly appreciated.
    | =====================================================
    |
    | This posting is provided "AS IS" with no warranties, and confers no
    rights.
    |
    | --------------------
    | | From: "John" <johnAtUnwantedmailDotCom>
    | | References: <>
    | <>
    | | Subject: Re: WM5 can not sync to exchange
    | | Date: Tue, 16 Jan 2007 18:00:12 -0800
    | | Lines: 386
    | | X-Priority: 3
    | | X-MSMail-Priority: Normal
    | | X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
    | | X-RFC2646: Format=Flowed; Original
    | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
    | | Message-ID: <#P$>
    | | Newsgroups: microsoft.public.windows.server.sbs
    | | NNTP-Posting-Host: user-0c2i932.cable.earthlink.net 24.41.36.98
    | | Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP02.phx.gbl
    | | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:10809
    | | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | |
    | | I'm having trouble emailing the files to you.
    | |
    | | Below is the message I've received.
    | |
    | | --------------------------------------------
    | | Reporting-MTA: dns;MYDOMAIN.com
    | |
    | | Final-Recipient: rfc822;
    | | Action: delayed
    | | Status: 4.4.7
    | | Will-Retry-Until: Thu, 18 Jan 2007 02:06:53 -0800
    | | X-Display-Name: ''
    | |
    | | --------------------------------------------------------------
    | |
    | |
    | | | | > Hello John,
    | | >
    | | > Thanks for posting here.
    | | >
    | | > From your post, my understanding on this issue is: You encountered
    | support
    | | > code 85010014 during ActiveSync with SBS. If I'm off base, please
    feel
    | | > free
    | | > to let me know.
    | | >
    | | > Based on my knowledge, support code 85010014 means error HTTP 500. I
    | | > suggest we try the following steps to see if we can resolve this
    issue:
    | | >
    | | > Step 1: For you change the DNS, I suggest you to Rerun CEICW to
    recreate
    | | > the self issued certificate
    | | >
    | | > Go through the follow KB and Rerun CEICW again carefully.
    | | >
    | | > How to configure Internet access in Windows Small Business Server 2003
    | | > http://support.microsoft.com/kb/825763/en-us
    | | >
    | | > Detailed steps for your reference:
    | | >
    | | > 1. On the SBS 2003 Server open the Server Management console. Go to
    | | > Standard Management\To Do List.
    | | >
    | | > 2. Click the "Connect to the Internet" link.
    | | >
    | | > 3. When navigating to the Firewall page, select "Enable firewall" and
    | | > click
    | | > Next (I suppose you have 2 network adapters in SBS 2003).
    | | >
    | | > 4. On the "Services Configuration" page, select all the items and then
    | | > click Next.
    | | >
    | | > 5. On the "Web Services Configuration" page, make sure "Allow access
    to
    | | > the
    | | > entire Web site from the Internet" is selected. If you select "Allow
    | | > access
    | | > to only the following Web site services from the Internet", make sure
    | all
    | | > item in the list are selected. Click Next.
    | | >
    | | > 6. On the "Web Server Certificate" page, choose to create a new Web
    | server
    | | > certificate and then type the public FQDN (your new DNS name) that
    you
    | | > will
    | | > use to access ActiveSync and OMA (for example, if your public FQDN
    that
    | | > you
    | | > use to access the sites is mail.xyz.com, you should type mail.xyz.com
    as
    | | > the new certificate name).
    | | >
    | | > 7. Go through the remaining steps.
    | | >
    | | > Step 2: The error often happens when the authentication method is not
    | | > configured correctly in ActiveSync, OMA and Exchange-OMA virtual
    | | > directory.
    | | >
    | | > Please verify Authentication settings by the following steps.
    | | >
    | | > For Exchange-oma virtual directory:
    | | >
    | | > 1. Open IIS Manager
    | | > 2. Open properties of virtual directory Exchange-oma
    | | > 3. Select Directory Security tab
    | | > 4. Select Edit in Authentication and access control box. Make sure the
    | | > authentication setting as below:
    | | >
    | | > Authentication Methods
    | | > Enabled Basic authentication
    | | > Enabled Integrated Windows authentication
    | | > Disabled anonymous access
    | | >
    | | > For OMA virtual directory and Microsoft-Server-ActiveSync virtual
    | | > directory:
    | | >
    | | > 1. Open IIS Manager
    | | > 2. Open properties of OMA virtual directory and
    | | > Microsoft-Server-ActiveSync
    | | > virtual directory respectively.
    | | > 3. Select Directory Security tab
    | | > 4. Select Edit in Authentication and access control box. Make sure the
    | | > authentication setting as below:
    | | >
    | | > Authentication Methods
    | | > Uncheck Enable anonymous access
    | | > Uncheck Integrated Windows authentication
    | | > Check Basic authentication
    | | >
    | | > After that, please restart the IIS Admin Service (services.msc) and
    then
    | | > verify the issue.
    | | >
    | | > If the issue persists after steps above, in order to have a more
    | concrete
    | | > idea about the issue, please let me know the following info.
    | | >
    | | > 1. Does issue happen to accessing mailbox by OMA? For further test,
    | please
    | | > login Exchange Server itself, and access URL: http://SBS_Server/OMA,
    | | > verify
    | | > whether you can access the mailbox successfully.
    | | >
    | | > 2. Do all the users have such issue or just specific users? Please
    | create
    | | > a
    | | > new mail-enabled user and verify whether he can access mailbox by
    | | > ActiveSync.
    | | >
    | | > 3. Collect the IIS metabase on Exchange Server and send to me:
    | | > for further analysis:
    | | >
    | | > 1). On Exchange Server, install .NET Framework Version 1.1:
    | | >
    |
    http://www.microsoft.com/downloads/details.aspx?FamilyID=262d25e3-f589-4842-
    | | > 8157-034d1e7cf3a3&DisplayLang=en.
    | | > 2). Install MBExplorer by installing IIS 6 Resource Kit Tools:
    | | >
    |
    http://www.microsoft.com/downloads/details.aspx?FamilyId=56FC92EE-A71A-4C73-
    | | > B628-ADE629C89499&displaylang=en.
    | | > 3). Once it is installed, access it from Start, Programs, IIS
    Resources,
    | | > Metabase Explorer.
    | | > 4). In the left pane, right click ''LM'' (under your server computer
    | name)
    | | > to choose ''Export to file'', and then save it as IIS.mbk.
    | | > 5). Compress this mbk file and send it to me for analysis. Please let
    me
    | | > know the password if you set on this iis mbk file.
    | | >
    | | > 4. Please collect the IIS log on Exchange Server so that I can perform
    | | > further research:
    | | >
    | | > 1). On Exchange Serves, open IIS MMC, right click Default Web Site
    and
    | | > then
    | | > click Properties.
    | | > 2). Click Website tab and then check Enable logging.
    | | > 3). Stop the Default Website and RENAME the existing IIS log files
    under
    | | > C:\WINDOWS\system32\LogFiles\W3SVC1.
    | | > 4). Restart the Default Website and reproduce the problem, which will
    | | > generate new IIS log file with the exact error.
    | | > 5). Wait for a while so that IIS Log can be synced. And then go to the
    | | > following folder on Exchange Server:
    | C:\WINDOWS\system32\LogFiles\W3SVC1.
    | | > 6). Send me the log files to my working email address
    | | > . And please let me know the alias of the user
    who
    | | > encountered the issue.
    | | >
    | | > 5. For further test, please temporarily disable SSL if you enable it
    for
    | | > ActiveSync; create a new test account and let me know the following
    | | > information.
    | | >
    | | > - Credential of this test account
    | | > - The public URL of your Exchange Server
    | | > - Domain name
    | | >
    | | > I will access the mailbox by ActiveSync in my side to verify the
    issue.
    | To
    | | > keep these confidential, please let me know by mail:
    | | >
    | | >
    | | > Hope this helps. Please let me know the results so that I can provide
    | | > further assistance on this problem. I am looking forward to your
    reply.
    | | >
    | | > Thanks and have a nice day!
    | | >
    | | > Best regards,
    | | >
    | | > Terence Liu(MSFT)
    | | >
    | | > Microsoft CSS Online Newsgroup Support
    | | >
    | | > Get Secure! - www.microsoft.com/security
    | | >
    | | > =====================================================
    | | > This newsgroup only focuses on SBS technical issues. If you have
    issues
    | | > regarding other Microsoft products, you'd better post in the
    | corresponding
    | | > newsgroups so that they can be resolved in an efficient and timely
    | manner.
    | | > You can locate the newsgroup here:
    | | > http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    | | >
    | | > When opening a new thread via the web interface, we recommend you
    check
    | | > the
    | | > "Notify me of replies" box to receive e-mail notifications when there
    | are
    | | > any updates in your thread. When responding to posts via your
    | newsreader,
    | | > please "Reply to Group" so that others may learn and benefit from your
    | | > issue.
    | | >
    | | > Microsoft engineers can only focus on one issue per thread. Although
    we
    | | > provide other information for your reference, we recommend you post
    | | > different incidents in different threads to keep the thread clean. In
    | | > doing
    | | > so, it will ensure your issues are resolved in a timely manner.
    | | >
    | | > For urgent issues, you may want to contact Microsoft CSS directly.
    | Please
    | | > check http://support.microsoft.com for regional support phone numbers.
    | | >
    | | > Any input or comments in this thread are highly appreciated.
    | | > =====================================================
    | | >
    | | > This posting is provided "AS IS" with no warranties, and confers no
    | | > rights.
    | | >
    | | > --------------------
    | | > | From: "John" <johnAtUnwantedmailDotCom>
    | | > | Subject: WM5 can not sync to exchange
    | | > | Date: Sun, 14 Jan 2007 18:37:47 -0800
    | | > | Lines: 122
    | | > | X-Priority: 3
    | | > | X-MSMail-Priority: Normal
    | | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
    | | > | X-RFC2646: Format=Flowed; Original
    | | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
    | | > | Message-ID: <>
    | | > | Newsgroups:
    | | >
    |
    microsoft.public.exchange.admin,microsoft.public.exchange.mobility,microsoft
    | | > public.windows.server.sbs
    | | > | NNTP-Posting-Host: user-0c2i932.cable.earthlink.net 24.41.36.98
    | | > | Path:
    TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP04.phx.gbl
    | | > | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.exchange.mobility:129
    | | > microsoft.public.windows.server.sbs:10194
    | | > microsoft.public.exchange.admin:6974
    | | > | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | | > |
    | | > | My mobile device is running WM5 and my exchange server is a SBS2003
    | SP1
    | | > | running ISA 2004
    | | > |
    | | > | The Exchange server has a self issued certificate that is trusted
    by
    | the
    | | > | mobile device.
    | | > |
    | | > | The system worked correctly for over a year, but began failing last
    | | > night
    | | > | after changing some DNS entries. these entries have been changed
    back
    | | > but
    | | > | errors continue.
    | | > |
    | | > | No errors are found in the event log.
    | | > |
    | | > | The mobile device is able to access the server, both when connected
    | to a
    | | > | internal desktop computer, and over the mobile GPRS but it fails to
    | sync
    | | > in
    | | > | both cases.
    | | > |
    | | > | The following error message is received from active sync.
    Activesync
    | | > | encountered a problem on the server. Support Code:85010014
    | | > |
    | | > | Please note the HTTP 500 error received at the end of the
    Activesync
    | | > log.
    | | > |
    | | > |
    | | >
    | __________________________________________________________________________
    | | > | Below are 2 connection attempts, the first internal, the second
    | | > external.
    | | > | IIS Log
    | | > | //internal
    | | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:16:44, W3SVC1,
    myServer,
    | | > | 10.0.0.1, 15, 422, 587, 200, 0, OPTIONS,
    /Microsoft-Server-ActiveSync,
    | | > |
    | | >
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:16:50, W3SVC1,
    myServer,
    | | > | 10.0.0.1, 5438, 493, 313, 500, 0, POST,
    /Microsoft-Server-ActiveSync,
    | | > |
    | | >
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:17:02, W3SVC1,
    myServer,
    | | > | 10.0.0.1, 0, 422, 587, 200, 0, OPTIONS,
    /Microsoft-Server-ActiveSync,
    | | > |
    | | >
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:17:08, W3SVC1,
    myServer,
    | | > | 10.0.0.1, 5375, 493, 313, 500, 0, POST,
    /Microsoft-Server-ActiveSync,
    | | > |
    | | >
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | | > | //external
    | | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:17, W3SVC1,
    | myServer,
    | | > | 10.0.0.1, 15, 422, 587, 200, 0, OPTIONS,
    /Microsoft-Server-ActiveSync,
    | | > |
    | | >
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:25, W3SVC1,
    | myServer,
    | | > | 10.0.0.1, 5500, 493, 313, 500, 0, POST,
    /Microsoft-Server-ActiveSync,
    | | > |
    | | >
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:31, W3SVC1,
    | myServer,
    | | > | 10.0.0.1, 0, 422, 587, 200, 0, OPTIONS,
    /Microsoft-Server-ActiveSync,
    | | > |
    | | >
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:38, W3SVC1,
    | myServer,
    | | > | 10.0.0.1, 5391, 493, 313, 500, 0, POST,
    /Microsoft-Server-ActiveSync,
    | | > |
    | | >
    |
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | | > |
    | | >
    | _________________________________________________________________________
    | | > |
    | | > | Below is an activesync verbose error log
    | | > |
    | | >
    | _________________________________________________________________________
    | | > | =-= Build 14847 =-=
    | | > | =-= No XIP Information Available =-=
    | | > | myExternalFQDN
    | | > |
    | | > | =-=- [14/1/2007 18:29:50.0] -=-=
    | | > | =-=-=-= Client Request =-=-=-=
    | | > | OPTIONS
    | | > |
    | | >
    |
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=Sma
    | | > rtPhone
    | | > | Accept-Language: en-us
    | | > | MS-ASProtocolVersion: 2.5
    | | > | X-MS-PolicyKey: 0
    | | > |
    | | > | -=-=-=- Start of Body -=-=-=-
    | | > |
    | | > |
    | | > | =-=- [14/1/2007 18:29:51.0] -=-=
    | | > | =-=-=-= Server Response =-=-=-
    | | > | HTTP/1.1 200 OK
    | | > | Connection: Keep-Alive
    | | > | Content-Length: 0
    | | > | Date: Mon, 15 Jan 2007 02:29:51 GMT
    | | > | Server: Microsoft-IIS/6.0
    | | > | MicrosoftOfficeWebServer: 5.0_Pub
    | | > | X-Powered-By: ASP.NET
    | | > | Pragma: no-cache
    | | > | Public: OPTIONS, POST
    | | > | Allow: OPTIONS, POST
    | | > | MS-Server-ActiveSync: 6.5.7638.1
    | | > | MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
    | | > | MS-ASProtocolCommands:
    | | > |
    | | >
    |
    Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateColle
    | | >
    |
    ction,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,F
    | | >
    |
    olderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,Vali
    | | > dateCert,Provision,Search,Notify,Ping
    | | > |
    | | > |
    | | > | -=-=-=- Start of Body -=-=-=-
    | | > |
    | | > |
    | | > | =-=- [14/1/2007 18:29:51.0] -=-=
    | | > | =-=-=-= Client Request =-=-=-=
    | | > | POST
    | | > |
    | | >
    |
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=Sma
    | | > rtPhone&Cmd=FolderSync
    | | > | Accept-Language: en-us
    | | > | MS-ASProtocolVersion: 2.5
    | | > | Content-Type: application/vnd.ms-sync.wbxml
    | | > | X-MS-PolicyKey: 0
    | | > |
    | | > | -=-=-=- Start of Body -=-=-=-
    | | > | <?xml version="1.0" encoding="utf-8"?><FolderSync
    | | > | xmlns="FolderHierarchy:"><SyncKey>0</SyncKey></FolderSync>
    | | > |
    | | > | =-=- [14/1/2007 18:29:57.0] -=-=
    | | > | =-=-=-= Server Response =-=-=-
    | | > | HTTP/1.1 500 Internal Server Error
    | | > | Connection: Keep-Alive
    | | > | Content-Length: 56
    | | > | Date: Mon, 15 Jan 2007 02:29:57 GMT
    | | > | Content-Type: text/html
    | | > | Server: Microsoft-IIS/6.0
    | | > | MicrosoftOfficeWebServer: 5.0_Pub
    | | > | X-Powered-By: ASP.NET
    | | > | Pragma: no-cache
    | | > | MS-Server-ActiveSync: 6.5.7638.1
    | | > |
    | | > |
    | | > |
    | | > | Thank you for looking this over,
    | | > | John
    | | > |
    | | > |
    | | > |
    | | >
    | |
    | |
    | |
    |
    |
     
    Terence Liu [MSFT], Jan 19, 2007
    #8
  9. John

    John S Guest

    Hi Terence,

    After uninstalling ISA 2004 I attempted to run the ECICW and still
    encountered an error on the email configuration step.
    I followed your steps to recreate the exchange-oma folder, after which the
    ECICW ran successfully.
    I then reinstalled ISA 2004 and the ECICW ran successfully during the
    installation as well.
    Windows Update installed ISA 2004 SP2.
    I reffered to your initial response to be sure the proper authentication
    methods were enabled on each virtual directory.

    CEICW runs smoothly now.
    The mobile device still fails to sync. A new error 85002003 is reported, and
    nothing is logged in the activesync log.
    OMA no longer works. I receive an internal server error and events are logs
    in both the system and application event log.

    I have emailed you my IIS logs, device activesync logs, IIS metabase, and
    also the events from my event log.

    Thank you for all you help with this issue,

    -John


     
    John S, Jan 19, 2007
    #9
  10. Hello John,

    Thank you for kind update.

    After you reinstall the ISA 2004, I suggest you to rerun the CEICW to
    publish the OMA, AtiveSync, OWA etc and create SSL certificate.

    Please go through the following KB:

    825763 How to configure Internet access in Windows Small Business Server
    2003
    http://support.microsoft.com/?id=825763

    Detailed steps for your reference:

    1. On the SBS 2003 Server open the Server Management console. Go to
    Standard Management\To Do List.

    2. Click the "Connect to the Internet" link.

    3. When navigating to the Firewall page, select "Enable firewall" and click
    Next (I suppose you have 2 network adapters in SBS 2003).

    4. On the "Services Configuration" page, select all the items and then
    click Next.

    5. On the "Web Services Configuration" page, make sure "Allow access to the
    entire Web site from the Internet" is selected. If you select "Allow access
    to only the following Web site services from the Internet", make sure all
    item in the list is selected. Click Next.

    6. On the "Web Server Certificate" page, choose to create a new Web server
    certificate and then type the public FQDN that you will use to access OWA
    (for example, if your public FQDN that you use to access the sites is
    mail.xyz.com, you should type mail.xyz.com as the new certificate name).

    7. Go through the remaining steps.

    Step 2:
    Please verify the settings in IIS server as follows to check if it helps:

    a. Open IIS snap-in.

    b. Go to all virtual directories under default web site, right click it to
    click Properties.

    c. Click ASP.NET tab, please change the ASP.NET version to 1.1.4322.

    d. Run IISReset command to take effect the change. Then please test the
    issue to see if it resolved.

    If the issue persists, please kindly help me collect some information for
    further investigation:

    1. Try to access OMA from internal client and SBS server, Does it work?

    2. Try to access ActiveSync from internal:

    1) Disable SSL for Microsoft-Server-ActiveSync virtual directory.
    2) Locate a workstation within LAN; download PC ActiveSync application as
    below:

    http://www.microsoft.com/windowsmobile/downloads/activesync42.mspx

    3) Connect Pocket PC through cradle with this PC;
    4) Specify the NetBIOS name of Exchange Server in order to avoid PPC
    connecting Exchange Server from Internet; and then synchronize Exchange
    Server mailbox by PC ActiveSync application.

    Is it fine?

    Hope these steps will give you some help.

    Thanks and have a nice day!

    Terence Liu

    Best regards,

    Terence Liu(MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
    | From: "John S" <johnAtUnwantedmailDotCom>
    | References: <>
    <>
    <#P$>
    <5xQ$k$>
    <>
    | Subject: Re: WM5 can not sync to exchange
    | Date: Fri, 19 Jan 2007 14:52:13 -0800
    | Lines: 835
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
    | X-RFC2646: Format=Flowed; Original
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
    | Message-ID: <>
    | Newsgroups: microsoft.public.windows.server.sbs
    | NNTP-Posting-Host: user-0c2i932.cable.earthlink.net 24.41.36.98
    | Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP06.phx.gbl
    | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:11547
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | Hi Terence,
    |
    | After uninstalling ISA 2004 I attempted to run the ECICW and still
    | encountered an error on the email configuration step.
    | I followed your steps to recreate the exchange-oma folder, after which
    the
    | ECICW ran successfully.
    | I then reinstalled ISA 2004 and the ECICW ran successfully during the
    | installation as well.
    | Windows Update installed ISA 2004 SP2.
    | I reffered to your initial response to be sure the proper authentication
    | methods were enabled on each virtual directory.
    |
    | CEICW runs smoothly now.
    | The mobile device still fails to sync. A new error 85002003 is reported,
    and
    | nothing is logged in the activesync log.
    | OMA no longer works. I receive an internal server error and events are
    logs
    | in both the system and application event log.
    |
    | I have emailed you my IIS logs, device activesync logs, IIS metabase, and
    | also the events from my event log.
    |
    | Thank you for all you help with this issue,
    |
    | -John
    |
    |
    | | > Hello John,
    | >
    | > Thank you for your email.
    | >
    | > From the CEICW log, I find error:
    | >
    | > *** Getting Sbs web listener certificate hash returned ERROR 8007007a
    | >
    | > For this error, I suggest you to reinstall ISA to resolve it:
    | > 1. Uninstall the ISA from the add/remove program
    | >
    | > 2. Reboot the server.
    | >
    | > 3. Install the ISA again from the SBS CD
    | >
    | > 4. Rerun the CEICW through the following KB:
    | >
    | > How to configure Internet access in Windows Small Business Server 2003
    | > http://support.microsoft.com/kb/825763/en-us
    | >
    | > If you can success run CEICW, the Exchange-oma folder will be created
    | > automatic.
    | >
    | > If we still can not run CEICW success, we have to create Exchange-oma
    | > folder manually:
    | > 1. Start Internet Information Services (IIS) Manager.
    | >
    | > 2. Locate the Exchange virtual directory. The default location is the
    | > following:
    | >
    | > Web Sites\Default Web Site\Exchange
    | >
    | > 3. Right-click the Exchange virtual directory, click All Tasks, and then
    | > click Save Configuration to a File.
    | >
    | > 4. In the File name box, type a name. For example, type ExchangeVDir.
    | > Click
    | > OK.
    | >
    | > 5. Right-click the root of this Web site. Typically, this is Default Web
    | > Site. Click New, and then click Virtual Directory (from file).
    | >
    | > 6. In the Import Configuration dialog box, click Browse, locate the file
    | > that you created in step 4, click Open, and then click Read File.
    | >
    | > 7. Under Select a configuration to import , click Exchange, and then
    click
    | > OK.
    | >
    | > A dialog box will appear that states that the "virtual directory already
    | > exists."
    | >
    | > 8. In the Alias box, type a name for the new virtual directory that you
    | > want Exchange ActiveSync and Outlook Mobile Access to use. For example,
    | > type exchange-oma. Click OK.
    | >
    | > 9. Right-click the new virtual directory. In this example, click
    | > exchange-oma. Click Properties.
    | >
    | > 10. Click the Directory Security tab.
    | >
    | > 11. Under Authentication and access control, click Edit.
    | >
    | > 12. Make sure that only the following authentication methods are
    enabled,
    | > and then click OK:
    | >
    | > Integrated Windows authentication
    | > Basic authentication
    | >
    | > 13. Under IP address and domain name restrictions, click Edit.
    | >
    | > 14. Click Denied access, click Add, click Single computer, type the IP
    | > address of the server that you are configuring, and then click OK.
    | >
    | > 15. Under Secure communications, click Edit. Make sure that Require
    secure
    | > channel (SSL) is not enabled, and then click OK.
    | >
    | > 16. Click OK, and then close the IIS Manager.
    | >
    | > 17. Click Start, click Run, type regedit, and then click OK.
    | >
    | > 18. Locate the following registry subkey:
    | >
    | > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters
    | >
    | > 19. Right-click Parameters, click to New, and then click String Value.
    | >
    | > 20. Type ExchangeVDir, and then press ENTER. Right-click ExchangeVDir,
    and
    | > then click Modify.
    | >
    | > NoteExchangeVDir is case-sensitive. If you do not type ExchangeVDir
    | > exactly
    | > as it appears in this article, ActiveSync does not find the key when it
    | > locates the exchange-oma folder.
    | >
    | > 21. In the Value data box, type the name of the new virtual directory
    that
    | > you created in step 8. For example, type exchange-oma. Click OK.
    | >
    | > 22. Quit Registry Editor.
    | >
    | > 23. Restart the IIS Admin service. To do this, follow these steps:
    | >
    | > a. Click Start, click Run, type services.msc, and then click OK.
    | > b. In the list of services, right-click IIS Admin service, and then
    click
    | > Restart.
    | >
    | > For detail info, please go through the following KB:
    | >
    | > Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or
    | > forms-based authentication is required for Exchange Server 2003
    | > http://support.microsoft.com/?id=817379
    | >
    | > If the issue persists, please kindly help me collect some information
    for
    | > further investigation:
    | >
    | > 1. Gather CEICW log again if it still fail
    | >
    | > 2. Gather IIS log and IIS metabase again
    | >
    | > Hope these steps will give you some help.
    | >
    | > Thanks and have a nice day!
    | >
    | > Best regards,
    | >
    | > Terence Liu(MSFT)
    | >
    | > Microsoft CSS Online Newsgroup Support
    | >
    | > Get Secure! - www.microsoft.com/security
    | >
    | > =====================================================
    | > This newsgroup only focuses on SBS technical issues. If you have issues
    | > regarding other Microsoft products, you'd better post in the
    corresponding
    | > newsgroups so that they can be resolved in an efficient and timely
    manner.
    | > You can locate the newsgroup here:
    | > http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    | >
    | > When opening a new thread via the web interface, we recommend you check
    | > the
    | > "Notify me of replies" box to receive e-mail notifications when there
    are
    | > any updates in your thread. When responding to posts via your
    newsreader,
    | > please "Reply to Group" so that others may learn and benefit from your
    | > issue.
    | >
    | > Microsoft engineers can only focus on one issue per thread. Although we
    | > provide other information for your reference, we recommend you post
    | > different incidents in different threads to keep the thread clean. In
    | > doing
    | > so, it will ensure your issues are resolved in a timely manner.
    | >
    | > For urgent issues, you may want to contact Microsoft CSS directly.
    Please
    | > check http://support.microsoft.com for regional support phone numbers.
    | >
    | > Any input or comments in this thread are highly appreciated.
    | > =====================================================
    | >
    | > This posting is provided "AS IS" with no warranties, and confers no
    | > rights.
    | >
    | > --------------------
    | > | X-Tomcat-ID: 198727761
    | > | References: <>
    | > <>
    | > <#P$>
    | > | MIME-Version: 1.0
    | > | Content-Type: text/plain
    | > | Content-Transfer-Encoding: 7bit
    | > | From: (Terence Liu [MSFT])
    | > | Organization: Microsoft
    | > | Date: Wed, 17 Jan 2007 10:11:40 GMT
    | > | Subject: Re: WM5 can not sync to exchange
    | > | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | > | Message-ID: <5xQ$k$>
    | > | Newsgroups: microsoft.public.windows.server.sbs
    | > | Lines: 494
    | > | Path: TK2MSFTNGHUB02.phx.gbl
    | > | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:10882
    | > | NNTP-Posting-Host: tomcatimport2.phx.gbl 10.201.218.182
    | > |
    | > | Hello John,
    | > |
    | > | Thank you for kind update.
    | > |
    | > | Please send email to my work mailbox: with
    | > subject
    | > | of this post's title.
    | > |
    | > | Note: please gather IIS metabase via the tool and send it to me, it is
    | > | important for troubleshooting this issue.
    | > |
    | > | Synchronizing your Pocket PC with Outlook (client sync) or Exchange
    | > server
    | > | directly (server sync): SBS 2003 supports ActiveSync via a client, or
    | > | Server ActiveSync if you have remote connectivity to the server via
    the
    | > | PDA. For example, you could use a Pocket PC Phone Edition 2003
    device,
    | > or
    | > | SmartPhone to use Server ActiveSync to sync your Inbox, Calendar,
    and/or
    | > | Contacts.
    | > |
    | > | If you are using client ActiveSync, as this feature is closely
    related
    | > to
    | > | the Pocket PC model you are using and the manufacturer's design,
    please
    | > | contact the Pocket PC provider or the Microsoft public Pocket PC
    | > newsgroup
    | > | for assistance. The public newsgroups are:
    | > |
    | > | news://news.microsoft.com/microsoft.public.pocketpc
    | > | news://news.microsoft.com/microsoft.public.pocketpc.activesync
    | > |
    | > | This is in order to make sure that this issue is efficiently
    addressed.
    | > | Thank you for your understanding.
    | > |
    | > | Meanwhile, the client host machine must be configured using the SBS
    Set
    | > Up
    | > | Computer Wizard. During the Set Up Computer Wizard, the option to
    | > install
    | > | ActiveSync 3.7 must be configured as well. If this is pushed to the
    | > client
    | > | machine, then there will be an option in the Start Menu called Mobile
    | > | Device Configuration. Then, it should be able to provision your phone
    or
    | > | PPC (including installing the certificat) so that the Server
    ActiveSync
    | > | works.
    | > |
    | > | Please also let me know some more info:
    | > |
    | > | 1. Try to use another mobile device to do ActiveSync, does it work?
    | > |
    | > | 2. Does the account admin can access activeSync?
    | > |
    | > | 3. Does the new account can access OMA?
    | > |
    | > | Hope this helps. Please let me know the results so that I can provide
    | > | further assistance on this problem. I am looking forward to your
    reply.
    | > |
    | > | Thanks and have a nice day!
    | > |
    | > | Best regards,
    | > |
    | > | Terence Liu(MSFT)
    | > |
    | > | Microsoft CSS Online Newsgroup Support
    | > |
    | > | Get Secure! - www.microsoft.com/security
    | > |
    | > | =====================================================
    | > | This newsgroup only focuses on SBS technical issues. If you have
    issues
    | > | regarding other Microsoft products, you'd better post in the
    | > corresponding
    | > | newsgroups so that they can be resolved in an efficient and timely
    | > manner.
    | > | You can locate the newsgroup here:
    | > | http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    | > |
    | > | When opening a new thread via the web interface, we recommend you
    check
    | > the
    | > | "Notify me of replies" box to receive e-mail notifications when there
    | > are
    | > | any updates in your thread. When responding to posts via your
    | > newsreader,
    | > | please "Reply to Group" so that others may learn and benefit from your
    | > | issue.
    | > |
    | > | Microsoft engineers can only focus on one issue per thread. Although
    we
    | > | provide other information for your reference, we recommend you post
    | > | different incidents in different threads to keep the thread clean. In
    | > doing
    | > | so, it will ensure your issues are resolved in a timely manner.
    | > |
    | > | For urgent issues, you may want to contact Microsoft CSS directly.
    | > Please
    | > | check http://support.microsoft.com for regional support phone numbers.
    | > |
    | > | Any input or comments in this thread are highly appreciated.
    | > | =====================================================
    | > |
    | > | This posting is provided "AS IS" with no warranties, and confers no
    | > rights.
    | > |
    | > | --------------------
    | > | | From: "John" <johnAtUnwantedmailDotCom>
    | > | | References: <>
    | > | <>
    | > | | Subject: Re: WM5 can not sync to exchange
    | > | | Date: Tue, 16 Jan 2007 18:00:12 -0800
    | > | | Lines: 386
    | > | | X-Priority: 3
    | > | | X-MSMail-Priority: Normal
    | > | | X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
    | > | | X-RFC2646: Format=Flowed; Original
    | > | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
    | > | | Message-ID: <#P$>
    | > | | Newsgroups: microsoft.public.windows.server.sbs
    | > | | NNTP-Posting-Host: user-0c2i932.cable.earthlink.net 24.41.36.98
    | > | | Path:
    TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP02.phx.gbl
    | > | | Xref: TK2MSFTNGHUB02.phx.gbl
    microsoft.public.windows.server.sbs:10809
    | > | | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | > | |
    | > | | I'm having trouble emailing the files to you.
    | > | |
    | > | | Below is the message I've received.
    | > | |
    | > | | --------------------------------------------
    | > | | Reporting-MTA: dns;MYDOMAIN.com
    | > | |
    | > | | Final-Recipient: rfc822;
    | > | | Action: delayed
    | > | | Status: 4.4.7
    | > | | Will-Retry-Until: Thu, 18 Jan 2007 02:06:53 -0800
    | > | | X-Display-Name: ''
    | > | |
    | > | | --------------------------------------------------------------
    | > | |
    | > | |
    message
    | > | | | > | | > Hello John,
    | > | | >
    | > | | > Thanks for posting here.
    | > | | >
    | > | | > From your post, my understanding on this issue is: You encountered
    | > | support
    | > | | > code 85010014 during ActiveSync with SBS. If I'm off base, please
    | > feel
    | > | | > free
    | > | | > to let me know.
    | > | | >
    | > | | > Based on my knowledge, support code 85010014 means error HTTP
    500. I
    | > | | > suggest we try the following steps to see if we can resolve this
    | > issue:
    | > | | >
    | > | | > Step 1: For you change the DNS, I suggest you to Rerun CEICW to
    | > recreate
    | > | | > the self issued certificate
    | > | | >
    | > | | > Go through the follow KB and Rerun CEICW again carefully.
    | > | | >
    | > | | > How to configure Internet access in Windows Small Business Server
    | > 2003
    | > | | > http://support.microsoft.com/kb/825763/en-us
    | > | | >
    | > | | > Detailed steps for your reference:
    | > | | >
    | > | | > 1. On the SBS 2003 Server open the Server Management console. Go
    to
    | > | | > Standard Management\To Do List.
    | > | | >
    | > | | > 2. Click the "Connect to the Internet" link.
    | > | | >
    | > | | > 3. When navigating to the Firewall page, select "Enable firewall"
    | > and
    | > | | > click
    | > | | > Next (I suppose you have 2 network adapters in SBS 2003).
    | > | | >
    | > | | > 4. On the "Services Configuration" page, select all the items and
    | > then
    | > | | > click Next.
    | > | | >
    | > | | > 5. On the "Web Services Configuration" page, make sure "Allow
    access
    | > to
    | > | | > the
    | > | | > entire Web site from the Internet" is selected. If you select
    "Allow
    | > | | > access
    | > | | > to only the following Web site services from the Internet", make
    | > sure
    | > | all
    | > | | > item in the list are selected. Click Next.
    | > | | >
    | > | | > 6. On the "Web Server Certificate" page, choose to create a new
    Web
    | > | server
    | > | | > certificate and then type the public FQDN (your new DNS name) that
    | > you
    | > | | > will
    | > | | > use to access ActiveSync and OMA (for example, if your public FQDN
    | > that
    | > | | > you
    | > | | > use to access the sites is mail.xyz.com, you should type
    | > mail.xyz.com
    | > as
    | > | | > the new certificate name).
    | > | | >
    | > | | > 7. Go through the remaining steps.
    | > | | >
    | > | | > Step 2: The error often happens when the authentication method is
    | > not
    | > | | > configured correctly in ActiveSync, OMA and Exchange-OMA virtual
    | > | | > directory.
    | > | | >
    | > | | > Please verify Authentication settings by the following steps.
    | > | | >
    | > | | > For Exchange-oma virtual directory:
    | > | | >
    | > | | > 1. Open IIS Manager
    | > | | > 2. Open properties of virtual directory Exchange-oma
    | > | | > 3. Select Directory Security tab
    | > | | > 4. Select Edit in Authentication and access control box. Make
    sure
    | > the
    | > | | > authentication setting as below:
    | > | | >
    | > | | > Authentication Methods
    | > | | > Enabled Basic authentication
    | > | | > Enabled Integrated Windows authentication
    | > | | > Disabled anonymous access
    | > | | >
    | > | | > For OMA virtual directory and Microsoft-Server-ActiveSync virtual
    | > | | > directory:
    | > | | >
    | > | | > 1. Open IIS Manager
    | > | | > 2. Open properties of OMA virtual directory and
    | > | | > Microsoft-Server-ActiveSync
    | > | | > virtual directory respectively.
    | > | | > 3. Select Directory Security tab
    | > | | > 4. Select Edit in Authentication and access control box. Make
    sure
    | > the
    | > | | > authentication setting as below:
    | > | | >
    | > | | > Authentication Methods
    | > | | > Uncheck Enable anonymous access
    | > | | > Uncheck Integrated Windows authentication
    | > | | > Check Basic authentication
    | > | | >
    | > | | > After that, please restart the IIS Admin Service (services.msc)
    and
    | > then
    | > | | > verify the issue.
    | > | | >
    | > | | > If the issue persists after steps above, in order to have a more
    | > | concrete
    | > | | > idea about the issue, please let me know the following info.
    | > | | >
    | > | | > 1. Does issue happen to accessing mailbox by OMA? For further
    test,
    | > | please
    | > | | > login Exchange Server itself, and access URL:
    http://SBS_Server/OMA,
    | > | | > verify
    | > | | > whether you can access the mailbox successfully.
    | > | | >
    | > | | > 2. Do all the users have such issue or just specific users? Please
    | > | create
    | > | | > a
    | > | | > new mail-enabled user and verify whether he can access mailbox by
    | > | | > ActiveSync.
    | > | | >
    | > | | > 3. Collect the IIS metabase on Exchange Server and send to me:
    | > | | > for further analysis:
    | > | | >
    | > | | > 1). On Exchange Server, install .NET Framework Version 1.1:
    | > | | >
    | > |
    | >
    http://www.microsoft.com/downloads/details.aspx?FamilyID=262d25e3-f589-4842-
    | > | | > 8157-034d1e7cf3a3&DisplayLang=en.
    | > | | > 2). Install MBExplorer by installing IIS 6 Resource Kit Tools:
    | > | | >
    | > |
    | >
    http://www.microsoft.com/downloads/details.aspx?FamilyId=56FC92EE-A71A-4C73-
    | > | | > B628-ADE629C89499&displaylang=en.
    | > | | > 3). Once it is installed, access it from Start, Programs, IIS
    | > Resources,
    | > | | > Metabase Explorer.
    | > | | > 4). In the left pane, right click ''LM'' (under your server
    computer
    | > | name)
    | > | | > to choose ''Export to file'', and then save it as IIS.mbk.
    | > | | > 5). Compress this mbk file and send it to me for analysis. Please
    | > let
    | > me
    | > | | > know the password if you set on this iis mbk file.
    | > | | >
    | > | | > 4. Please collect the IIS log on Exchange Server so that I can
    | > perform
    | > | | > further research:
    | > | | >
    | > | | > 1). On Exchange Serves, open IIS MMC, right click Default Web Site
    | > and
    | > | | > then
    | > | | > click Properties.
    | > | | > 2). Click Website tab and then check Enable logging.
    | > | | > 3). Stop the Default Website and RENAME the existing IIS log files
    | > under
    | > | | > C:\WINDOWS\system32\LogFiles\W3SVC1.
    | > | | > 4). Restart the Default Website and reproduce the problem, which
    | > will
    | > | | > generate new IIS log file with the exact error.
    | > | | > 5). Wait for a while so that IIS Log can be synced. And then go
    to
    | > the
    | > | | > following folder on Exchange Server:
    | > | C:\WINDOWS\system32\LogFiles\W3SVC1.
    | > | | > 6). Send me the log files to my working email address
    | > | | > . And please let me know the alias of the
    user
    | > who
    | > | | > encountered the issue.
    | > | | >
    | > | | > 5. For further test, please temporarily disable SSL if you enable
    it
    | > for
    | > | | > ActiveSync; create a new test account and let me know the
    following
    | > | | > information.
    | > | | >
    | > | | > - Credential of this test account
    | > | | > - The public URL of your Exchange Server
    | > | | > - Domain name
    | > | | >
    | > | | > I will access the mailbox by ActiveSync in my side to verify the
    | > issue.
    | > | To
    | > | | > keep these confidential, please let me know by mail:
    | > | | >
    | > | | >
    | > | | > Hope this helps. Please let me know the results so that I can
    | > provide
    | > | | > further assistance on this problem. I am looking forward to your
    | > reply.
    | > | | >
    | > | | > Thanks and have a nice day!
    | > | | >
    | > | | > Best regards,
    | > | | >
    | > | | > Terence Liu(MSFT)
    | > | | >
    | > | | > Microsoft CSS Online Newsgroup Support
    | > | | >
    | > | | > Get Secure! - www.microsoft.com/security
    | > | | >
    | > | | > =====================================================
    | > | | > This newsgroup only focuses on SBS technical issues. If you have
    | > issues
    | > | | > regarding other Microsoft products, you'd better post in the
    | > | corresponding
    | > | | > newsgroups so that they can be resolved in an efficient and timely
    | > | manner.
    | > | | > You can locate the newsgroup here:
    | > | | > http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    | > | | >
    | > | | > When opening a new thread via the web interface, we recommend you
    | > check
    | > | | > the
    | > | | > "Notify me of replies" box to receive e-mail notifications when
    | > there
    | > | are
    | > | | > any updates in your thread. When responding to posts via your
    | > | newsreader,
    | > | | > please "Reply to Group" so that others may learn and benefit from
    | > your
    | > | | > issue.
    | > | | >
    | > | | > Microsoft engineers can only focus on one issue per thread.
    Although
    | > we
    | > | | > provide other information for your reference, we recommend you
    post
    | > | | > different incidents in different threads to keep the thread
    clean.
    | > In
    | > | | > doing
    | > | | > so, it will ensure your issues are resolved in a timely manner.
    | > | | >
    | > | | > For urgent issues, you may want to contact Microsoft CSS directly.
    | > | Please
    | > | | > check http://support.microsoft.com for regional support phone
    | > numbers.
    | > | | >
    | > | | > Any input or comments in this thread are highly appreciated.
    | > | | > =====================================================
    | > | | >
    | > | | > This posting is provided "AS IS" with no warranties, and confers
    no
    | > | | > rights.
    | > | | >
    | > | | > --------------------
    | > | | > | From: "John" <johnAtUnwantedmailDotCom>
    | > | | > | Subject: WM5 can not sync to exchange
    | > | | > | Date: Sun, 14 Jan 2007 18:37:47 -0800
    | > | | > | Lines: 122
    | > | | > | X-Priority: 3
    | > | | > | X-MSMail-Priority: Normal
    | > | | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
    | > | | > | X-RFC2646: Format=Flowed; Original
    | > | | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
    | > | | > | Message-ID: <>
    | > | | > | Newsgroups:
    | > | | >
    | > |
    | >
    microsoft.public.exchange.admin,microsoft.public.exchange.mobility,microsoft
    | > | | > public.windows.server.sbs
    | > | | > | NNTP-Posting-Host: user-0c2i932.cable.earthlink.net 24.41.36.98
    | > | | > | Path:
    | > TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP04.phx.gbl
    | > | | > | Xref: TK2MSFTNGHUB02.phx.gbl
    | > microsoft.public.exchange.mobility:129
    | > | | > microsoft.public.windows.server.sbs:10194
    | > | | > microsoft.public.exchange.admin:6974
    | > | | > | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | > | | > |
    | > | | > | My mobile device is running WM5 and my exchange server is a
    | > SBS2003
    | > | SP1
    | > | | > | running ISA 2004
    | > | | > |
    | > | | > | The Exchange server has a self issued certificate that is
    trusted
    | > by
    | > | the
    | > | | > | mobile device.
    | > | | > |
    | > | | > | The system worked correctly for over a year, but began failing
    | > last
    | > | | > night
    | > | | > | after changing some DNS entries. these entries have been changed
    | > back
    | > | | > but
    | > | | > | errors continue.
    | > | | > |
    | > | | > | No errors are found in the event log.
    | > | | > |
    | > | | > | The mobile device is able to access the server, both when
    | > connected
    | > | to a
    | > | | > | internal desktop computer, and over the mobile GPRS but it
    fails
    | > to
    | > | sync
    | > | | > in
    | > | | > | both cases.
    | > | | > |
    | > | | > | The following error message is received from active sync.
    | > Activesync
    | > | | > | encountered a problem on the server. Support Code:85010014
    | > | | > |
    | > | | > | Please note the HTTP 500 error received at the end of the
    | > Activesync
    | > | | > log.
    | > | | > |
    | > | | > |
    | > | | >
    | > |
    | >
    __________________________________________________________________________
    | > | | > | Below are 2 connection attempts, the first internal, the second
    | > | | > external.
    | > | | > | IIS Log
    | > | | > | //internal
    | > | | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:16:44, W3SVC1,
    | > myServer,
    | > | | > | 10.0.0.1, 15, 422, 587, 200, 0, OPTIONS,
    | > /Microsoft-Server-ActiveSync,
    | > | | > |
    | > | | >
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | > | | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | > | | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:16:50, W3SVC1,
    | > myServer,
    | > | | > | 10.0.0.1, 5438, 493, 313, 500, 0, POST,
    | > /Microsoft-Server-ActiveSync,
    | > | | > |
    | > | | >
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | > | | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | > | | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:17:02, W3SVC1,
    | > myServer,
    | > | | > | 10.0.0.1, 0, 422, 587, 200, 0, OPTIONS,
    | > /Microsoft-Server-ActiveSync,
    | > | | > |
    | > | | >
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | > | | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | > | | > | 24.41.36.98, myDomain\userName, 1/14/2007, 18:17:08, W3SVC1,
    | > myServer,
    | > | | > | 10.0.0.1, 5375, 493, 313, 500, 0, POST,
    | > /Microsoft-Server-ActiveSync,
    | > | | > |
    | > | | >
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | > | | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | > | | > | //external
    | > | | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:17, W3SVC1,
    | > | myServer,
    | > | | > | 10.0.0.1, 15, 422, 587, 200, 0, OPTIONS,
    | > /Microsoft-Server-ActiveSync,
    | > | | > |
    | > | | >
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | > | | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | > | | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:25, W3SVC1,
    | > | myServer,
    | > | | > | 10.0.0.1, 5500, 493, 313, 500, 0, POST,
    | > /Microsoft-Server-ActiveSync,
    | > | | > |
    | > | | >
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | > | | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | > | | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:31, W3SVC1,
    | > | myServer,
    | > | | > | 10.0.0.1, 0, 422, 587, 200, 0, OPTIONS,
    | > /Microsoft-Server-ActiveSync,
    | > | | > |
    | > | | >
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Log=VNATNASNC:0A0C0D
    | > | | > 0FS:0A0C0D0SP:0C0I0S0R0S0L0H,
    | > | | > | 208.54.14.19, myDomain\userName, 1/14/2007, 18:23:38, W3SVC1,
    | > | myServer,
    | > | | > | 10.0.0.1, 5391, 493, 313, 500, 0, POST,
    | > /Microsoft-Server-ActiveSync,
    | > | | > |
    | > | | >
    | > |
    | >
    User=userName&DeviceId=myDeviceID&DeviceType=SmartPhone&Cmd=FolderSync&Log=V
    | > | | > 4TNASNC:0A0C0D0FS:0A0C0D0SP:5C0I0S0R0S0L0H0P,
    | > | | > |
    | > | | >
    | > |
    | >
    _________________________________________________________________________
    | > | | > |
    | > | | > | Below is an activesync verbose error log
    | > | | > |
    | > | | >
    | > |
    | >
    _________________________________________________________________________
    | > | | > | =-= Build 14847 =-=
    | > | | > | =-= No XIP Information Available =-=
    | > | | > | myExternalFQDN
    | > | | > |
    | > | | > | =-=- [14/1/2007 18:29:50.0] -=-=
    | > | | > | =-=-=-= Client Request =-=-=-=
    | > | | > | OPTIONS
    | > | | > |
    | > | | >
    | > |
    | >
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=Sma
    | > | | > rtPhone
    | > | | > | Accept-Language: en-us
    | > | | > | MS-ASProtocolVersion: 2.5
    | > | | > | X-MS-PolicyKey: 0
    | > | | > |
    | > | | > | -=-=-=- Start of Body -=-=-=-
    | > | | > |
    | > | | > |
    | > | | > | =-=- [14/1/2007 18:29:51.0] -=-=
    | > | | > | =-=-=-= Server Response =-=-=-
    | > | | > | HTTP/1.1 200 OK
    | > | | > | Connection: Keep-Alive
    | > | | > | Content-Length: 0
    | > | | > | Date: Mon, 15 Jan 2007 02:29:51 GMT
    | > | | > | Server: Microsoft-IIS/6.0
    | > | | > | MicrosoftOfficeWebServer: 5.0_Pub
    | > | | > | X-Powered-By: ASP.NET
    | > | | > | Pragma: no-cache
    | > | | > | Public: OPTIONS, POST
    | > | | > | Allow: OPTIONS, POST
    | > | | > | MS-Server-ActiveSync: 6.5.7638.1
    | > | | > | MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
    | > | | > | MS-ASProtocolCommands:
    | > | | > |
    | > | | >
    | > |
    | >
    Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateColle
    | > | | >
    | > |
    | >
    ction,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,F
    | > | | >
    | > |
    | >
    olderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,Vali
    | > | | > dateCert,Provision,Search,Notify,Ping
    | > | | > |
    | > | | > |
    | > | | > | -=-=-=- Start of Body -=-=-=-
    | > | | > |
    | > | | > |
    | > | | > | =-=- [14/1/2007 18:29:51.0] -=-=
    | > | | > | =-=-=-= Client Request =-=-=-=
    | > | | > | POST
    | > | | > |
    | > | | >
    | > |
    | >
    Microsoft-Server-ActiveSync?User=userName&DeviceId=myDeviceID&DeviceType=Sma
    | > | | > rtPhone&Cmd=FolderSync
    | > | | > | Accept-Language: en-us
    | > | | > | MS-ASProtocolVersion: 2.5
    | > | | > | Content-Type: application/vnd.ms-sync.wbxml
    | > | | > | X-MS-PolicyKey: 0
    | > | | > |
    | > | | > | -=-=-=- Start of Body -=-=-=-
    | > | | > | <?xml version="1.0" encoding="utf-8"?><FolderSync
    | > | | > | xmlns="FolderHierarchy:"><SyncKey>0</SyncKey></FolderSync>
    | > | | > |
    | > | | > | =-=- [14/1/2007 18:29:57.0] -=-=
    | > | | > | =-=-=-= Server Response =-=-=-
    | > | | > | HTTP/1.1 500 Internal Server Error
    | > | | > | Connection: Keep-Alive
    | > | | > | Content-Length: 56
    | > | | > | Date: Mon, 15 Jan 2007 02:29:57 GMT
    | > | | > | Content-Type: text/html
    | > | | > | Server: Microsoft-IIS/6.0
    | > | | > | MicrosoftOfficeWebServer: 5.0_Pub
    | > | | > | X-Powered-By: ASP.NET
    | > | | > | Pragma: no-cache
    | > | | > | MS-Server-ActiveSync: 6.5.7638.1
    | > | | > |
    | > | | > |
    | > | | > |
    | > | | > | Thank you for looking this over,
    | > | | > | John
    | > | | > |
    | > | | > |
    | > | | > |
    | > | | >
    | > | |
    | > | |
    | > | |
    | > |
    | > |
    | >
    |
    |
    |
     
    Terence Liu [MSFT], Jan 22, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.