WMDC / Artemis disconnects

Discussion in 'Windows Vista Hardware' started by debully, May 13, 2007.

  1. debully

    debully Guest

    Background: No problems with vista/orbit before sending laptop of for a hdd
    swap out, comes back with a new drive and I do a fresh install of Vista, WMDC
    has been updated to final version 6 in the mean time and nothing now works.
    Orbit is then hard resetted. WMDC tries to set up the device but before I can
    press the 'set up my device button' my laptop thinks the device has
    disconnected.

    This fault happens however I try and connect my device. Any sugestions are
    welcomed, but I am rapidly running out ideas myself.

    Nothing I try resolves this problem. And I now believe I have tried
    everything, including:

    reinstalling vista on a new partition,
    trying to install without additional drivers,
    with additional drivers,
    3 different cables,
    virus scanners off,
    firewalls off,
    3 other devices connect/sync ok - not Artemis' tho - not WM5 devices.
    uninstalling and reinstalling wmdc and driver update - reboots in between,
    port opening,
    driver forcing,
    new bios - old bios.
    Advanced USB connectivity on/off

    Amonst other stuff! And still the problem is the same:

    I plug in the phone - and the device listed in device manager under portable
    devices (Windows Mobile device) appears until just after the 'set up your
    device' box appears in WMDC then dissapears. WMDC then reports 'not connected'

    The driver which dissapears reports this to ms:

    Description:
    Windows was able to successfully install device driver software, but the
    driver software encountered a problem when it tried to run. The problem code
    is 0.

    Problem signature:
    Problem Event Name: PnPDeviceProblemCode
    Architecture: x86
    Hardware Id: TCPIP\WINDOWS_MOBILE_DEVICE
    Setup class GUID: {eec5ad98-8080-425f-922a-dabf3de3f69a}
    PnP problem code: 00000000
    Driver name: WUDFRd.sys
    Driver version: 6.0.6000.16386
    Driver date: 11-02-2006
    OS Version: 6.0.6000.2.0.0.768.3
    Locale ID: 2057



    I just cannot get my head round this.

    TIA

    debully
     
    debully, May 13, 2007
    #1
    1. Advertisements

  2. debully

    debully Guest

    SOLVED - please excuse x-posts

    --------------------------------------------------------------------------------

    FFS I hope this helps someone and am fairy sure it will.

    The problem is MS's answer to the problems that ppl were having syncing from
    wmplayer and their storage cards (I guess)

    Basically, everytime the device is connected a few processes connected with
    windows media player start and if not manually ended will terminate the
    connection.

    To be able to terminate these processes I had to put my laptop into power
    saving mode to lower the cpu speed and gain enough time to hit the 'end
    process' button a few times.

    When you finally manage to stop each wmplayer connected service (i used task
    manager sorted alphabetically to see them) the device will install and WM
    DC will finally sync.

    Things to note:

    WMDC and WMDC drive update were uninstalled - pc was rebooted.
    advanced usb connectivity was turned off on device
    existing partnerships had been deleted in activesync on device
    *autoplay options set to 'do nothing' in Vista control panel*
    Although this problem did not appear on 3 of my old devices, it is not a
    specific Artemis problem as I have read MANY reports of the same behaviour.

    WMplayer will have to be manually killed on each connection or the device
    will disconnect - any ideas how to stop WMDC from launching on pluggin in
    device are welcome.
     
    debully, May 13, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.