WMDC worked in Evaluation - but not on new laptop w/ Vista Ultimat

Discussion in 'ActiveSync' started by mcasmcas, Feb 13, 2007.

  1. mcasmcas

    mcasmcas Guest

    Hi there,

    I have been killing myself over reading solutions on the internet and in
    this newsgroup before writing this, so this is really my last option. All
    comments / insights are extremely appreciated.

    The problem: WMDC is not working with my HTC TyTN device!!!

    (but when I was running the Evaluation version of Vista before that - on
    another laptop - everything was working fine!!)

    Chronologically, I've done the following to try and resolve the issue:

    1. New laptop came with Vista Ultimate --> but WMDC was not working 'out of
    the box' because Vista needs a driver (I tried all sorts of things including
    loading the CD with which my phone came, nothing worked)

    2. I then installed Version 6 from MS site, following the instructions
    carefully --> but WMDC was still not working (and it still kept asking for
    drivers)

    3. Reinstalled laptop with XP to see if this is a hardware issue (could be!)
    --> Activesync worked fine (so this is not a hardware issue)

    4. Removed XP and installed Vista --> WMDC still not working, as before

    5. Found on the MS website (the blog) a tip about changing the USB settings
    on my HTC TyTN, which I did; I removed the "Enable Enhanced Network
    Functionality" --> Vista now wants to install a different driver (but again
    does not accept original CD with which my mobile came)

    6. Considering it was working with Beta 3, I uninstalled WMDC completely and
    forced an install of WMDC Beta 3 (which I fortunately happened to keep) -->
    now, WMDC finally recognised my device and installed the driver "HTC USB
    Sync" --> but WMDC is still not syncing

    7. Changed back to the Enhanced Network Functionality --> WMDC installed
    RNDIS driver --> but WMDC not syncing

    8. Added ports to firewall (as some suggested) --> WMDC still not syncing

    9. Switched off firewall completely (to see if it was a firewall issue at
    all) --> WMDC not syncing

    10. Interestingly, WMDC kept saying "Error" when trying to locate my device,
    so I tried disconnecting my device during its "checking device" activity -->
    WMDC said my device was disconnected but had now named it "Pocket_PC"

    11. Tried re-syncing / re-scanning again --> No luck.

    12. Restarted PC numerous times --> No luck

    13. Manually killed the wmdc process in task manager because whenever you
    reconnect the phone it does not try and find it again --> No luck

    14. Tried to install Activesync 4.2 --> Vista simply won't let me :(


    What frustrates me the most is that this is supposed to be the RTM version.
    Moreover, it was working without a problem on the Evaluation version with
    WMDC Beta 3!!! Seriously, what good is my WM5 device if I can't even sync it
    anymore....... :(

    Does anybody have any ideas!?!? I have no more left.

    Thanks,
    mcas
     
    mcasmcas, Feb 13, 2007
    #1
    1. Advertisements

  2. mcasmcas

    mcasmcas Guest

    P.S. I think after version 6 it showed up with Windows Media (or BAR?)
    drives in the Sync center - but they are not accessible from Explorer, and
    only (sometimes) does it recognise my MicroSD card from my device.
     
    mcasmcas, Feb 13, 2007
    #2
    1. Advertisements

  3. Can you do 2 things for me? Post your \windows\inf\setupapi.dev.log file -
    this will show me what driver its picking and installing when you plug in
    your device. Check you Event Log for events from rapimgr or wcescomm:
    start->computer, right click, manage, look under system tools->Event
    Viewer->Windows Logs->Application
     
    Gary Waliczek [MSFT], Feb 14, 2007
    #3
  4. mcasmcas

    Ako Guest

    Since I am having some of the same problems, I looked in my log file and it
    is huge and dated 2/9/07. Then I looked at "applications" and WMDC did not
    show up when I used it at 5pm (CST) to try and syn with my smartphone.

    Can you help me understand how to find what you're looking for? Nothng is
    working for me. One syn early on and now never past connected.
     
    Ako, Feb 15, 2007
    #4
  5. mcasmcas

    mcasmcas Guest

    Gary, thanks for your response.

    It's solved now!! I have an Acer Aspire 9114 laptop and the drivers Acer
    just posted on their website solved all my problems. It works like before
    (like in the evaluation version). A lot of headache for nothing
    unfortunately, but at least it's all working now. Everything is!

    To all others who have issues; hassle your PC manufacturer and email your
    request here at the same time (might resolve things quicker).

    Thanks again.
     
    mcasmcas, Feb 15, 2007
    #5
  6. When I look at this log file, I usually start from the bottom and search up
    for instances of !! that relate to wceusbsh.inf, wcerndis.inf, wpdrapi.inf
    or wcebth.inf
    Its very large but compresses amazingly well in a zip or cab file.
     
    Gary Waliczek [MSFT], Feb 15, 2007
    #6
  7. mcasmcas

    Ako Guest

    Gary:

    Would you be willing to look at my log? I have tried to post it here with my
    message, but even the zip version is apparently too large. I don't have a
    clue about how to
    read it and as noted already I can't find the second part of your directive
    posted earlier in this thread.

    I took delivery of a new pc 2 weeks ago with Vista from the factory. I
    quickly installed WMDC and was able to sync with my Cingular 3125 for at
    least one day. Then I started installing software needed to do office work
    on my pc at home. From that point out, I have not been able to get past the
    "connected" stage. When the sync bar starts to light up, it quickly turns
    red and says that 'activesyn' (which I do not have on my pc and only the
    factory installed on my phone) encountered a problem on my desktop.

    I don't think the problem is my phone since sync did work originally. And
    the third party software that is installed have nothing to do with sync, but
    are Ms Voice Command, Sprite BackUp, Don't Forget, and Google Maps. And
    whenever possible, I install these programs on my storage card, not on the
    device itself. I just noticed an icon for "midlet manager' and I don't
    remember what this program is and if it came from the factory. I hestitate
    to uninstall all these programs and do a reinstall since I am not tech-savy
    enough to make sure they will all work again esp now that my pc has Vista
    rather than Xp. And I will have to relearn how to install everyone of them
    since I have almost no memory of how they were installed.

    Anyway advice you could give would be much appreciate. Not being able to
    sync with my home pc is now more than an inconvenience.

    Harold
     
    Ako, Feb 17, 2007
    #7
  8. the setupapi.dev.log file only has to do with WMDC installing, on first
    connect or Windows Update. In this case it sounds like there may something
    that installed itself into your Windows networking layer thats breaking the
    connectivity. I assue this is a Windows Mobile 5 (or later) device? Can
    you try turning off "Advanced Networking" in the PC connection settings, or
    try connecting Bluetooth or IR?
     
    Gary Waliczek [MSFT], Feb 20, 2007
    #8
  9. mcasmcas

    Ako Guest

    My Cingular 3125 is Mobile 5. Until advised today by Jane Ly to try out
    Advanced Networking, I did not have that activated on my phone. I do use BT
    at the office on my Xp pc, but don't have a BT or IR connection at home so I
    use the USB cable.

    It confuses me somewhat that I did get it to syn when everything was new and
    have not changed anything on my smartphone but have added a lot of office
    software to my pc.

    Anyway you say I should uncheck Advanced Networking? Either way, I have not
    been able to get passed the connected stage and when the sync starts the
    inevitable encountered-a-problem-with-the-desktop error.
     
    Ako, Feb 21, 2007
    #9
  10. The log of interest is the ETL trace found in
    \Windows\System32\LogFiles\WindowsMobile
    Probably the one with the most recent time stamp - a new one gets created
    each reboot so if they're all too big, reboot and then try connecting just
    once, then post the file.
     
    Gary Waliczek [MSFT], Feb 21, 2007
    #10
  11. The network connection to the device is returning WSAESHUTDOWN which
    basically means the connection was closed. Either the device closed the
    connection or something on the PC that installed itself into your networking
    layer is closing the connection. That could be a firewall, anti-virus,
    anti-malware, VPN software, etc.
     
    Gary Waliczek [MSFT], Feb 21, 2007
    #11
  12. mcasmcas

    Ako Guest

    Gary:

    Thanks for taking time to review these data. Unfortunately some of your
    tech-speak if beyond my expertise.

    I haven't made any change to my Cingular 3125 through this process (one
    sucess then nothing beyond connection) with the exception of checking on my
    phone to enable advanced network functionality. I now have this unchecked as
    the one sync that worked did not have this checked.

    I have totally disabled my firewall (NIS 2007) but don't see how to
    completely stop the Norton anti-virus program. I have written special rules.
    I have run msconfig and disabled everything on those two main tabs. The
    results are the same.

    You loose me when you talk about "malware and VPN software". The office
    software that I have installed is Office 2007, WordPerfect X3 (with a Vista
    update), Ms Money 2004, Paperport Pro 11 (Vista verison) and Omni 15 (vista
    version). There is Ms software for my ms keyboard and mouse. There is
    preloaded software from Dell that I have yet to explore (like Google desktop
    and Google toolbar on the Ms Explorer browser) with the one exception being
    a Vista patch from Roxio to burn cds/dvds. Oh, yes I did install Real Player
    but don't see what that would do with my problem.

    One of the first programs I loaded was Laplink 12 Gold so I could transfer
    files from an old pc to this new one. But as I remember it I was finished
    with Laplink before I got around to trying out WMDC. In any event, I could
    uninstall it if it seems like a problem although it is for pc to pc, not pc
    to mobile device.

    I have Adobe productions like Acrobat 8 Pro, Photoshop CS 2, Pagemaker.

    So I'm lost and getting desperate. If I can't get my Vista pc to syn, I
    don't know what to do.

    Harold
     
    Ako, Feb 22, 2007
    #12
  13. I knew some of my earlier post wouldn't mean much to you but I try to post
    details for anyone who might be able to make use of them. I don't see
    anything in the list (as long as its not the firewall) that I would guess to
    be causing this. Does this device still work against other (WMDC or
    ActiveSync) machines?
     
    Gary Waliczek [MSFT], Feb 22, 2007
    #13
  14. mcasmcas

    Ako Guest

    I don't have access to another machine with Vista so I can not check WMDC,
    but I daily sync with the same smartphone at my office with a desktop
    running Xp Pro and using BT.

    I just did a chat session with Symantec about NIS 2007 and they could not
    help or nor that other link I found in this NG about the settings for this
    firewall that should work with WMDC.
     
    Ako, Feb 22, 2007
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.