WMP 11 on Vista Biz x64 Appcrash

Discussion in 'Windows Vista Music, Pictures and Video' started by bad_the_ba, Jun 21, 2008.

  1. bad_the_ba

    bad_the_ba Guest

    I'm hoping zachd sees this, since I have followed many of hi
    instructions and nothing has worked. Everything on his site looks ver
    helpful, but I think my situation may be a little more unique.
    installed Vista x64 several months ago, and have had Media Playe
    working fine with K-lite codec pack (being Vista Biz, there was no ou
    of the box DVD playback). It has also worked fine with Nero OEM
    installed, but i do not think the nero burn plug in was ever installe
    or used by WMP. I have made several hardware changes recently, mainl
    because my motherboard was upgraded by ASUS's warranty department afte
    sending in another last year. So I had Vista installed fresh with my ne
    board, but old proc and memory. About 3 weeks ago, I replaced th
    processor, but since I have most of my music on another computer,
    never really used WMP on the new setup. Today, I tried to set up m
    library on WMP11 on x64, and whenever I open WMP it crashes withi
    seconds. The only way I can get it to stay open for any length of tim
    is to open a preferences menu, or somehow get it to switch to a ta
    other than "library" quick enough. I browsed Google and various forum
    to get enough info to try several steps, and nothing yet has worked.
    have uninstalled K-lite codecs and Nero. I have deleted the contents o
    the DRM folder. I have tried individualizing DRM again. I have delete
    the Media Player folder under my profile which includes my librar
    databases. With K-lite codecs reinstalled, I am able to play a DVD a
    times, but any time Media player stays on the library window for mor
    tha na few seconds, it crashes. Here is the data I receive

    Problem signature
    Problem Event Name: APPCRAS
    Application Name: wmplayer.ex
    Application Version: 11.0.6001.700
    Application Timestamp: 4791935
    Fault Module Name: Indiv01.ke
    Fault Module Version: 11.0.6000.632
    Fault Module Timestamp: 47e3274
    Exception Code: c000000
    Exception Offset: 0011167
    OS Version: 6.0.6001.2.1.0.256.
    Locale ID: 103
    Additional Information 1: fd0
    Additional Information 2: ea6f5fe8924aaa756324d57f8783416
    Additional Information 3: fd0
    Additional Information 4: ea6f5fe8924aaa756324d57f8783416

    When I run the command found here 'WMP FAQ: A trouble-shooting guid
    for Windows Media Player problems.
    (http://zachd.com/pss/pss.html#indiv), I receive a similar crash wit
    these details

    Problem signature
    Problem Event Name: APPCRAS
    Application Name: unregmp2.ex
    Application Version: 11.0.6001.700
    Application Timestamp: 47919dc
    Fault Module Name: Indiv01_64.ke
    Fault Module Version: 11.0.6000.632
    Fault Module Timestamp: 47e326c
    Exception Code: 4000001
    Exception Offset: 00000000001230d
    OS Version: 6.0.6001.2.1.0.256.
    Locale ID: 103
    Additional Information 1: 293
    Additional Information 2: 64fd5719f41bbbf32ebe7651ae7fa3a
    Additional Information 3: dc5
    Additional Information 4: d1a695a3016dd30400e553e73a16232

    Also, opening the DRM update link in IE 7 results in a similar crash o
    IE with these results. 'Security component upgrade
    (http://drmlicense.one.microsoft.com/Indivsite/en/indivit.asp?force=1

    Problem signature
    Problem Event Name: APPCRAS
    Application Name: iexplore.ex
    Application Version: 7.0.6001.1800
    Application Timestamp: 47918f1
    Fault Module Name: Indiv01.ke
    Fault Module Version: 11.0.6000.632
    Fault Module Timestamp: 47e3274
    Exception Code: c000000
    Exception Offset: 0011b9e
    OS Version: 6.0.6001.2.1.0.256.
    Locale ID: 103
    Additional Information 1: fd0
    Additional Information 2: ea6f5fe8924aaa756324d57f8783416
    Additional Information 3: fd0
    Additional Information 4: ea6f5fe8924aaa756324d57f8783416

    I am pretty confident this issue is related to changing processors i
    this computer, but the steps listed on MS's tech site as a workaround d
    not work, as deleting the DRM folder, with or without backing up m
    licenses, fails to correct the issue. I have not ripped anything int
    the library on this Vista x64 setup, but instead was trying to connec
    to shared media on another computer. This same scenario works flawlessly
    on a Vista Home Premium x86 computer on the same network. I will post
    this, then see if I can swap enough things around to temporarily go back
    to the old proc, and update the thread if needed.
    Todd V.
     
    bad_the_ba, Jun 21, 2008
    #1
    1. Advertisements

  2. bad_the_ba

    zachd [MSFT] Guest

    Yeah, you followed the trail right so far - the Indiv crash you're hitting
    is definitively a crash in the DRM component. That's still on your system
    in a bad state, that's why you're crashing.
    http://zachd.com/pss/pss.html#indiv
    should fix you up, but since you're still crashing:
    Find those Indiv files on your system and then follow the "reset the DRM
    cache" instructions making sure you include those Indiv folders on your
    system.

    If you notice ways the documentation here could be made better, let me know.
    This should fix you up though - I'm betting you just missed a folder.
     
    zachd [MSFT], Jun 21, 2008
    #2
    1. Advertisements

  3. bad_the_ba

    Rob Redbeard Guest

    The real problem lies in the fact that Vista and/or WMP 11 do not properly
    handle having the system CPU changed. This was not always such a common
    thing to do. However, the Socket 775 platform's ubiquity and the presence of
    more "horizontal upgrades" such as moving from Celery's to dual or quad cores
    has made the chance of a user upgrading their CPU much more likely. Vista
    knows when you change the CPU, it detects and installs new software (or just
    registry settings) for it. You need to write a patch that back's up, resets,
    the recovers users license cache's. I fixed one set last night with WMP only
    to find that my Media Center (x64) were in another location and needed to be
    separately deleted. This problem is severe (in that it blocks users from
    loading WMP at all) and should have been patched last year.

    Rob
     
    Rob Redbeard, Jul 19, 2008
    #3
  4. bad_the_ba

    bad_the_ba Guest

    Sorry I didn't follow up on this earlier, I wasn't notified of zach's
    response for some reason. I have been awaiting a warranty situation from
    Seagate to decide if I wanted to reinstall Vista Biz 64 on a RAID
    configuration, as that is the reason I bought 2 drives (one brand new
    750GB makes interesting noises, so I left it unused). As of today,
    though, I saw the follow-up on my thread and went back for another try.
    I never use WMP on this computer, but then again I could never access my
    main library either. I went back through the instructions and gave it
    another go, and re-deleted the DRM folder contents (I assume files were
    recreated on my attempts to run WMP before during my first attempts). I
    ran the "run" command to Individualize once again, and it worked fine.
    Thanks zach for the expertise on this subject, and again... sorry I
    didn't see your response earlier.

    One interesting side note... the MS kb site you reference for resetting
    the DRM lists the registry location to finding the DRM store, but
    nothing more than HKEY_LOCAL_MACHINE\Software\Microsoft\DRM appears in
    the registry on my setup, no sub keys or anything. Pretty much
    inconsequential at this point, but the KB site shows
    HKEY_LOCAL_MACHINE\Software\Microsoft\DRM\DataPath should be available,
    showing the directory DRM is using.

    Bottom line is it's working. I don't know if I will reinstall Windows
    anyway because of changing my HDD setup, but kudos to you ZachD, I've
    learned something. Your website is very helpful.
     
    bad_the_ba, Jul 20, 2008
    #4
  5. bad_the_ba

    Rob Redbeard Guest

    Glad it worked for you. My point is that you shouldn't have to manually do
    this. I have never bought music online that uses DRM, so I've never even
    used these DRM features. I only found out there was a license store on my
    computer after I had to delete it to be able to use WMP 11 again. This
    should handled automatically when a CPU change occurs.

    Rob
     
    Rob Redbeard, Jul 20, 2008
    #5
  6. bad_the_ba

    bad_the_ba Guest

    You're right that it is an annoyance that could have been handled bette
    by MS. but you're wrong in placing the blame entirely on MS. Music an
    movie industries have been pressuring software and hardware vendor
    forever to build in more and more protection so that media cannot b
    copied from computer to computer, etc. I don't really view this a
    something that upset me, just something I wanted to figure out as
    technical support issue for future reference. I don't buy music onlin
    either, I just play my ripped media which I own on physical media acros
    a network. If you run into a new annoyance on Vista, don't just view i
    as a Microsoft failure. Personally, I just store this one away as
    nugget in the back of my brain that I might be able to help someone els
    out with in the future. Again, kudos to Zach, as he got me where
    wanted to be, and kept it simple

    Nope, no issues, I think it's very well laid out. Like you said, I mus
    have just missed a folder or something. This was easier than Microsoft'
    KB fix which involved returning the computer to it's origina
    configuration again :
     
    bad_the_ba, Jul 21, 2008
    #6
  7. bad_the_ba

    zachd [MSFT] Guest

    If you have a way to reliably reproduce this crash, I have The Right Guy on
    the DRM team who would loooooooooove to get that information from you.

    What exactly were you doing when you ran into that crash? How would he
    semi-reliably manage to run into this same error?

    (I realize it might be crystal clear to you, but there seems to be some
    missing data here so far that would be very helpful to have on the MS side.)


     
    zachd [MSFT], Jul 21, 2008
    #7
  8. bad_the_ba

    Rob Redbeard Guest

    I would love to help.
    Recreation of the WMP loadtime crash:
    System:
    Motherboard: GA-EX38-DS4 w/ latest Intel drivers
    Initial CPU: Core2Duo E6420
    OS: Windows Vista Ultimate 64-bit

    To create the problem, I took the CPU out and put in a new one: C2D E8400.

    That's it. When Vista booted it detected the hardware change. Office
    applications prompted to activate office online again. However, starting WMP
    resulted in it loading for a brief second, then crashing due to the lincense
    system. I'm relatively tech savy, so I googled around and found the KB
    article with the instructions to delete the license cache. However, this
    should never have been necessary, that's a critical failure in the user
    experience department. Good luck and have fun swapping CPU's.

    I appreciate you guys trying to make music profitable to musicians without
    making that annoying and cumbersome to users. How about instead of a buried
    KB article about how to back up, delete, and restore your license cache;
    writing a small procedure that does this when the system detects a CPU
    change. Hope you can finish it before the new q9650's come out. :)
    Rob
     
    Rob Redbeard, Jul 22, 2008
    #8
  9. bad_the_ba

    bad_the_ba Guest

    Yeah, My experience was pretty much the same. I had Installed Vista Bi
    x64 and had added a network folder to monitor for my WMP library. I ha
    no other music added other than the included sample music. The origina
    setup was
    Asus P5N32E-SLI Plu
    Pentium D 950 3.
    OCZ 2x2GB DDR2 800 SLI editio
    Seagate 750 GB SATAI
    I ordered parts for a Media Center PC, and when I got them I swappe
    the Pentium D for an E8400 and booted up. I got no errors or prompts an
    everything seemed like normal. Until I ran WMP for the first time.
    then got the AppCrash and it was reproduced every time I tried to ope
    WMP or Individualize through IE7. I have no other MS licensed softwar
    on his machine, and Vista at that point was still unactivated because o
    my HDD situation I had mentioned before. I assume that this could b
    reproduced the same way over and over again. The KB article told me wha
    I needed to do, but I was unwilling to swap back to the original config
    since I had the machines already set up on opposite ends of the house
    That's about it, thanks for the support
     
    bad_the_ba, Jul 22, 2008
    #9
  10. bad_the_ba

    zachd [MSFT] Guest

    This will be a great thread for anyone hitting this problem to help
    contribute to.

    Follow-up questions:
    * This was indeed the indiv001.key crash, right?
    * Was there any user mode or kernel debugger attached?


     
    zachd [MSFT], Jul 22, 2008
    #10
  11. bad_the_ba

    zachd [MSFT] Guest

    Thank you - the second confirmation on the E8400 is very interesting.

    If I'm reading this correctly: are you still hitting this crash these days?
    That might potentially have some additional value as it might still be able
    to be debugged in some fashion.
     
    zachd [MSFT], Jul 22, 2008
    #11
  12. bad_the_ba

    zachd [MSFT] Guest

    This may be tough to answer but:
    * Was the system individualized / able to play DRM files before the system
    upgrade?
    * Had the player been used before the system upgrade?

    Right now the dev and tester aren't getting any crashes when they:
    * indiv / play the content
    * swap CPU
    * play the content
    , so I'm wondering what they/I are missing here in terms of information.

    Thanks,
    -Zach
     
    zachd [MSFT], Jul 25, 2008
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.