WMP11 no longer streams .asx and .asf files

Discussion in 'Windows Vista General Discussion' started by Greg, Sep 16, 2008.

  1. Greg

    Greg Guest

    I get an error saying it's unable to play the files, and the detailed message
    suggests they are corrupted. They are not corrupted, I changed IE to use
    Winamp and they play just fine from the same sites. Also if I save the files
    to my hard drive, they iopen fine in WMP11. It only fusses when I try to
    stream them.

    The only thing that changed recently is I tried and then removed (via
    restore) IE8 as it was mangling the rendering of many pages.

    Yes I have a workaround, but as I experienced with XP and WMP9/10, it starts
    with one thing not working and gets progressively worse.

    As MS has decided to not allow me to uninstall and reinstall WMP11 under
    Vista, I have to do some repair "as is".
     
    Greg, Sep 16, 2008
    #1
    1. Advertisements

  2. Check WMP's Options
    In menu........*Tools >> Options*
    Navigate to *Network *tab
    Now select the check boxes as per used protocols and enable *Allow
    Player to receive multicast streams*


    --
    Ramesh Kumar MVP

    RAMESH KUMAR
    Microsoft MVP: 'My MVP Profile'
    (https://mvp.support.microsoft.com/profile/Ramesh.Kumar)
    My Blog: 'It's My Windows' (http://itsmywindows.com)
     
    Ramesh Kumar MVP, Sep 17, 2008
    #2
    1. Advertisements

  3. Greg

    Greg Guest

    Unfortunately, that option is already checked as are all the protocols.

    Greg
     
    Greg, Sep 18, 2008
    #3
  4. Greg

    Greg Guest

    More info: The same streams will play directly in Google Chrome using WMP
    11. Obviosuly the problem is not with WMP but with IE so perhaps my
    suspicion about IE8 corrupting something is correct?
     
    Greg, Sep 18, 2008
    #4
  5. Greg

    zachd [MSFT] Guest

    This sounds like your file associations are wonky.

    What's a sample URL that fails?
    What third party media players are installed?

    If you reset the file associations under Vista's Default Programs:Set
    Program Access and Defaults control panel, does that fix this up?
     
    zachd [MSFT], Sep 18, 2008
    #5
  6. Greg

    Greg Guest

    The file associations are correct. If I try to stream something at
    cdconnection.com, WMP 11 starts and says it is unable to play the file. If I
    save the link as a file and open it with WMP 11 it works fine. If I access
    the same site with Google Chrome, it plays in WMP 11. I looked at the
    contents of the .asx file and it is syntactically correct. If I enter the
    URL into WMP 11 it also plays fine.

    I also tried resetting the default program setting and that had no effect on
    the problem.

    I have the latest Winamp Pro and, for now, have associated .asx and .asf
    files with it so I can stream from IE 7.

    BTW, I tried the repair you suggesed to someone else, I think it was scf
    /scannow and afterwards my system would boot to the desktop and the CPU was
    so tied up doing something I couldn't do anything at all. From the 21 mb log
    file, it looks like it replaced two damaged files neither of which appears to
    be related to WMP. Repeated reboots didn't fix the problem so I booted to
    safe mode and rolled back to the previous day.

    Greg
     
    Greg, Sep 19, 2008
    #6
  7. Greg

    zachd [MSFT] Guest

    What's a sample URL that fails?

    WinAMP and any other player that I'm aware of download the media file
    differently than the player does. You cannot emulate what the player does
    in any other fashion. You cannot emulate the file association methodology
    used precisely here in any other way. It is indeed possible to "speed bump"
    the association via incorrect third party associations so that an internal
    file association check fails but the file association then correctly works
    on a secondary path which may or may not result in a minor aberration which
    can affect playback. But if you went through SPAD you ~should~ have
    corrected that path if it was broken.
     
    zachd [MSFT], Sep 19, 2008
    #7
  8. Greg

    Greg Guest

    As I already stated above, www.cdconnection.com. I cannot stream any of the
    sample audio files.

    Other than your querty about url, the rest of your answer/comment is
    complete gibberish and I'm not impressed. If you are here to help (which I
    appreciate) then help, don't write something that sounds like a politician on
    the Sunday morning talk shows.

    Greg
     
    Greg, Sep 22, 2008
    #8
  9. Greg

    zachd [MSFT] Guest

    Right, but if you told me *exactly* what you were trying to play, that would
    help me *exactly* try what you're trying, this ensuring better accuracy of
    my testing. =)

    If you right-click Save As one of those ASX's to your hard drive and open up
    that ASX in the player directly, does it work then?

    I'm not attempting to be on TV, just attempting to point out important
    technical considerations which you had *potentially* glossed over with this
    comment: "The file associations are correct". It is nearly impossible for
    anyone to verify that without inspecting the registry directly (even if it
    "seems" right, other things can be going on) as the file association methods
    used can be intricate. I'm assuming that's ~not~ the problem going on here,
    but that's hard to definitively say.

    I am here to help and am unfortunately ill-suited to do so as I work writing
    code for areas of my interest and thus suck at explaining to the lay more
    casual observer that appearances can be deceiving. I apologize. =\
     
    zachd [MSFT], Sep 22, 2008
    #9
  10. Greg

    Greg Guest

    The reason I know the file associations are correct is if I try to stream the
    audio file, it does start WMP 11 with an error message saying it's unable to
    play the file. If the association wasn't correct I assume WMP would not be
    launched a all. Yes, if I save the .asx file to disk and then open it with
    WMP 11, it does play.

    Try *any* audio link on cdconnection.com, choose your favorite music and
    then save the target file if you want to examine the .asx file. No matter
    what file I try to stream, the results are the same.

    Here's the contents of one I have saved to disk:

    <ASX Version="3.0"><ENTRY><REF
    HREF="mms://sg5.allmusic.com/027wma_28/s131/s13158/s1315886/s131588602hb6je.wma"/></ENTRY></ASX>

    I am also a software developer who has to provide client support at times.
    I know the difficulties of seeing exactly what the client is seeing and
    appreciate them. I also know giving my clients excess technical information
    on what's going on is probably making their eyes glaze over. :) I still
    can't make much sense of your previous post. My comments were meant to be
    tongue-in-cheek, I do appreciate your help. :)

    Greg
     
    Greg, Sep 22, 2008
    #10
  11. Greg

    zachd [MSFT] Guest

    Nope: it can just get launched differently. There's multiple layers of
    associations, if one fails you simply step down a layer. When you're
    interacting with a web server, sometimes they can try to do little
    server-side tricks that will interfere with that failover.
    OK, and so for you when you click "Web Help" on that Error dialog, what
    *URL* does it take you to?

    Does it happen with non-CDConnection web sites? Does a sample WMV such as
    one of http://zachd.com/mvc2/fulllist.html?360 work for you? Does a sample
    ASF such as one of http://zachd.com/mvc2/fulllist.html?asf work for you? (I
    realize that content is all dumb, but -- I know the URL off the top of my
    head, so that's a quick test URL.)

    -Z
     
    zachd [MSFT], Sep 22, 2008
    #11
  12. Greg

    Greg Guest

    Let me try again: If I go to internet options/programs, then click Set
    Programs under internet program,s it brings up a dialog. I click associate a
    file type or... and scroll down to .asx. Right now it';s set to winamp but
    if I set it back to WMP, the fle type doesn't stream. Are you saying this is
    NOT the place to set the file associations? And yes, it's not just
    cdconnection, and, in any case, cd connection was working up until recently.

    I've also used the set your default program option on the same dialog.

    None of your files stream, the only choices I get are open, save, cancel.
    As far as I can tell, the only difference between open and save is where it
    places the file, but regardless it is downloaded before playing.

    Some change I have made since pursuing this problem now causes the streams
    on cdconnection to fail without an error message. I click, it appears to do
    a quick download but nothing comes up so I can no longer tell you where it
    goes when I click Web Help. I can tell you it suggested codec, compression
    or corrupted file.

    Wouldn't it be nice if MS allowed me to unistall WMP 11 so I could reinstall
    it thereby reestablishing the associations and/or repairing whatever the
    problem is?

    Greg
     
    Greg, Sep 22, 2008
    #12
  13. Greg

    zachd [MSFT] Guest

    'Set your default programs' does per-user file associations, which is why I
    explicitly referenced "Set Program Access and Defaults", which also allows
    the player a minor chance to correct damage other utilities/players can do
    to its associations. They're related but different. =)
    Interesting: is that with WMP or WinAMP set as default? This is obviously
    incorrect behavior and a likely sign that the file association is indeed set
    wrong. I had kind of been moving away from that as a suspected cause, but
    your system behaving this way does indicate that it is currently set
    incorrectly.
    Yes, it's too bad that MS doesn't offer this functionality that would *not*
    have reestablished the associations and/or likely repaired whatever the
    problem is. ;-)

    The basic BOMs (install designs) are on your system and can be inspected.
    You'll note that the player install design is to be friendly to other
    players that take associations, which thus means that associations are not
    reestablished.* It also operates on a global (per-machine) level only,
    really, so if you are experiencing user-level corruption (verifiable via
    trying this on a second account on the system), it would be unlikely to
    repair the problem in question. Does this work for a new user account on
    your system? (Note that system-wide association corruption/mis-setting
    would also affect a second user, so this isn't definitive, just potentially
    interesting.)

    * These registrations are done in config sections designed not to overwrite
    settings done by other players. The (system) component installer has no
    mechanism for determining if the association chain is valid, and since that
    could change as components (shell, IE) get updated, there would be no
    persistent way to determine that. Windows Media Player's SPAD
    implementation is your only chance to give the player the reins to reset
    things back to "normal" if they were corrupt. SYDP operates via the shell
    parsing the application's Capabilities information, which does not allow the
    player to reset any system-wide corruption. Capabilities points to
    something along the lines of WMP11.AssocFile.ASF - if Player XYZ decides to
    corrupt WMP11.AssocFile.ASF, SYDP doesn't and can't correct for that (it
    doesn't know). SPAD *can* correct for that (with the additional notation
    that it's always possible to do righteously horrible things to file
    associations, so it's always best to use your own named hive. You would
    think that with a name like "WMP11.something" other apps would not stomp on
    those subkeys, but you'd be surprised. The WMP code will try to repair
    damage done to the "WMP11.something" hives if I recall correctly, but it
    isn't always possible.)



    Let's get back to core interesting questions as opposed to tangenting over
    to underlying technology which I find fascinating but you likely find a
    waste of your time:
    * Did you try SPAD?
    * Does it work for a second account?
    * What are the values and subkeys under HKEY_CLASSES_ROOT\.asx and under
    HKEY_CLASSES_ROOT\WMP11.AssocFile.ASX ?

    -Zach
     
    zachd [MSFT], Sep 22, 2008
    #13
  14. Greg

    Greg Guest

    I had previously checked the Set Program Access and Defaults and it was set
    to use WMP as my player. On a hunch, I chose the custom radio button, and
    forced in WMP again. Voila! It now streams .asx files. So apparently,
    seeing isn't necessarily believing.

    Thank you very much!

    Greg
     
    Greg, Sep 23, 2008
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.