WMP11, XP, Iomega NAS, DLNA Sony

Discussion in 'Windows Media Player' started by Pendy, Sep 23, 2009.

  1. Pendy

    Pendy Guest

    Hi,
    Can someone advise me if WMP11 can share photos that are on a NAS to a DLNA
    compliant Sony LCD? I can use the files and folders on my NAS in WMP11
    locally using media sharing. When I go to my TV to view the photos located on
    the WMP11 server, I can't see the anything from the NAS. Do you know if WMP11
    will share a NAS folder to a DLNA client and act as a "middle man"? I don't
    understand why WMP11 can utilize all the folders and files on the NAS locally
    but can't provide them via DLNA to the TV. The TV recognizes the WMP11 server
    (and local photos) and the NAS DLNA server (twonky) when I enable DLNA on it.
    The reason I am trying to get the NAS photos to work by going through WMP11
    is that there is some reason why the NAS and TV don't communicate properly. I
    don't know if this is a Sony problem or Iomega. I downloaded and tried Twonky
    Media Mangager and it was capable of showing everything, but is a trial.
    Ideally I eventually would like to get the TV and Iomega working nicely but
    for now I am trying this. Any ideas?????
     
    Pendy, Sep 23, 2009
    #1
    1. Advertisements

  2. Pendy

    Vincent Guest

    A device supporting DNLA is one thing. DNLA certification is another.
    My experience is that a lot of these DNLA implementations on a NAS don’t
    work properly including an Iomega NAS I owned a couple of years ago

    I expect:

    WMP and NAS both using media sharing:
    WMP will show 2 different libraries, one of its own and another on the NAS
    WMP will broadcast only its own library

    You might try
    WMP with file sharing to the media on the NAS
    Now the content on the NAS will become part of the WMP library and displayed
    on the TV
     
    Vincent, Sep 24, 2009
    #2
    1. Advertisements

  3. Pendy

    Pendy Guest

    Vincent,
    First, thank you for taking the time to reply to my question. I am a bit
    confused about your comment regarding "WMP with file sharing to the media on
    the NAS". My current setup on WMP11 is set for sharing. I have also linked
    the folders on the NAS to the library on WMP. I currently can view all NAS
    folders (music, photos, videos) in WMP on the laptop, but I can not view them
    on the TV. I can only view the laptop's pics on the TV (music doesn't stream
    to my TV. This is an inherant inability of the Sony DLNA software - it can
    only stream pictures). The folder from the NAS does not even show up on the
    TV as an available option. Is there some way to make this available? If so,
    can you explain how to do this in WMP11?
    Thank you for your time and pardon my ignorance in this topic.
     
    Pendy, Sep 24, 2009
    #3
  4. Pendy

    Vincent Guest

    Sharing:
    There are 2 options
    Media sharing= UPnP/DLNA sharing using the UPnP protocol (Share my Media)
    File sharing: adding a path to the monitored folders

    If I understand you correctly you added the files on the NAS to the
    monitored folders (file sharing) so they show up as a integral part of WMP’s
    library.
    In this case one expect them to be shown on the TV as well
    I know there are a couple of knowledge base articles in the Microsoft
    website about this as there is a problem with (media) sharing fileslocated on
    external devices (access rights)
    I’m afraid I can’t supply a direct link.
    You must be British
     
    Vincent, Sep 24, 2009
    #4
  5. Pendy

    rak Guest

    I don't have an NAS drive or a Sony, but do have a Pioneer 151 that is DLNA
    certified and stream media to it from a Media Center PC through a router
    connected by ethernet cable to the TV. A few things I would check. First -
    format. Is what is on the NAS supported by the TV? Second, sharing. What
    "controls" the NAS? Does this pc see the TV? Is it set to share media to
    the TV?
     
    rak, Sep 24, 2009
    #5
  6. Pendy

    Pendy Guest

    I was afraid the answer would not be as simple as clicking an unchecked box
    here or there. I have searched extensively through A/V forums, etc. but can't
    find out how to fix this. I would think that as these complex setups (NAS,
    laptop, desktop, DLNA TV, etc) become more common-place that more people will
    be running into problems such as this. The strange part of this is the free
    Twonky Media Manager works just like I want WMP to work, but I don't know
    why. I will continue the quest for an answer. I browsed to the link you
    provided a few days ago from a previous post of yours. It didn't help to
    solve my problem. Wasn't the whole point of DLNA to make things "talk" to
    each other effortlessly? Ha, Ha.
    Thank you for you advice.

    BTW, I am not British, just a polite American.
     
    Pendy, Sep 24, 2009
    #6
  7. Pendy

    Vincent Guest

    Twonkey is a very mature implementation of UPnP
    laptop, desktop, DLNA TV, etc) become more common-place that more people
    will be running into problems such as this<<

    They will, the moment they try it….

    IMHO, the concept behind UPnP is good, at the present the implementation in
    a lot of products is a little feeble
     
    Vincent, Sep 24, 2009
    #7
  8. Pendy

    Pendy Guest

    Thanks for responding. The TV can only recognize .jpg format pictures via
    DLNA. This is what I am trying to get the NAS to serve to the TV. When I
    first bought the NAS (Iomega Home Media Network Hard Drive 1tb), I connected
    to my router, installed the software included on my computers and loaded my
    media to it. The NAS runs some scaled down, unaccessable verision of twonky.
    I enabled DLNA sharing in the pictures folder and the TV found the NAS when I
    told it to look. When I went to view the pics, some folders show up with a
    few pictures (no thumbnails show up) in each and I can only view about 10 out
    of like 4000. All album art shows up from my music folder however. So I gave
    up on that setup for now and enabled media sharing in WMP11 (XP!!), added the
    NAS folders to my library and was successful in viewing pics, playing .mp3's,
    etc. on the local computer. The TV was added to WMP shared devices and it can
    see my laptop as WMP. The TV can only see the folders on the local hard drive
    on the laptop, the NAS folders do not show up on the TV at all. Like I
    mentioned to Vincent, Twonky Media Manager (free for 30 days, tick...tick...)
    works perfect for all NAS and local folders, running off my laptop. Should I
    be happy with this setup and quit while I have something working or press on
    for a reason why WMP can't do this? I hate to quit when I think something
    should work. Any ideas???
     
    Pendy, Sep 25, 2009
    #8
  9. Pendy

    Vincent Guest

    Vincent, Sep 25, 2009
    #9
  10. Pendy

    Vincent Guest

    As the NAS is running Twonky try
    http://IPNas:9000/webbrowse

    If this works, you can inspect what Twonky on the NAS is publishing

    http://IPNas:9000 is the configuration page of Twonky
    If it is blocked, you need Telnet access on the NAS to change it's
    configuration file
    Change enableweb=0 into enableweb=2
     
    Vincent, Sep 25, 2009
    #10
  11. Pendy

    Pendy Guest

    Here is the "funny" part. After I hooked up the NAS to my router, loaded the
    included Iomega software on each client computer and upgraded the NAS
    firmware. After the upgrade, I can no longer access the webbrowse :9000. I
    receive a "Access is restricted to server configuration" message in the
    browser. I can only access the NAS settings via Iomega's software (loaded on
    each computer). I can only make limited changes as a result. This "problem"
    pertaining to web access is all over the posts on the Iomega forum.
    Apparently Iomega intended to do this. Why? I don't know. As my computer
    knowledge is self taught and limited, I will research Telnet access and see
    what I can find out and how to do what you are asking me to try. I also
    printed the article you referenced in your previous reply and will give the
    security settings a look. As I am at work doing this, I will have to wait
    until tonight to try these suggestions. Please continue to reply if you think
    of anything else.
    Thanks again.
     
    Pendy, Sep 25, 2009
    #11
  12. Pendy

    Vincent Guest

    After the upgrade, I can no longer access the webbrowse :9000. I
    receive a "Access is restricted to server configuration" message in the
    browser.<<<<

    Just to make sure, this is the error you get when trying to access the
    Twonky configuration page as it is listening by default to :9000
    In general this is locked to avoid conflicts between the NAS GUI/settings
    and Twonky

    Most of the time IPnas:9000/webbrowse/ works as it is a read only (browsing)
    interface.

    In 2007 I had a Iomega.
    To much problems with the UPnP, unable to get Telnet access, unable to
    browse directories if more than a couple of files in it, etc.
    I sold the unit and bought a Qnap.
    I'm still using it today
    It runs Twonky but using the Qnap interface you can simply get access to the
    Twonky interface and configure it.
     
    Vincent, Sep 25, 2009
    #12
  13. Pendy

    Pendy Guest

    I have not tried accessing the :9000/webbrowse, only :9000. I will also try
    that. If it does work and I can inspect what twonky the NAS is publishing,
    what should I do then? I know a lot of Iomega owners were put off by the loss
    of access to the NAS via this method, so hopefully with the next firmware
    upgrade, we get access back. There is a list of requests to be included with
    the next firmware update on the Iomega forum about 30 items deep and
    counting. I should have researched more about this drive prior to purchase. I
    was sucked in by the price per gb. I must say however that I have had no
    problems with accessing the files stored on the NAS on my computers. It is
    just this one function I am having trouble with (DLNA...it's the future.
    Right???? Not if this is the way it will be).
     
    Pendy, Sep 25, 2009
    #13
  14. Pendy

    Vincent Guest

    I should have researched more about this drive prior to purchase
    That is excatly what I said to myself in 2007 after buying a Iomega.
    Best is to check user forum's first.

    Yes but we talk UPnP 1.5 or so.
    The concept is right
    It is supported by almost any major manufacturer of consumer electronics
    But it will need some time to get mature.
    I do then?

    If everything is in place in the browser interface it is a indication that
    Twonky on the NAS at least is able to scan and publish your entire collection
    on the NAS.
    If the TV is not able to see part of it you might check things like file
    formats, the numer of items in a folder, etc.
    The problem is to isolate the problem.
     
    Vincent, Sep 25, 2009
    #14
  15. Pendy

    Pendy Guest

    Update:
    WMP11 is fully functional with the TV. Upon attempting various things in the
    referenced article you mentioned, it now forwards the folders on the NAS to
    the TV. I "enabled remote content sharing" in the registry of the laptop. I
    am also going to attempt this on my desktop to see if that will work (the
    desktop has other sharing issues - a story for another forum). I also checked
    my firewall settings (both windows and norton) but they were OK. I also went
    into the NAS folders to check each type of file. I had 3 .avi files mixed
    into the .jpg folders. I removed them. I can now see many more pictures on
    the TV from the NAS via DLNA but this is still in need of improvement. I have
    some other types of picture files to remove from the folders to see if that
    does the trick. I was able to access the NAS twonky server per your
    :9000/webbrowse suggestion. It is running Twonkyvision GmbH (TwonkyMedia
    Model 4.4 (no further version number). Interestingly I could use the browser
    as a viewer of pictures (this is how I saw some video files were mixed in).
    Anyway, I will continue to work on the NAS - TV direct delivery of pictures
    over the weekend, but for today, WMP is fully functional. Thanks for your
    help.

    P.S., what is the difference between quicktime pictures and the .jpeg or
    ..jpg format? Does WMP convert quicktime to .jpg?
     
    Pendy, Sep 26, 2009
    #15
  16. Pendy

    Vincent Guest

    Good to hear everything is working more or less

    Quicktime is one of the formats supported by WMP. It doesn't convert, it has
    a CODEC to interpreted the content
    http://support.microsoft.com/default.aspx/kb/316992

    Try finding a user forum for your TV, wouldn't be surprised if the TV is
    causing the problem

    Thanks for the update

    Succes

    Vincent
     
    Vincent, Sep 26, 2009
    #16
  17. Pendy

    rak Guest

    I've been following this one with interest. Helpful for me too. Sounds as
    if you have figured this part out already, but maybe highlighting it will
    help someone else. One thing I found on my Pioneer is that even one
    unsupported file in a folder causes (in my case) an "unable to acquire list"
    error and will prevent the entire folder from being viewed.
     
    rak, Sep 26, 2009
    #17
  18. Pendy

    Pendy Guest

    Vincent was a real help. I am glad this post has possibly helped you. I
    figured that I can't be the only one out there with a problem like this. I am
    going to troubleshoot the unviewable NAS DLNA folders tomorrow. I may need to
    convert quicktime pics to .jpeg or .jpg (same?) if that is even possible or
    worthwhile. With each step comes another hurdle, until the race is over. I
    keep needing to research as I go but that is how we learn. I was able to
    enjoy a nice slideshow with my family tonight before the kids went to bed.
    Now if I can get the laptop out of the loop. Maybe tomorrow. Giant leap
    today. Back to baby steps tomorrow.
     
    Pendy, Sep 27, 2009
    #18
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.