WMplayer inside browser and relative paths including ".."

Discussion in 'Windows Media Player' started by Antonio Lopez Arredondo, Nov 21, 2003.

  1. Hi all !!!

    I am trying to show some WMV files inside the Internet Explorer. it works
    fine until I use paths that include ".." to specify where the WMV file is
    located.

    for example, the code below it will work fine if I substitute FILENAMEHERE
    with any of the following:
    FILENAMEHERE = "C:\absolute\path\to\video\take1.wmv"

    FILENAMEHERE = "video\take1.wmv"

    but it will do nothing if I use:
    FILENAMEHERE = "..\video\take1.wmv"

    any help on this will be greatly appreciated.
    regards,
    ant


    <html>
    <body>
    <OBJECT id='mediaPlayer'
    classid='CLSID:22d6f312-b0f6-11d0-94ab-0080c74c7e95'

    codebase='http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.
    cab#Version=5,1,52,701'
    standby=downloading...' type='application/x-oleobject'>
    <param name='fileName' value=FILENAMEHERE>
    <param name='animationatStart' value='true'>
    <param name='transparentatStart' value='true'>
    <param name='autoStart' value="true">
    <param name='showControls' value="true">
    <param name='loop' value="true">
    </OBJECT>
    </body>
    </html>
     
    Antonio Lopez Arredondo, Nov 21, 2003
    #1
    1. Advertisements

  2. Antonio Lopez Arredondo

    zachd [ms] Guest

    Yes, that's correct. You cannot use "..". This is a security feature. :)

    -Zach
     
    zachd [ms], Nov 22, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.