wmpnetwk.exe and CPU usage

Discussion in 'Windows Media Player' started by cwcXBOX360, Jan 27, 2007.

  1. cwcXBOX360

    cwcXBOX360 Guest

    I have WMP 11 installed (version 11.0.5721.5145) and have attempted to turn
    media sharing on in order to stream video to an XBOX 360. As soon as I turn
    media sharing on, wmpnetwk.exe shows up and grabs nearly 100% CPU usage and
    never releases it. I am unable to change it's processing priority on Task
    Manager.

    So basically, I am unable to use my XBOX 360's as Media Center Extenders
    since it requires the use of WMP 11 with Media Share turned on.

    Has anyone else experienced this? Any suggestions?
     
    cwcXBOX360, Jan 27, 2007
    #1
    1. Advertisements


  2. Could be a firewall interacting badly with the service. Did you allow
    access for WMP11 and the wmpnetwk.exe process in your firewall ?

    Cheers - Neil
     
    Neil Smith [MVP Digital Media], Jan 29, 2007
    #2
    1. Advertisements

  3. cwcXBOX360

    cwcXBOX360 Guest

    When Media Sharing is enabled in WMP11, it dynamically makes changes to the
    firewall on my computer. The XBOX360 is on the same LAN segment, so there is
    not a need to open anything on my external firewall.

    Is there something else that I am missing in your question?

    Have you had anything similar happen?

    Thanks.
     
    cwcXBOX360, Jan 29, 2007
    #3
  4. OK well I've not heard of this dynamic reconfiguration of firewalls as
    being part of WMP - though I haven't checked. To confirm, the
    following settings should be in place on that firewall :

    http://www.microsoft.com/windows/windowsmedia/player/faq/sharing.mspx#q20_7

    Try to pay particular attention to the settings required for the
    wmpnetwk.exe process.

    Another avenue to check is that IPSEC should be disabled on your PC
    for the sharing to work reliably (assuming you don't use a VPN to work
    computers) and I believe "internet connection sharing" shouldn't be in
    use either :
    http://www.microsoft.com/windows/windowsmedia/player/faq/sharing.mspx#q20_6

    If you have a Linksys BEFSR41v4 router, go to the Security settings
    for that, and enable Multicast routing. It's been implicated in some
    issues with the X360, see http://tinyurl.com/2c6azx


    HTH
    CHeers - Neil
     
    Neil Smith [MVP Digital Media], Jan 30, 2007
    #4
  5. cwcXBOX360

    cwcXBOX360 Guest

    Thank you for all of your suggestions. I tried adding the ports manually to
    the firewall (McAfee) on my PC, but no change. I then turned the firewall
    off completely, but still no affect. I can run WMP 11 without any problem,
    but as soon as I turn Media Sharing on, WMP takes 99% of my CPU and does not
    let it go. If I close WMP11, then wmpnetwk.exe takes over hogging the CPU.
    As soon as I turn media sharing off, it goes back to normal. This is really
    frustrating and I am not sure where to turn to for help.

    Any suggestions?

    Thanks, Clint
     
    cwcXBOX360, Feb 1, 2007
    #5
  6. No I can't think of anything else, I don't know what your router is
    (and so if there are any reported problems with that) or anything
    about IPSEC. So far we've discussed mostly generalities, and as I
    don't have a X360 to try this out with, short of detailed network info
    I'm stumped.

    Cheers - Neil

     
    Neil Smith [MVP Digital Media], Feb 1, 2007
    #6
  7. cwcXBOX360

    SteelDog Guest

    Your not alone. Lot's of people are experiencing the high CPU usage. I
    tried everthing I can think of and only 1 thing worked. Revert back to WMP
    10. As soon as switched back to WMP 10 all my problem went away.

    There is something very buggy and wrong with WMP 11. Look at all the
    threads of people with CPU usage issues with WMP 11.
     
    SteelDog, Feb 27, 2007
    #7
  8. cwcXBOX360

    zachd [MSFT] Guest

    When did this start happening?
     
    zachd [MSFT], Feb 28, 2007
    #8
  9. cwcXBOX360

    SteelDog Guest

    For me, it started the second I installed WMP11. Prior to installing, I used
    WMP10 and Windows Media Connect 2 for sharing. Everything was fine.
    However, I wanted to use WMP11. I installed it and notice my PC started
    crawling. My CPU utilization was a solid 50% and showed wmpnetwk.exe as the
    culprite.

    When I shut down that service, the CPU utilization went down to 0%. Tried
    everything suggested on other forums (people have been having the same
    issue). Rolled back to WMP10 and the problem went away. Tried installing
    WMP11 again and again the problem returned. Rolled back again and the
    problem went away.
     
    SteelDog, Feb 28, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.