Wow and Vista

Discussion in 'Windows Vista Games' started by Dazgt, Jun 21, 2007.

  1. Dazgt

    Dazgt Guest

    When I play wow the sound is distorted and cracky. I have vista ultimate,
    amd 64 3000, geforce fx 5600 256 agp, 1 gig ram and 30 gigs free on my hd.
    Anyone else having this problem or have a fix for it? This could keep me
    from playing the game anymore it is extremely annoying. I have tried a view
    different settings on wow but still have not found the right one. Any
    suggestions???

    Thanks,

    Darrell
     
    Dazgt, Jun 21, 2007
    #1
    1. Advertisements

  2. Dazgt

    Brett Guest

    I had the very same problem. Sounds in WoW would get so choppy and bad I
    couldn't stand it. You didn't say what Sound Card you are using. I am
    using the Creative X-Fi Fatal1ty.

    Try Creative ALchemy. It totally solved my problems and WoW sounds
    wonderful again. Hope this helps. Good luck

    http://preview.creativelabs.com/alchemy/default.aspx
     
    Brett, Jun 21, 2007
    #2
    1. Advertisements

  3. Dazgt

    Dazgt Guest

    Brett,

    Thanks for the info, I found a solution yesterday that works though. Go to
    video options and disable vsink. This game played perfectly in xp for me
    just started getting that problem in vista.
     
    Dazgt, Jun 21, 2007
    #3
  4. Dazgt

    Andy Guest

    You still want to install the OpenAL drivers for your Creative sound card
    Dazgt. (AKA Creative ALchemy)
    It'll [hopefully] prevent other issues down the line, that way you can turn
    on VSync again to get rid of all that "tearing".
     
    Andy, Jun 21, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.