WS08 networking services blocking internet, eating 50% CPU

Discussion in 'Server Networking' started by a.k.a., Mar 22, 2009.

  1. a.k.a.

    a.k.a. Guest

    Hello everyone,

    Your help will be very valuable right now. I'm running WS 2008 x64 as a
    laptop OS on a Lenovo ThinkPad T61p. I'm still very much a learner, so
    please break the troubleshooting down into simple walkthroughs if you can.

    As soon as I flip on the physical WiFi / BT radio switch, a svchost process
    loads that eats 50% of the CPU, and blocks IE8 from connecting to the
    internet, even after I've connected to a WiFi router. I have to kill the
    svchost process in Task Manager for IE to connect (and it does so instantly).
    Usually, after killing it, the svchost vanishes after that, although it may
    pop up again for about 1 minute.

    The services running under it are:
    Windows Remote Management (WinRM)
    Terminal Services (TermService)
    Network Locatoin Awareness (NlaSvc)
    KtmRm for Distributed Transaction Coordinator )(KtmRm)
    DNS Client (Dnscache)
    Cryptographic Services (SryptSvc)

    I hesitate to mention anything in particular that might be associated with
    this, as I have no idea what is going on, and would rather not prejudice your
    diagnoses. Still, here are some other details, which may or may not be red
    herrings -- mainly I'm curious whether something needs re-setting.

    1. I recently tried to establish an Ad Hoc wi-fi connection with a friend's
    laptop, which didn't work. (Just curious if there's a reset I haven't done.)

    2. I succeeded in connecting via Ethernet. Sharing is now off, although
    could it be that the user's login is still active on this machine?

    3. I wonder whether the ThinkPad WiFi networking utility (Access
    Connections) is in conflict with Windows Networking or the Intel networking
    drivers.

    4. I have uninstalled some 3rd party programs I thought might be
    contributing to the problem, but the problem remains.

    Thanks for your help.

    a.k.a.
     
    a.k.a., Mar 22, 2009
    #1
    1. Advertisements

  2. a.k.a.

    a.k.a. Guest

    I also tried turning off Microsoft Update, and that did not stop the svchost
    from reappearing on restart. All of these are running under PID 1276.
     
    a.k.a., Mar 23, 2009
    #2
    1. Advertisements

  3. a.k.a.

    a.k.a. Guest

    I also discovered, BTW, that file sharing seems to be set automatically to
    ON when connecting to a WiFi network. (I checked the current network status
    and found it was set to on, though I had no intention of doing so.) What
    master setting might I have changed that I need to undo?

    Yet even after turning off file sharing manually for my current WiFi
    network, it doesn't stop the svchost from running.
     
    a.k.a., Mar 23, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.