wshtcpip.dll file damaged and can not connect to internet

Discussion in 'Windows Vista Performance' started by Tsulliv1, Sep 14, 2007.

  1. Tsulliv1

    Tsulliv1 Guest

    My girlfriend recently bought a dell inspiron 1520 laptop and it worked great
    for the first couple weeks. However, Monday when she started the computer up
    it gave her the error message "GoogleDesktop.exe - Bad Image -
    C:\windows\system32\wshtcpip.dll is either not designed to run on Windows or
    contains an error. Try installing..." Once closed, the same message came up
    but for SiteAdv.exe (McAfee's Site Advisor). Additionally, the computer
    would connect to the wireless network, but get a local connection only; no
    internet.

    Unistalling Google Desktop, and uninstalling/reinstalling McAfee made the
    error messages go away, but did not solve the internet issue. I have reset
    my modem and router several times and the internet works perfectly on our
    other laptop and our old desktop. The internet does not work even if the new
    Vista laptop is plugged directly into the modem. While trying to fix the
    problem, I tried to ping microsoft.com in the command prompt and got a bad
    image error again.

    I tried running the StartUp Repair, but it keeps telling me to remove all
    USB devices and memory cards even when none are plugged in. What else can I
    do to solve this problem? Am I right in assuming that the damaged dll file
    and my internet problem are connected (the name of the dll file and from what
    little I have read about this file seems to suggest they are)? I greatly
    appreciate any advice!
     
    Tsulliv1, Sep 14, 2007
    #1
    1. Advertisements

  2. Tsulliv1

    dean-dean Guest

    The file wshtcpip.dll is the Winsock2 Helper DLL.

    You could see if the file is damaged by running the following command (by
    right-clicking on the Command Prompt shortcut in Start
    Menu\Programs\Accessories, and choosing Run as Administrator). Copy and
    then Paste this at the prompt:

    sfc /SCANFILE="C:\Windows\System32\wshtcpip.dll"

    Press Enter on your keyboard. What does Windows Resource Protection report?

    If you want check all your system files, Copy the following, and Paste it
    after the prompt:

    sfc /scannow

    Press Enter. It will scan all your system files. It may take a few
    minutes. If things are okay, you are given the text message "Windows
    Resource Protection did not find any integrity violations". If things
    aren't okay, it will attempt to replace the bad system files.
     
    dean-dean, Sep 14, 2007
    #2
    1. Advertisements

  3. Tsulliv1

    Tsulliv1 Guest

    Thanks! That fixed everthing!

     
    Tsulliv1, Sep 16, 2007
    #3
  4. Hi there

    Did you get any answers to this? I have EXACTLY the same problem
    except its an HP (Dell in drag). Of course I can't download anything t
    fix it given that I can't connect

    What did you do? Anyone have any advice

    Thanks
    Jennife
     
    crackerjack61, May 16, 2008
    #4
  5. Hey - I just saw the response to the original email. Yay - thanks. Bu
    what is the command prompt shortcut? LOL. Do I need to use the "run
    command? I can't find it on the start button and can't find men
    either.

    Guess I'm computer silly. Help?

    Thanks,
    Jennife
     
    crackerjack61, May 16, 2008
    #5
  6. Okay found the run command - had to add it. Now it says I must be a
    administrator. And its MY computer. Any ideas for that
     
    crackerjack61, May 16, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.