WSUS asking for username and password.

Discussion in 'Update Services' started by purtech, Jun 30, 2006.

  1. purtech

    purtech Guest

    I have SBS 2003 Premium.

    I added my own generated Certificate to the Default web site. (I was working
    on RPC over HTTP/S).

    Last night the system gave a me:

    Application Log errors monitor : event received. Critical condition.
    Log: Application
    ID: 506
    Type: Error
    Source: Windows Server Update Services
    The SelfUpdate Tree is not working. Clients may not be able to update to
    the latest WUA client software and communicate with the WSUS Server.

    I know this is because of the certificate. I have removed the certificate.
    (It is not crticial at the moment I have it.) But still WSUS asks for
    Username and Password.

    I would like to get this working again - then I will work on adding Certs
    correctly to WSUS after. Default site has Anonymous and Integrated Directory
    permissions. WSUS site has the same.

    Why is it asking for username and password and how do I stop it? It did not
    before adding the Cert.
     
    purtech, Jun 30, 2006
    #1
    1. Advertisements

  2. purtech

    Ken Guest

    I think you need to add the WSUS admin page back to the trusted sites.

    If you have Internet Explorer hardening (also known as the Microsoft Windows
    Server 2003 Internet Explorer Enhanced Security Configuration component)
    enabled on a computer and you do not add the WSUS console to the Trusted
    sites and Local intranet Web content zones, you will be prompted for user
    credentials every time you open a page in the WSUS console.

    To add the WSUS console to the Local intranet and Trusted sites Web content
    zones:

    Open Internet Options (for example, click Start, point to Control Panel, and
    then click Internet Options).


    On the Security tab, click Local intranet, click Sites, click Advanced, add
    the URL (http://WSUSServername/WSUSAdmin), and then click OK.


    Click Trusted sites, click Sites, add the WSUS console URL, click OK, and
    then click OK again to exit Internet Options.
     
    Ken, Jun 30, 2006
    #2
    1. Advertisements

  3. This is caused because Windows Sharepoint Services (installed by default on
    SBS2003), removed anonymous access permissions from the Default Web Site.

    Restore the anonymous access permissions to the Default Web Site.

    Also, you will need to exclude certain WSUS resources from Sharepoint
    management.
    See How do I make WSUS work on my Sharepoint server?
    at http://wsusinfo.onsitechsolutions.com/articles/013.htm
    for additional information on configuring WSUS with Sharepoint (on SBS2003).

    --
    Lawrence Garvin, M.S., MVP-Software Distribution
    Everything you need for WSUS is at
    http://technet2.microsoft.com/windowsserver/en/technologies/featured/wsus/default.mspx
    And, eveything else is at
    http://wsusinfo.onsitechsolutions.com
    ....
     
    Lawrence Garvin \(MVP\), Jul 1, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.