WSUS console error: MMC could not create the snap-in.

Discussion in 'Windows Server' started by mct, Jan 20, 2009.

  1. mct

    mct Guest

    WSUS mysteriously stopped letting me into the MMC console for it this week.
    When I run the console it says:
    MMC could not create the snap-in. The snap-in might not have been installed
    correctly.
    Name: Update Services
    CLSID: FX:{8b6499ed-0241-e032-6508-da4b1c879d7e}

    OS is Server Standard 2003 SP2, fully patched, with WSUS 3.0 SP1. WSUS
    itself actually seems to be working. The server is a secondary domain
    controller. We have SQL 2005 in mixed mode running a LOB database, but it's
    been running fine for nearly a year.
    Rebooting doesn't help. I uninstalled and reinstalled WSUS and it still
    doesn't work. I've tried looking for MMC cache files in
    %USERPROFILE%\Application Data\Microsoft\MMC and deleting them, but still no
    luck. No errors are thrown into the event logs.
    I'm completely stuck at this point. Does anyone know what's going on or what
    I can do to troubleshoot this further?
     
    mct, Jan 20, 2009
    #1
    1. Advertisements

  2. WSUS mysteriously stopped letting me into the MMC console for it this week.
    WSUS 3.0 SP1? Not sure if it'll help but give
    http://support.microsoft.com/kb/940848 a shot.

    - Thee Chicago Wolf
     
    Thee Chicago Wolf, Jan 20, 2009
    #2
    1. Advertisements

  3. Access to your users profile folder (c:\Users) and inside this path
    AppData\Roaming\Microsoft\MMC you'll the a file named "wsus". Delete it, and
    check if you can now open the console.

    If still have no luck, check on EventViewer on "Security", are there any
    failure audits for your SQL Server DB?

    Cheers

    --

    augusto alvarez | it professional
    MCP - MCTS - MCITP DBA
    http://blog.augustoalvarez.com.ar/


    ""
     
    Augusto Alvarez, Jan 20, 2009
    #3
  4. mct

    mct Guest

    I did a search of the entire Documents and Settings folder for anything with
    "wsus" in the filename, and whatever I found I deleted. It still didn't fix
    it.
    I also tried opening mmc directly out of the run menu and adding the Update
    Services snap in manually, but it immediately popped up a box with the same
    error.
    Nope. Nothing gets put in the event viewer at all when I try to add or open
    the snap in. If I restart the services I get the usual WSUS startup messages,
    but they say that WSUS is working properly.
     
    mct, Jan 21, 2009
    #4
  5. Dusko Savatovic, Jan 21, 2009
    #5
  6. mct

    Fabio Guest

    Fabio, Mar 5, 2009
    #6
  7. mct

    mct Guest

    Thanks for the reply, but reregistering the most recent msxml3 files didn't
    help the situation.
    It's still a problem. I'm currently in a discussion with the LOB software
    company about it. There's a chance that their software installed/registered
    older or otherwise incompatible libraries, but this one wasn't it.
     
    mct, Mar 6, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.