WSUS not downloading updates that are needed for client updates

Discussion in 'Update Services' started by Collin, Jan 9, 2006.

  1. Collin

    Collin Guest

    I have WSUS set up on Win 2003 SBS Premium with out SP1.
    This was a migration from SUS, I never did get SUS to work and update
    clients. I have followed all WSUS instructions for 2003 SBS, everything
    seems to be working fine except the downloading of updates from the MS
    update
    server does not download the updates. I have the following settings in
    place:

    1. WSUS Computers Group Policy is set as follows: -Computer Configuration

    -Administrative Templates

    -Windows Components

    -Windows Update

    -Configure Automatic Updates- Auto download and schedule the install
    Day - Every Wednesday
    Time - 00:00

    -Specify intranet Microsoft update service location- Set the intranet
    update service for detecting updates: http://Servername:8530/selfupdate

    Set the intranet statistics server: http://Servername:8530/selfupdate


    -Enable client-side targeting- Target group name for this computer:
    Servername Computers


    -Automatic Updates detection frequency: interval (hours): 1
    (I have set this to 1hr to be sure that the clients were being detected
    by the WSUS server rather than waiting 22hrs.)


    -Allow Automatic Updates immediate installation- Enabled


    -Allow non-administrators to receive update notifications- Enabled


    The clients are showing the above WSUS Group Policy being accepted under the
    client gpedit.msc console

    Under the WSUS Computers Site page all clients are Reporting in, and showing
    the updates that are needed under the Status Column
    and under the Approval Column it shows the needed updates set to install.
    The WSUS Updates page shows the needed updates with green arrows and
    Stating: The Update is Downloading.
    But when I go to the Home page of the WSUS site and click on Synchronize Now
    it shows the following each time:
    Current status: percentage always shows 0% and Downloading 0.00 MB of
    4,744.01 MB never changes.
    The Last synchronization: Date & Time is updated to the current Date & Time
    each time I Sync, and under Last synchronization result: Success is shown
    each time.


    Synchronization Status

    Last synchronization: 1/9/2006 1:21 PM
    Last synchronization result: Success
    Next synchronization: 1/9/2006 8:23 PM
    Current status: Running (0%)

    Status of Downloads
    Updates needing Files: 403
    Downloading 0.00 MB of 4,744.01 MB

    The proxy server Settings are set with the Server Name and Port:8080 the
    server name and Port are the same ones used in IE during client setup
    Wizard.
    Maybe these are incorrect, and user credentials to connect to the proxy
    server are set with
    User name: Administrator user name
    Domain: Domain name
    Password: user password

    Allow basic Authentication (password is sent in clear text) is unchecked.
    Update source: Synchronize from Microsoft Update

    Any ideas or resources greatly appreciated!!!!!!

    Thanks,

    Collin
     
    Collin, Jan 9, 2006
    #1
    1. Advertisements

  2. Collin

    Collin Guest

    2006-01-09 17:39:45 1908 7c0 Misc WARNING: SendRequest failed with hr =
    80072efd. Proxy List used: <Servername:8080> Bypass List used : <<local>>
    Auth Schemes used : <>

    2006-01-09 17:39:45 1908 7c0 PT + Last proxy send request failed with hr =
    0x80072EFD, HTTP status code = 0

    2006-01-09 17:39:45 1908 7c0 PT + Caller provided proxy = No

    2006-01-09 17:39:45 1908 7c0 PT + Proxy list used = Servername:8080

    2006-01-09 17:39:45 1908 7c0 PT + Bypass list used = <local>

    2006-01-09 17:39:45 1908 7c0 PT + Caller provided credentials = No

    2006-01-09 17:39:45 1908 7c0 PT + Impersonate flags = 0

    2006-01-09 17:39:45 1908 7c0 PT + Possible authorization schemes used =

    2006-01-09 17:39:45 1908 7c0 PT WARNING: GetConfig failure, error =
    0x80072EFD, soap client error = 5, soap error code = 0, HTTP status code =
    200

    2006-01-09 17:39:45 1908 7c0 Report WARNING: Reporter failed to upload
    events with hr = 80072efd.
     
    Collin, Jan 9, 2006
    #2
    1. Advertisements

  3. These would be incorrect. They should be http://servername:8530
    That's interesting, considering they have an invalid URL specified for the
    location of the WSUS server. :)
    The WSUS server needs to be able to communicate on both HTTP (80) and HTTPS
    (443) simultaneously. If you're redirecting -all- comunications to the proxy
    server on port 8080, the proxy server may not be routing these
    communications correctly.

    Btw.. since WSUS is -on- the SBS2003 system.... why are you even using the
    proxy server? Bypass the proxy server completely. There's no functional
    reason why WSUS should tie up precious proxy server cache resources by
    storing updates in the cache. Nothing else will ever access those files via
    the proxy server cache.

    Create an outbound access rule for "Local Host" to permit access on HTTP
    (80) -and- HTTPS (443).

    Btw.. also... I would /strongly/ recommend installing Service Pack 1 and
    upgrading the ISA Server to ISA Server 2004.
     
    Lawrence Garvin \(MVP\), Jan 10, 2006
    #3
  4. The '0x80072efd' error is another indication that the proxy server is
    interfering, except in this case, it's interfering with the client's access
    to the WSUS server.

    In the case of the SBS2003 server as a WSUS /client/, set the WinHTTP proxy
    configuration to -direct- (proxycfg -d), so that it can talk to itself,
    directly, on port 8530.
     
    Lawrence Garvin \(MVP\), Jan 10, 2006
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.