WU does not work, wuaueng.dll won't register anymore

Discussion in 'Update Services' started by Helmut Schneider, Aug 31, 2005.

  1. Hi,

    after the last patching day I restartet a certain server after patching. A
    few days later I was wondering that this server does not use WSUS anymore. I
    tried to stop wuauserv but it hangs in stopping state.
    So I tried to reinstall WU:

    net stop wuauserv
    regsvr32 wups.dll
    regsvr32 wuapi.dll
    regsvr32 wuaueng.dll
    regsvr32 oleaut32.dll
    regsvr32 jscript.dll
    regsvr32 vbscript.dll
    regsvr32 msxml.dll
    regsvr32 softpub.dll
    regsvr32 wintrust.dll
    regsvr32 initpki.dll
    regsvr32 cryptdlg.dll
    net start wuauserv

    "regsvr32 wuaueng.dll" hangs. Every command succeedes but wuaueng.dll does
    not. Even after waiting 30 minutes nothing happened. I also copied it from
    another machine without success.

    Any ideas?

    Thanks, Helmut
     
    Helmut Schneider, Aug 31, 2005
    #1
    1. Advertisements

  2. APC Software. Uninstalled and everything is fine again.
     
    Helmut Schneider, Oct 13, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.